summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/netcf
diff options
context:
space:
mode:
authorLi xin <lixin.fnst@cn.fujitsu.com>2015-08-07 14:55:07 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2015-08-07 10:59:39 -0400
commit77d17425b50997b0b356bcfc811a87472e5f4c47 (patch)
tree3efdbdfda294528aa99008d0e678bf819d46fb34 /meta-networking/recipes-support/netcf
parent465afbad994a10a21546e8f38b27d545b95d4f7f (diff)
downloadmeta-openembedded-77d17425b50997b0b356bcfc811a87472e5f4c47.tar.gz
netcf: upgrade 0.2.3 -> 0.2.8
add systemd support for netcf Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/netcf')
-rw-r--r--meta-networking/recipes-support/netcf/netcf_git.bb22
1 files changed, 17 insertions, 5 deletions
diff --git a/meta-networking/recipes-support/netcf/netcf_git.bb b/meta-networking/recipes-support/netcf/netcf_git.bb
index 0e88b304a..d47bb3b03 100644
--- a/meta-networking/recipes-support/netcf/netcf_git.bb
+++ b/meta-networking/recipes-support/netcf/netcf_git.bb
@@ -6,8 +6,8 @@ LICENSE = "LGPLv2.1"
6 6
7LIC_FILES_CHKSUM = "file://COPYING;md5=bbb461211a33b134d42ed5ee802b37ff" 7LIC_FILES_CHKSUM = "file://COPYING;md5=bbb461211a33b134d42ed5ee802b37ff"
8 8
9SRCREV = "b8a19dc860b38c97c42115d8a559b78853452a4b" 9SRCREV = "9158278ad35b46ce9a49b2e887483c6d8c287994"
10PV = "0.2.3+git${SRCPV}" 10PV = "0.2.8+git${SRCPV}"
11 11
12SRC_URI = "git://git.fedorahosted.org/netcf.git;protocol=git \ 12SRC_URI = "git://git.fedorahosted.org/netcf.git;protocol=git \
13" 13"
@@ -16,9 +16,13 @@ DEPENDS += "augeas libnl libxslt libxml2 gnulib"
16 16
17S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
18 18
19inherit gettext autotools-brokensep pkgconfig 19inherit gettext autotools-brokensep pkgconfig systemd
20 20
21EXTRA_OECONF_append_class-target = " --with-driver=redhat" 21EXTRA_OECONF_append_class-target = " --with-driver=redhat"
22
23PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "systemd", "systemd", "", d)}"
24PACKAGECONFIG[systemd] = "--with-sysinit=systemd,--with-sysinit=initscripts,"
25
22do_configure_prepend() { 26do_configure_prepend() {
23 cd ${S} 27 cd ${S}
24 rm -f .gitmodules 28 rm -f .gitmodules
@@ -26,6 +30,14 @@ do_configure_prepend() {
26} 30}
27 31
28do_install_append() { 32do_install_append() {
29 mv ${D}${sysconfdir}/rc.d/init.d/ ${D}${sysconfdir} 33 if ${@base_contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
30 rm -rf ${D}${sysconfdir}/rc.d/ 34 install -d ${D}${systemd_unitdir}/system
35 mv ${D}${libdir}/systemd/system/* ${D}${systemd_unitdir}/system/
36 rm -rf ${D}${libdir}/systemd/
37 else
38 mv ${D}${sysconfdir}/rc.d/init.d/ ${D}${sysconfdir}
39 rm -rf ${D}${sysconfdir}/rc.d/
40 fi
31} 41}
42
43SYSTEMD_SERVICE_${PN} = "netcf-transaction.service"