diff options
author | Khem Raj <raj.khem@gmail.com> | 2013-01-06 00:07:32 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2013-01-08 09:31:44 -0800 |
commit | 1db7387892476ff25576cf5ae37360405b60a8ae (patch) | |
tree | d066466a681ea9f2765b51627ecff0ec795f41d4 /meta-networking/recipes-support/ndisc6 | |
parent | 5d56edf7a7dc53f92e954fbf92238409c1e183e8 (diff) | |
download | meta-openembedded-1db7387892476ff25576cf5ae37360405b60a8ae.tar.gz |
ndisc6: Forward port recipe from OE classic
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/ndisc6')
-rw-r--r-- | meta-networking/recipes-support/ndisc6/ndisc6_1.0.2.bb | 62 |
1 files changed, 62 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/ndisc6/ndisc6_1.0.2.bb b/meta-networking/recipes-support/ndisc6/ndisc6_1.0.2.bb new file mode 100644 index 0000000000..3920c1a5a0 --- /dev/null +++ b/meta-networking/recipes-support/ndisc6/ndisc6_1.0.2.bb | |||
@@ -0,0 +1,62 @@ | |||
1 | SECTION = "console/network" | ||
2 | DESCRIPTION = "This package includes some useful diagnostics tools for \ | ||
3 | IPv6 networks, including ndisc6, rdisc6, tcptraceroute6 and traceroute6." | ||
4 | SECTION = "console/network" | ||
5 | HOMEPAGE = "http://www.remlab.net/ndisc6/" | ||
6 | LICENSE = "GPL-2.0" | ||
7 | |||
8 | # The tcptraceroute6 and tracert6 commands depend on rltraceroute6 to | ||
9 | # perform the actual trace operation. | ||
10 | RDEPENDS_${PN}-tcptraceroute6 = "${PN}-rltraceroute6" | ||
11 | RDEPENDS_${PN}-tracert6 = "${PN}-rltraceroute6" | ||
12 | |||
13 | SRC_URI = "http://www.remlab.net/files/ndisc6/ndisc6-${PV}.tar.bz2 \ | ||
14 | " | ||
15 | SRC_URI[md5sum] = "50cb4c19606cf6ff2b7388e71832f579" | ||
16 | SRC_URI[sha256sum] = "6acec8a0cb9efa3ac98456f46c3016aeec0598b0c7557c95242b5228ad62ca7a" | ||
17 | |||
18 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" | ||
19 | |||
20 | inherit autotools gettext | ||
21 | |||
22 | # Split into seperate packages since we normal don't want them all | ||
23 | # The main package is left empty and therefore not created. | ||
24 | PACKAGES += "${PN}-ndisc6 ${PN}-tcpspray6 ${PN}-rdisc6 \ | ||
25 | ${PN}-tcptraceroute6 ${PN}-rltraceroute6 \ | ||
26 | ${PN}-tracert6 ${PN}-rdnssd ${PN}-misc" | ||
27 | FILES_${PN} = "" | ||
28 | FILES_${PN}-ndisc6 = "${bindir}/ndisc6" | ||
29 | FILES_${PN}-tcpspray6 = "${bindir}/tcpspray6" | ||
30 | FILES_${PN}-rdisc6 = "${bindir}/rdisc6" | ||
31 | FILES_${PN}-tcptraceroute6 = "${bindir}/tcptraceroute6" | ||
32 | FILES_${PN}-rltraceroute6 = "${bindir}/rltraceroute6" | ||
33 | FILES_${PN}-tracert6 = "${bindir}/tracert6" | ||
34 | FILES_${PN}-rdnssd = "${sbindir}/rdnssd ${sysconfdir}/rdnssd" | ||
35 | FILES_${PN}-misc = "${bindir}/dnssort ${bindir}/name2addr ${bindir}/tcpspray ${bindir}/addr2name" | ||
36 | |||
37 | DESCRIPTION_${PN}-ndisc6 = "ICMPv6 Neighbor Discovery tool. \ | ||
38 | Performs IPv6 neighbor discovery in userland. Replaces arping from the \ | ||
39 | IPv4 world." | ||
40 | DESCRIPTION_${PN}-rdisc6 = "ICMPv6 Router Discovery tool. \ | ||
41 | Queries IPv6 routers on the network for advertised prefixes. Can be used \ | ||
42 | to detect rogue IPv6 routers, monitor legitimate IPv6 routers." | ||
43 | DESCRITPION_${PN}-tcpspray6 = "Performs bandwidth measurements of TCP \ | ||
44 | sessions between the local system and a remote echo server in either IPv6 \ | ||
45 | or IPv4." | ||
46 | |||
47 | DESCRITPION_${PN}-rdnssd = "Daemon to autoconfigure the list of DNS \ | ||
48 | servers through slateless IPv6 autoconfiguration." | ||
49 | |||
50 | do_install_append () { | ||
51 | rm -rf ${D}${localstatedir} | ||
52 | } | ||
53 | # Enable SUID bit for applications that need it | ||
54 | pkg_postinst_${PN}-rltraceroute6 () { | ||
55 | chmod 4555 ${bindir}/rltraceroute6 | ||
56 | } | ||
57 | pkg_postinst_${PN}-ndisc6 () { | ||
58 | chmod 4555 ${bindir}/ndisc6 | ||
59 | } | ||
60 | pkg_postinst_${PN}-rdisc6 () { | ||
61 | chmod 4555 ${bindir}/rdisc6 | ||
62 | } | ||