summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/memcached
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-04-12 11:52:30 -0700
committerKhem Raj <raj.khem@gmail.com>2022-04-13 19:21:41 -0700
commitffba3bbe131beaed10ac393b949c90b5af07bdbf (patch)
tree6e4ef0197085d29dd90badb220c87b5504836f28 /meta-networking/recipes-support/memcached
parent4cde452b197b09272131bff98c0c98f49267b9cc (diff)
downloadmeta-openembedded-ffba3bbe131beaed10ac393b949c90b5af07bdbf.tar.gz
memcached: Upgrade to 1.6.15
Drop upstreamed patch Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/memcached')
-rw-r--r--meta-networking/recipes-support/memcached/memcached/0002-stats_prefix.c-Check-for-NDEBUG-before-using-total_w.patch48
-rw-r--r--meta-networking/recipes-support/memcached/memcached_1.6.15.bb (renamed from meta-networking/recipes-support/memcached/memcached_1.6.9.bb)3
2 files changed, 1 insertions, 50 deletions
diff --git a/meta-networking/recipes-support/memcached/memcached/0002-stats_prefix.c-Check-for-NDEBUG-before-using-total_w.patch b/meta-networking/recipes-support/memcached/memcached/0002-stats_prefix.c-Check-for-NDEBUG-before-using-total_w.patch
deleted file mode 100644
index 2979552a3..000000000
--- a/meta-networking/recipes-support/memcached/memcached/0002-stats_prefix.c-Check-for-NDEBUG-before-using-total_w.patch
+++ /dev/null
@@ -1,48 +0,0 @@
1From d6294e9166e4875a0572349aabcc5e51acbd2e3c Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 4 Jun 2021 11:33:12 -0700
4Subject: [PATCH] stats_prefix.c: Check for NDEBUG before using total_written
5 variable
6
7When using NDEBUG assert macro is ineffective which is caught by latest
8clang and reports that total_written is set but unused. Therefore check
9for NDEBUG to make sure assert is used only when its effective
10
11Fixes
12error: variable 'total_written' set but not used [-Werror,-Wunused-but-set-variable]
13 size_t size = 0, written = 0, total_written = 0;
14 ^
15Upstream-Status: Submitted [https://github.com/memcached/memcached/pull/792]
16Signed-off-by: Khem Raj <raj.khem@gmail.com>
17---
18 stats_prefix.c | 8 ++++++--
19 1 file changed, 6 insertions(+), 2 deletions(-)
20
21diff --git a/stats_prefix.c b/stats_prefix.c
22index 62f0d04..d72e514 100644
23--- a/stats_prefix.c
24+++ b/stats_prefix.c
25@@ -127,8 +127,10 @@ char *stats_prefix_dump(int *length) {
26 PREFIX_STATS *pfs;
27 char *buf;
28 int i, pos;
29- size_t size = 0, written = 0, total_written = 0;
30-
31+ size_t size = 0, written = 0;
32+#ifndef NDEBUG
33+ size_t total_written = 0;
34+#endif
35 /*
36 * Figure out how big the buffer needs to be. This is the sum of the
37 * lengths of the prefixes themselves, plus the size of one copy of
38@@ -154,8 +156,10 @@ char *stats_prefix_dump(int *length) {
39 pfs->prefix, pfs->num_gets, pfs->num_hits,
40 pfs->num_sets, pfs->num_deletes);
41 pos += written;
42+#ifndef NDEBUG
43 total_written += written;
44 assert(total_written < size);
45+#endif
46 }
47 }
48
diff --git a/meta-networking/recipes-support/memcached/memcached_1.6.9.bb b/meta-networking/recipes-support/memcached/memcached_1.6.15.bb
index adf3c34e1..b28bfe72b 100644
--- a/meta-networking/recipes-support/memcached/memcached_1.6.9.bb
+++ b/meta-networking/recipes-support/memcached/memcached_1.6.15.bb
@@ -21,9 +21,8 @@ RDEPENDS:${PN} += "perl perl-module-posix perl-module-autoloader \
21 21
22SRC_URI = "http://www.memcached.org/files/${BP}.tar.gz \ 22SRC_URI = "http://www.memcached.org/files/${BP}.tar.gz \
23 file://memcached-add-hugetlbfs-check.patch \ 23 file://memcached-add-hugetlbfs-check.patch \
24 file://0002-stats_prefix.c-Check-for-NDEBUG-before-using-total_w.patch \
25 " 24 "
26SRC_URI[sha256sum] = "d5a62ce377314dbffdb37c4467e7763e3abae376a16171e613cbe69956f092d1" 25SRC_URI[sha256sum] = "8d7abe3d649378edbba16f42ef1d66ca3f2ac075f2eb97145ce164388e6ed515"
27 26
28# set the same COMPATIBLE_HOST as libhugetlbfs 27# set the same COMPATIBLE_HOST as libhugetlbfs
29COMPATIBLE_HOST = "(i.86|x86_64|powerpc|powerpc64|aarch64|arm).*-linux*" 28COMPATIBLE_HOST = "(i.86|x86_64|powerpc|powerpc64|aarch64|arm).*-linux*"