diff options
author | Amy Fong <amy.fong@windriver.com> | 2014-06-23 12:08:58 -0400 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2014-06-29 23:30:49 -0400 |
commit | 87bbe91686e1bbc9036aacd924162f17db214aad (patch) | |
tree | 283d7be17c180e71fd35290534007341214bb885 /meta-networking/recipes-support/memcached/memcached_1.4.17.bb | |
parent | 43da512cc3a5860c2e274225e73bc721d6d97918 (diff) | |
download | meta-openembedded-87bbe91686e1bbc9036aacd924162f17db214aad.tar.gz |
Uprev memcached from upstream
memcached 1.4.15 has some configuration errors:
configure:5798: error: cannot run test program while cross compiling
Uprev has the needed fix for the configuration error and some other fixes.
Signed-off-by: Amy Fong <amy.fong@windriver.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/memcached/memcached_1.4.17.bb')
-rw-r--r-- | meta-networking/recipes-support/memcached/memcached_1.4.17.bb | 43 |
1 files changed, 43 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/memcached/memcached_1.4.17.bb b/meta-networking/recipes-support/memcached/memcached_1.4.17.bb new file mode 100644 index 000000000..6a01ec28c --- /dev/null +++ b/meta-networking/recipes-support/memcached/memcached_1.4.17.bb | |||
@@ -0,0 +1,43 @@ | |||
1 | SUMMARY = "A high-performance memory object caching system" | ||
2 | DESCRIPTION = "\ | ||
3 | memcached optimizes specific high-load serving applications that are designed \ | ||
4 | to take advantage of its versatile no-locking memory access system. Clients \ | ||
5 | are available in several different programming languages, to suit the needs \ | ||
6 | of the specific application. Traditionally this has been used in mod_perl \ | ||
7 | apps to avoid storing large chunks of data in Apache memory, and to share \ | ||
8 | this burden across several machines." | ||
9 | |||
10 | HOMEPAGE = "http://memcached.org/" | ||
11 | LICENSE = "BSD-3-Clause" | ||
12 | |||
13 | LIC_FILES_CHKSUM = "file://COPYING;md5=7e5ded7363d335e1bb18013ca08046ff" | ||
14 | |||
15 | inherit autotools | ||
16 | |||
17 | DEPENDS += "libevent" | ||
18 | RDEPENDS_${PN} += "perl perl-module-posix perl-module-autoloader perl-module-tie-hash" | ||
19 | |||
20 | SRC_URI = "http://www.memcached.org/files/${PN}-${PV}.tar.gz" | ||
21 | |||
22 | SRC_URI[md5sum] = "46402dfbd7faadf6182283dbbd18b1a6" | ||
23 | SRC_URI[sha256sum] = "d9173ef6d99ba798c982ea4566cb4f0e64eb23859fdbf9926a89999d8cdc0458" | ||
24 | |||
25 | python __anonymous () { | ||
26 | endianness = d.getVar('SITEINFO_ENDIANNESS', True) | ||
27 | if endianness == 'le': | ||
28 | d.setVar('EXTRA_OECONF', "ac_cv_c_endian=little") | ||
29 | else: | ||
30 | d.setVar('EXTRA_OECONF', "ac_cv_c_endian=big") | ||
31 | } | ||
32 | |||
33 | inherit update-rc.d | ||
34 | |||
35 | INITSCRIPT_NAME = "memcached" | ||
36 | INITSCRIPT_PARAMS = "defaults" | ||
37 | |||
38 | do_install_append() { | ||
39 | install -D -m 755 ${S}/scripts/memcached-init ${D}${sysconfdir}/init.d/memcached | ||
40 | mkdir -p ${D}/usr/share/memcached/scripts | ||
41 | install -m 755 ${S}/scripts/memcached-tool ${D}/usr/share/memcached/scripts | ||
42 | install -m 755 ${S}/scripts/start-memcached ${D}/usr/share/memcached/scripts | ||
43 | } | ||