summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/libtevent/libtevent_0.9.28.bb
diff options
context:
space:
mode:
authorJoe MacDonald <joe_macdonald@mentor.com>2016-04-18 17:00:51 -0400
committerJoe MacDonald <joe_macdonald@mentor.com>2016-04-20 08:55:42 -0400
commit59b17c8f45404af7d98a0d4792b3d54ac3965e07 (patch)
tree18fc818383ca70f1d7b7b016a9b839110a6e8a1b /meta-networking/recipes-support/libtevent/libtevent_0.9.28.bb
parent37c158f79acda29710946e64d2eb42bce6874e45 (diff)
downloadmeta-openembedded-59b17c8f45404af7d98a0d4792b3d54ac3965e07.tar.gz
libtevent: Update to latest stable
The update of Samba requires a newer version of libtevent, so update it. Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/libtevent/libtevent_0.9.28.bb')
-rw-r--r--meta-networking/recipes-support/libtevent/libtevent_0.9.28.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/libtevent/libtevent_0.9.28.bb b/meta-networking/recipes-support/libtevent/libtevent_0.9.28.bb
new file mode 100644
index 000000000..d0ad748f5
--- /dev/null
+++ b/meta-networking/recipes-support/libtevent/libtevent_0.9.28.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Hierarchical, reference counted memory pool system with destructors"
2HOMEPAGE = "http://tevent.samba.org"
3SECTION = "libs"
4LICENSE = "LGPLv3+"
5
6DEPENDS += "libbsd libtalloc"
7RDEPENDS_python-tevent = "python"
8
9SRC_URI = "http://samba.org/ftp/tevent/tevent-${PV}.tar.gz"
10LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/LGPL-3.0;md5=bfccfe952269fff2b407dd11f2f3083b"
11
12SRC_URI[md5sum] = "945845817918f5cfbe0202d80a7db118"
13SRC_URI[sha256sum] = "04d953379025b1560af5c4ffcce58a3ee84db7aaa09c9f1e3eff5b2945a13529"
14
15inherit waf-samba
16
17PACKAGECONFIG[attr] = ",,attr"
18
19SRC_URI += "${@bb.utils.contains('PACKAGECONFIG', 'attr', '', 'file://avoid-attr-unless-wanted.patch', d)}"
20
21S = "${WORKDIR}/tevent-${PV}"
22
23EXTRA_OECONF += "--disable-rpath \
24 --bundled-libraries=NONE \
25 --builtin-libraries=replace \
26 --with-libiconv=${STAGING_DIR_HOST}${prefix}\
27 --without-gettext \
28 "
29DISABLE_STATIC = ""
30
31PACKAGES += "python-tevent python-tevent-dbg"
32
33FILES_python-tevent = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/*"
34FILES_python-tevent-dbg = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/.debug"