summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/libldb/libldb_1.3.1.bb
diff options
context:
space:
mode:
authorJohannes Pointner <johannes.pointner@br-automation.com>2018-02-27 08:18:43 +0100
committerJoe MacDonald <joe_macdonald@mentor.com>2018-04-06 08:12:20 -0400
commitdb4763a59186e05872b69728728bd2351a514581 (patch)
tree2d2ec18f5e269c40a6056cf505b6a93f2bbdfe8a /meta-networking/recipes-support/libldb/libldb_1.3.1.bb
parentea5c8925c0cf1d35800547cfc5d6efc05b94d3d2 (diff)
downloadmeta-openembedded-db4763a59186e05872b69728728bd2351a514581.tar.gz
libldb: update to version 1.3.1
Version >= 1.2.3 needed to build samba 4.7.5. Signed-off-by: Johannes Pointner <johannes.pointner@br-automation.com> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/libldb/libldb_1.3.1.bb')
-rw-r--r--meta-networking/recipes-support/libldb/libldb_1.3.1.bb63
1 files changed, 63 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/libldb/libldb_1.3.1.bb b/meta-networking/recipes-support/libldb/libldb_1.3.1.bb
new file mode 100644
index 000000000..7e14cde35
--- /dev/null
+++ b/meta-networking/recipes-support/libldb/libldb_1.3.1.bb
@@ -0,0 +1,63 @@
1SUMMARY = "Hierarchical, reference counted memory pool system with destructors"
2HOMEPAGE = "http://ldb.samba.org"
3SECTION = "libs"
4LICENSE = "LGPL-3.0+ & LGPL-2.1+ & GPL-3.0+"
5
6DEPENDS += "libtdb libtalloc libtevent popt"
7RDEPENDS_pyldb += "python"
8
9SRC_URI = "http://samba.org/ftp/ldb/ldb-${PV}.tar.gz \
10 file://do-not-import-target-module-while-cross-compile.patch \
11 file://options-1.3.1.patch \
12 "
13
14PACKAGECONFIG ??= "\
15 ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)} \
16 ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'attr', '', d)} \
17"
18PACKAGECONFIG[acl] = "--with-acl,--without-acl,acl"
19PACKAGECONFIG[attr] = "--with-attr,--without-attr,attr"
20PACKAGECONFIG[ldap] = ",,openldap"
21PACKAGECONFIG[libaio] = "--with-libaio,--without-libaio,libaio"
22PACKAGECONFIG[libbsd] = "--with-libbsd,--without-libbsd,libbsd"
23PACKAGECONFIG[libcap] = "--with-libcap,--without-libcap,libcap"
24PACKAGECONFIG[valgrind] = "--with-valgrind,--without-valgrind,valgrind"
25
26SRC_URI += "${@bb.utils.contains('PACKAGECONFIG', 'ldap', '', 'file://avoid-openldap-unless-wanted.patch', d)}"
27
28LIC_FILES_CHKSUM = "file://pyldb.h;endline=24;md5=dfbd238cecad76957f7f860fbe9adade \
29 file://man/ldb.3.xml;beginline=261;endline=262;md5=137f9fd61040c1505d1aa1019663fd08 \
30 file://tools/ldbdump.c;endline=19;md5=a7d4fc5d1f75676b49df491575a86a42"
31
32SRC_URI[md5sum] = "e5233f202bca27f6ce8474fb8ae65983"
33SRC_URI[sha256sum] = "b19f2c9f55ae0f46aa5ebaea0bf1a47ec1ac135e1d78af0f6318cf50bf62cbd2"
34
35inherit waf-samba
36
37S = "${WORKDIR}/ldb-${PV}"
38
39EXTRA_OECONF += "--disable-rpath \
40 --disable-rpath-install \
41 --bundled-libraries=cmocka \
42 --builtin-libraries=replace \
43 --with-modulesdir=${libdir}/ldb/modules \
44 --with-privatelibdir=${libdir}/ldb \
45 --with-libiconv=${STAGING_DIR_HOST}${prefix}\
46 "
47
48PACKAGES =+ "pyldb pyldb-dbg pyldb-dev"
49
50NOAUTOPACKAGEDEBUG = "1"
51
52FILES_${PN} += "${libdir}/ldb/*"
53FILES_${PN}-dbg += "${bindir}/.debug/* \
54 ${libdir}/.debug/* \
55 ${libdir}/ldb/.debug/* \
56 ${libdir}/ldb/modules/ldb/.debug/*"
57
58FILES_pyldb = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/* \
59 ${libdir}/libpyldb-util.so.* \
60 "
61FILES_pyldb-dbg = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/.debug \
62 ${libdir}/.debug/libpyldb-util.so.*"
63FILES_pyldb-dev = "${libdir}/libpyldb-util.so"