summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/drbd
diff options
context:
space:
mode:
authorJianchuan Wang <jianchuan.wang@windriver.com>2017-08-31 04:57:32 -0400
committerJoe MacDonald <joe_macdonald@mentor.com>2017-09-12 10:55:07 -0400
commit446619d5ec45f0480852a6806067c1937b95923a (patch)
tree212213572b6aae7fcf035a7798be2af3e711c995 /meta-networking/recipes-support/drbd
parent0ede604e78bc88c654b596e825b2bca1e687c398 (diff)
downloadmeta-openembedded-446619d5ec45f0480852a6806067c1937b95923a.tar.gz
drbd-utils: only rmmod if DRBD is a module
Account for the case if the DRBD drive is built into the kernel. Otherwise, errors, like the following, will occur: root@localhost:~# /etc/init.d/drbd stop Stopping all DRBD resources: ERROR: Module drbd does not exist in /proc/modules Signed-off-by: Jianchuan Wang <jianchuan.wang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/drbd')
-rw-r--r--meta-networking/recipes-support/drbd/drbd-utils/0001-drbd-8.4.4-drbd-tools-only-rmmod-if-DRBD-is-a-module.patch39
-rw-r--r--meta-networking/recipes-support/drbd/drbd-utils_8.9.6.bb1
2 files changed, 40 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/drbd/drbd-utils/0001-drbd-8.4.4-drbd-tools-only-rmmod-if-DRBD-is-a-module.patch b/meta-networking/recipes-support/drbd/drbd-utils/0001-drbd-8.4.4-drbd-tools-only-rmmod-if-DRBD-is-a-module.patch
new file mode 100644
index 000000000..add0b030c
--- /dev/null
+++ b/meta-networking/recipes-support/drbd/drbd-utils/0001-drbd-8.4.4-drbd-tools-only-rmmod-if-DRBD-is-a-module.patch
@@ -0,0 +1,39 @@
1Subject: drbd-tools: only rmmod if DRBD is a module
2
3Account for the case if the DRBD drive is built into
4the kernel. Otherwise, errors, like the following,
5will occur:
6
7root@localhost:~# /etc/init.d/drbd stop
8 Stopping all DRBD resources: ERROR: Module drbd does not exist in
9 /proc/modules
10
11Signed-off-by: Aws Ismail <aws.ismail@windriver.com>
12Signed-off-by: Jason Wessel <jason.wessel@windriver.com>
13
14[ refresh to 8.4.4: squash Aws' and Jason's patches ]
15Signed-off-by: Michel Thebeau <michel.thebeau@windriver.com>
16
17Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
18---
19 scripts/drbd | 4 +++-
20 1 file changed, 3 insertions(+), 1 deletion(-)
21
22diff --git a/scripts/drbd b/scripts/drbd
23index 20bf628..de589dc 100755
24--- a/scripts/drbd
25+++ b/scripts/drbd
26@@ -241,7 +241,9 @@ case "$1" in
27 if [ -d /sys/module/drbd/holders ]; then
28 (cd /sys/module/drbd/holders; for tr in *; do [ -d ${tr} ] && ${RMMOD} ${tr}; done)
29 fi
30- $RMMOD drbd && break
31+ if [ ! -z "$(cat /proc/modules | grep -w drbd)" ]; then
32+ $RMMOD drbd && break
33+ fi
34 fi
35 done
36 run_hook stop
37--
381.9.1
39
diff --git a/meta-networking/recipes-support/drbd/drbd-utils_8.9.6.bb b/meta-networking/recipes-support/drbd/drbd-utils_8.9.6.bb
index 5f6c43f7e..5979fbb58 100644
--- a/meta-networking/recipes-support/drbd/drbd-utils_8.9.6.bb
+++ b/meta-networking/recipes-support/drbd/drbd-utils_8.9.6.bb
@@ -10,6 +10,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
10 10
11SRC_URI = "http://oss.linbit.com/drbd/${BP}.tar.gz \ 11SRC_URI = "http://oss.linbit.com/drbd/${BP}.tar.gz \
12 file://0001-Makefile.in-fix-permission-bits-for-drbd.service.patch \ 12 file://0001-Makefile.in-fix-permission-bits-for-drbd.service.patch \
13 file://0001-drbd-8.4.4-drbd-tools-only-rmmod-if-DRBD-is-a-module.patch \
13 " 14 "
14SRC_URI[md5sum] = "76ed6d3190cd77b00890f3365353124b" 15SRC_URI[md5sum] = "76ed6d3190cd77b00890f3365353124b"
15SRC_URI[sha256sum] = "297b77c9b3f88de2e7dae459234f2753ea4fc2805282b2d276e35cf51e292913" 16SRC_URI[sha256sum] = "297b77c9b3f88de2e7dae459234f2753ea4fc2805282b2d276e35cf51e292913"