summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/drbd
diff options
context:
space:
mode:
authorJagadeesh Krishnanjanappa <jkrishnanjanappa@mvista.com>2017-07-28 01:01:15 +0530
committerJoe MacDonald <joe_macdonald@mentor.com>2017-09-08 16:39:10 -0400
commit4437e03095cf8207fd8be50cbf1b5ab67b455e2d (patch)
treee03aa664c07cdd000470a28a3d1e5cca260ad0a5 /meta-networking/recipes-support/drbd
parent64e1ba5bf78debdbb16b02b2f4909a1d4806022f (diff)
downloadmeta-openembedded-4437e03095cf8207fd8be50cbf1b5ab67b455e2d.tar.gz
drbd: Add recipe
DRBD is a block device which is designed to build high availability clusters. This is done by mirroring a whole block device via (a dedicated) network. You could see it as a "network RAID-1". This recipe provides DRBD9 kernel modules drbd.ko and drbd_transport_tcp.ko. Signed-off-by: Jagadeesh Krishnanjanappa <jkrishnanjanappa@mvista.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/drbd')
-rw-r--r--meta-networking/recipes-support/drbd/drbd/check_existence_of_modules_before_installing.patch24
-rw-r--r--meta-networking/recipes-support/drbd/drbd_9.0.8-1.bb22
2 files changed, 46 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/drbd/drbd/check_existence_of_modules_before_installing.patch b/meta-networking/recipes-support/drbd/drbd/check_existence_of_modules_before_installing.patch
new file mode 100644
index 000000000..6414f7305
--- /dev/null
+++ b/meta-networking/recipes-support/drbd/drbd/check_existence_of_modules_before_installing.patch
@@ -0,0 +1,24 @@
1If CONFIG_BLK_DEV_DRBD kernel config is enabled, then DRBD
2does not build drbd.ko here. Under this circumstance do_install
3task is going to fail with a below error:
4-- snip --
5| install: cannot stat ‘drbd.ko’: No such file or directory
6| make[1]: *** [install] Error 1
7-- snip --
8
9So, check for kernel module existence before installing.
10
11Upstream-Status: Inappropriate [embedded specific]
12
13Signed-off-by: Jagadeesh Krishnanjanappa <jkrishnanjanappa@mvista.com>
14--- drbd-9.0.1-1/drbd/Makefile 2016-07-03 06:54:19.421538690 -0700
15+++ drbd-9.0.1-1/drbd/Makefile_mod 2016-07-03 06:53:18.938801628 -0700
16@@ -158,7 +158,7 @@ else
17 fi
18 install -d $(DESTDIR)/lib/modules/$(KERNELRELEASE)/$(MODSUBDIR)
19 set -e ; for ko in $(MODOBJS); do \
20- install -m 644 $$ko $(DESTDIR)/lib/modules/$(KERNELRELEASE)/$(MODSUBDIR); \
21+ [ -e $$ko ] && install -m 644 $$ko $(DESTDIR)/lib/modules/$(KERNELRELEASE)/$(MODSUBDIR); \
22 done
23 ifeq ($(DESTDIR),/)
24 ifeq ($(shell uname -r),$(KERNELRELEASE))
diff --git a/meta-networking/recipes-support/drbd/drbd_9.0.8-1.bb b/meta-networking/recipes-support/drbd/drbd_9.0.8-1.bb
new file mode 100644
index 000000000..e943f2464
--- /dev/null
+++ b/meta-networking/recipes-support/drbd/drbd_9.0.8-1.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Distributed block device driver for Linux"
2DESCRIPTION = "DRBD is a block device which is designed to build high \
3 availability clusters. This is done by mirroring a whole \
4 block device via (a dedicated) network. You could see \
5 it as a network raid-1."
6HOMEPAGE = "http://oss.linbit.com/drbd/"
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
9DEPENDS = "virtual/kernel"
10
11SRC_URI = "http://www.linbit.com/downloads/drbd/9.0/drbd-${PV}.tar.gz \
12 file://check_existence_of_modules_before_installing.patch"
13
14SRC_URI[md5sum] = "c1dd58043f46e9926b579aa65d4ea980"
15SRC_URI[sha256sum] = "87f72d46db9bad926415b3ab9f5f1397de8c581d2e2ec1addbdd5ce2604e6123"
16inherit module
17
18EXTRA_OEMAKE += "KDIR='${STAGING_KERNEL_DIR}'"
19
20do_install () {
21 oe_runmake install DESTDIR="${D}"
22}