summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/curlpp
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2017-03-22 00:35:11 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2017-03-24 14:10:18 -0400
commitf2dfae565531dd126131474b8a15dfe1d2871cc3 (patch)
treead57b363e423d7f75a0ce16625d6c2877d91ea79 /meta-networking/recipes-support/curlpp
parentcb3561aa22640e27d2bcadd541f247e90a7f1436 (diff)
downloadmeta-openembedded-f2dfae565531dd126131474b8a15dfe1d2871cc3.tar.gz
curlpp: 0.7.3 -> 0.8.1
Upgrade curlpp from 0.7.3 to 0.8.1. The main difference between 0.7.x and 0.8.0 is that it replaces autotools with cmake, see https://github.com/jpbarrette/curlpp/releases/tag/v0.8.0 The homepage of curlpp on googlecode is obsoleted, so update it and use soure code repo on github. Remove dependency boost which is dropped by upstream. And remove extra CXXFLAGS which has been fixed by upstream. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/curlpp')
-rw-r--r--meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb40
-rw-r--r--meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb33
2 files changed, 33 insertions, 40 deletions
diff --git a/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb b/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb
deleted file mode 100644
index c3a242a31..000000000
--- a/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb
+++ /dev/null
@@ -1,40 +0,0 @@
1SUMMARY = "C++ library for client-side URL transfers"
2HOMEPAGE = "http://code.google.com/p/curlpp/"
3SECTION = "libdevel"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
6
7DEPENDS = "curl boost"
8DEPENDS_class-native = "curl-native"
9
10SRC_URI = "http://curlpp.googlecode.com/files/curlpp-${PV}.tar.gz \
11 file://example21.cpp-remove-deprecated-code.patch \
12"
13
14SRC_URI[md5sum] = "ccc3d30d4b3b5d2cdbed635898c29485"
15SRC_URI[sha256sum] = "e3f9427b27c5bddf898d383d45c0d3d5397e2056ff935d9a5cdaef6a9a653bd5"
16
17inherit autotools-brokensep pkgconfig binconfig
18
19EXTRA_OECONF = "--with-boost=${STAGING_DIR_HOST}${prefix}"
20# Upstream is currently working on porting the code to use std::unique_ptr instead of the
21# deprecated auto_ptr. For now, ignore the issue.
22CXXFLAGS += "-Wno-error=deprecated-declarations"
23
24do_install_append () {
25 sed -i 's,${STAGING_DIR_TARGET},,g' ${D}${libdir}/pkgconfig/curlpp.pc
26}
27
28PACKAGES =+ "libcurlpp libcurlpp-dev libcurlpp-staticdev"
29
30FILES_lib${BPN} = "${libdir}/lib*.so.*"
31
32FILES_lib${BPN}-dev = "${includedir} \
33 ${libdir}/lib*.la \
34 ${libdir}/pkgconfig \
35 ${bindir}/*-config \
36"
37
38FILES_lib${BPN}-staticdev = "${libdir}/lib*.a"
39
40BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb b/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb
new file mode 100644
index 000000000..340f57dc7
--- /dev/null
+++ b/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb
@@ -0,0 +1,33 @@
1SUMMARY = "C++ library for client-side URL transfers"
2HOMEPAGE = "http://www.curlpp.org/"
3SECTION = "libdevel"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
6
7DEPENDS = "curl"
8DEPENDS_class-native = "curl-native"
9
10SRC_URI = "git://github.com/jpbarrette/curlpp.git"
11
12SRCREV = "592552a165cc569dac7674cb7fc9de3dc829906f"
13
14S = "${WORKDIR}/git"
15
16inherit cmake pkgconfig binconfig
17
18do_install_append () {
19 sed -i 's,${STAGING_DIR_TARGET},,g' ${D}${libdir}/pkgconfig/curlpp.pc
20}
21
22PACKAGES =+ "libcurlpp libcurlpp-dev libcurlpp-staticdev"
23
24FILES_lib${BPN} = "${libdir}/lib*.so.*"
25
26FILES_lib${BPN}-dev = "${includedir} \
27 ${libdir}/pkgconfig \
28 ${bindir}/*-config \
29"
30
31FILES_lib${BPN}-staticdev = "${libdir}/lib*.a"
32
33BBCLASSEXTEND = "native nativesdk"