summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/curlpp
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-06-09 14:54:43 -0400
committerJoe MacDonald <joe_macdonald@mentor.com>2016-06-15 19:52:22 -0400
commit5c8efcc9f54d04ac9a7c41176989efb78c4ac54f (patch)
tree9133a8fb57f4490de322baa84d8bd978d0e30fb8 /meta-networking/recipes-support/curlpp
parentf316c4a32686e57c4b65e659fbf7d7936ac39ff6 (diff)
downloadmeta-openembedded-5c8efcc9f54d04ac9a7c41176989efb78c4ac54f.tar.gz
curlpp: fix build with gcc-6 and remove blacklist
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/curlpp')
-rw-r--r--meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb b/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb
index 43e69b93a..78b943247 100644
--- a/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb
+++ b/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb
@@ -16,6 +16,10 @@ SRC_URI[sha256sum] = "e3f9427b27c5bddf898d383d45c0d3d5397e2056ff935d9a5cdaef6a9a
16 16
17inherit autotools-brokensep pkgconfig binconfig 17inherit autotools-brokensep pkgconfig binconfig
18 18
19# Upstream is currently working on porting the code to use std::unique_ptr instead of the
20# deprecated auto_ptr. For now, ignore the issue.
21CXXFLAGS += "-Wno-error=deprecated-declarations"
22
19PACKAGES =+ "libcurlpp libcurlpp-dev libcurlpp-staticdev" 23PACKAGES =+ "libcurlpp libcurlpp-dev libcurlpp-staticdev"
20 24
21FILES_lib${BPN} = "${libdir}/lib*.so.* \ 25FILES_lib${BPN} = "${libdir}/lib*.so.* \
@@ -29,6 +33,3 @@ FILES_lib${BPN}-dev = "${includedir} \
29FILES_lib${BPN}-staticdev = "${libdir}/lib*.a" 33FILES_lib${BPN}-staticdev = "${libdir}/lib*.a"
30 34
31BBCLASSEXTEND = "native nativesdk" 35BBCLASSEXTEND = "native nativesdk"
32
33# http://errors.yoctoproject.org/Errors/Details/68623/
34PNBLACKLIST[curlpp] ?= "BROKEN: fails to build with gcc-6"