summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/ctdb/ctdb_2.5.1.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2016-01-13 16:23:57 -0500
committerJoe MacDonald <joe_macdonald@mentor.com>2016-01-26 18:08:17 -0500
commite4dc2a3641b61649bb92511d5c8b52f3e86f6b8e (patch)
treeb541909f66fc77002348835ab485745d364c0a9e /meta-networking/recipes-support/ctdb/ctdb_2.5.1.bb
parenta9c2fe6cd1fe7dd8555772cd2bfde2952e8de564 (diff)
downloadmeta-openembedded-e4dc2a3641b61649bb92511d5c8b52f3e86f6b8e.tar.gz
ctdb: Fix rootfs creation errors
While building an image I was getting an error during rootfs creation that ctdb was conflicting with base-files as both were creating '/var/run': warning: Removing ctdb-2.5.1-r0@core2_64 due to file /var/run \ conflicting with base-files-3.0.14-r89@genericx86_64 This is normally a volatile directory so we have no need to include this in the ctdb package, so revert the actions of the Makefile by deleting the directory. Although /run and $localstatedir/run are linked to be consistent we update the .service file to use the latter. To ensure the 'ctdb' subdir exists we patch the use of RuntimeDirectory= in to the .service file. This will compensate for our removal of this directory creation from the Makefile. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/ctdb/ctdb_2.5.1.bb')
-rw-r--r--meta-networking/recipes-support/ctdb/ctdb_2.5.1.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta-networking/recipes-support/ctdb/ctdb_2.5.1.bb b/meta-networking/recipes-support/ctdb/ctdb_2.5.1.bb
index 0cc7aadf1..ba9c4e5ef 100644
--- a/meta-networking/recipes-support/ctdb/ctdb_2.5.1.bb
+++ b/meta-networking/recipes-support/ctdb/ctdb_2.5.1.bb
@@ -17,6 +17,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
17SRC_URI = "https://ftp.samba.org/pub/${PN}/${BP}.tar.gz \ 17SRC_URI = "https://ftp.samba.org/pub/${PN}/${BP}.tar.gz \
18 file://01-support-cross-compile-for-linux-os.patch \ 18 file://01-support-cross-compile-for-linux-os.patch \
19 file://02-link-rep_snprintf-for-ltdbtool.patch \ 19 file://02-link-rep_snprintf-for-ltdbtool.patch \
20 file://service-ensure-the-PID-directory-is-created.patch \
20 " 21 "
21 22
22SRC_URI[md5sum] = "d0cd91726ff4ca2229e1b21859c94717" 23SRC_URI[md5sum] = "d0cd91726ff4ca2229e1b21859c94717"
@@ -36,11 +37,12 @@ do_install_append() {
36 install -d ${D}${systemd_unitdir}/system 37 install -d ${D}${systemd_unitdir}/system
37 install -m 0644 ${S}/config/ctdb.service ${D}${systemd_unitdir}/system 38 install -m 0644 ${S}/config/ctdb.service ${D}${systemd_unitdir}/system
38 sed -i -e 's,/usr/sbin/,${sbindir}/,' ${D}${systemd_unitdir}/system/ctdb.service 39 sed -i -e 's,/usr/sbin/,${sbindir}/,' ${D}${systemd_unitdir}/system/ctdb.service
40 sed -i -e 's,\([=\ ]\)/run/,\1${localstatedir}/run/,' ${D}${systemd_unitdir}/system/ctdb.service
41
42 rm -r ${D}/${localstatedir}/run
39} 43}
40 44
41SYSTEMD_SERVICE_${PN} = "ctdb.service" 45SYSTEMD_SERVICE_${PN} = "ctdb.service"
42 46
43FILES_${PN} += "/run"
44
45# onnode is a shell script with bashisms and bash #! 47# onnode is a shell script with bashisms and bash #!
46RDEPENDS_${PN} += "bash" 48RDEPENDS_${PN} += "bash"