diff options
author | zhengruoqin <zhengrq.fnst@fujitsu.com> | 2021-12-21 08:06:03 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-12-21 18:49:37 -0800 |
commit | 0f5d1070994b7f76d7ea88569c787caea5d2e49c (patch) | |
tree | fe266d8044a4dd6cb24e65cae582d58648d5c177 /meta-networking/recipes-support/chrony | |
parent | 60637824d8b4d4a319a4384e29eb0a1344ddc634 (diff) | |
download | meta-openembedded-0f5d1070994b7f76d7ea88569c787caea5d2e49c.tar.gz |
chrony: upgrade 4.1 -> 4.2
refresh arm_eabi.patch
Changelog:
==========
Enhancements
-Add support for NTPv4 extension field improving synchronisation stability and
resolution of root delay and dispersion (experimental)
-Add support for NTP over PTP (experimental)
-Add support for AES-CMAC and hash functions in GnuTLS
-Improve server interleaved mode to be more reliable and support multiple clients behind NAT
-Update seccomp filter
-Add statistics about interleaved mode to serverstats report
Bug fixes
-Fix RTC support with 64-bit time_t on 32-bit Linux
-Fix seccomp filter to work correctly with bind*device directives
-Suppress kernel adjustments of system clock (dosynctodr) on illumos
Other changes
-Switch Solaris support to illumos
Signed-off-by: Zheng Ruoqin <zhengrq.fnst@fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/chrony')
-rw-r--r-- | meta-networking/recipes-support/chrony/chrony/arm_eabi.patch | 30 | ||||
-rw-r--r-- | meta-networking/recipes-support/chrony/chrony_4.2.bb (renamed from meta-networking/recipes-support/chrony/chrony_4.1.bb) | 2 |
2 files changed, 19 insertions, 13 deletions
diff --git a/meta-networking/recipes-support/chrony/chrony/arm_eabi.patch b/meta-networking/recipes-support/chrony/chrony/arm_eabi.patch index 837cb6d72c..4a2769b843 100644 --- a/meta-networking/recipes-support/chrony/chrony/arm_eabi.patch +++ b/meta-networking/recipes-support/chrony/chrony/arm_eabi.patch | |||
@@ -23,19 +23,22 @@ Subject: [PATCH] chrony: fix build failure for arma9 | |||
23 | 23 | ||
24 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | 24 | Signed-off-by: Khem Raj <raj.khem@gmail.com> |
25 | --- | 25 | --- |
26 | sys_linux.c | 20 ++++++++++++++------ | 26 | sys_linux.c | 15 +++++++++------ |
27 | 1 file changed, 14 insertions(+), 6 deletions(-) | 27 | 1 file changed, 9 insertions(+), 6 deletions(-) |
28 | 28 | ||
29 | diff --git a/sys_linux.c b/sys_linux.c | ||
30 | index 9cab2ef..8104b8f 100644 | ||
29 | --- a/sys_linux.c | 31 | --- a/sys_linux.c |
30 | +++ b/sys_linux.c | 32 | +++ b/sys_linux.c |
31 | @@ -499,14 +499,12 @@ SYS_Linux_EnableSystemCallFilter(int lev | 33 | @@ -484,7 +484,6 @@ SYS_Linux_EnableSystemCallFilter(int level, SYS_ProcessContext context) |
32 | #endif | 34 | #endif |
33 | SCMP_SYS(gettimeofday), | 35 | SCMP_SYS(gettimeofday), |
34 | SCMP_SYS(settimeofday), | 36 | SCMP_SYS(settimeofday), |
35 | - SCMP_SYS(time), | 37 | - SCMP_SYS(time), |
36 | 38 | ||
37 | /* Process */ | 39 | /* Process */ |
38 | SCMP_SYS(clone), | 40 | SCMP_SYS(clone), |
41 | @@ -494,7 +493,6 @@ SYS_Linux_EnableSystemCallFilter(int level, SYS_ProcessContext context) | ||
39 | SCMP_SYS(exit), | 42 | SCMP_SYS(exit), |
40 | SCMP_SYS(exit_group), | 43 | SCMP_SYS(exit_group), |
41 | SCMP_SYS(getpid), | 44 | SCMP_SYS(getpid), |
@@ -43,7 +46,7 @@ Subject: [PATCH] chrony: fix build failure for arma9 | |||
43 | SCMP_SYS(getuid), | 46 | SCMP_SYS(getuid), |
44 | SCMP_SYS(getuid32), | 47 | SCMP_SYS(getuid32), |
45 | SCMP_SYS(rt_sigaction), | 48 | SCMP_SYS(rt_sigaction), |
46 | @@ -520,7 +518,6 @@ SYS_Linux_EnableSystemCallFilter(int lev | 49 | @@ -508,7 +506,6 @@ SYS_Linux_EnableSystemCallFilter(int level, SYS_ProcessContext context) |
47 | /* Memory */ | 50 | /* Memory */ |
48 | SCMP_SYS(brk), | 51 | SCMP_SYS(brk), |
49 | SCMP_SYS(madvise), | 52 | SCMP_SYS(madvise), |
@@ -51,28 +54,28 @@ Subject: [PATCH] chrony: fix build failure for arma9 | |||
51 | SCMP_SYS(mmap2), | 54 | SCMP_SYS(mmap2), |
52 | SCMP_SYS(mprotect), | 55 | SCMP_SYS(mprotect), |
53 | SCMP_SYS(mremap), | 56 | SCMP_SYS(mremap), |
54 | @@ -580,8 +577,6 @@ SYS_Linux_EnableSystemCallFilter(int lev | 57 | @@ -568,8 +565,6 @@ SYS_Linux_EnableSystemCallFilter(int level, SYS_ProcessContext context) |
55 | SCMP_SYS(sendmsg), | 58 | SCMP_SYS(sendmsg), |
56 | SCMP_SYS(sendto), | 59 | SCMP_SYS(sendto), |
57 | SCMP_SYS(shutdown), | 60 | SCMP_SYS(shutdown), |
58 | - /* TODO: check socketcall arguments */ | 61 | - /* TODO: check socketcall arguments */ |
59 | - SCMP_SYS(socketcall), | 62 | - SCMP_SYS(socketcall), |
60 | 63 | ||
61 | /* General I/O */ | 64 | /* General I/O */ |
62 | SCMP_SYS(_newselect), | 65 | SCMP_SYS(_newselect), |
63 | @@ -604,7 +599,6 @@ SYS_Linux_EnableSystemCallFilter(int lev | 66 | @@ -593,7 +588,6 @@ SYS_Linux_EnableSystemCallFilter(int level, SYS_ProcessContext context) |
64 | #ifdef __NR_futex_time64 | 67 | #ifdef __NR_futex_time64 |
65 | SCMP_SYS(futex_time64), | 68 | SCMP_SYS(futex_time64), |
66 | #endif | 69 | #endif |
67 | - SCMP_SYS(select), | 70 | - SCMP_SYS(select), |
68 | SCMP_SYS(set_robust_list), | 71 | SCMP_SYS(set_robust_list), |
69 | SCMP_SYS(write), | 72 | SCMP_SYS(write), |
70 | 73 | ||
71 | @@ -612,6 +606,15 @@ SYS_Linux_EnableSystemCallFilter(int lev | 74 | @@ -601,6 +595,15 @@ SYS_Linux_EnableSystemCallFilter(int level, SYS_ProcessContext context) |
72 | SCMP_SYS(getrandom), | 75 | SCMP_SYS(getrandom), |
73 | SCMP_SYS(sysinfo), | 76 | SCMP_SYS(sysinfo), |
74 | SCMP_SYS(uname), | 77 | SCMP_SYS(uname), |
75 | + /* not always available */ | 78 | + /* not always available */ |
76 | +#if ! defined(__ARM_EABI__) | 79 | +#if ! defined(__ARM_EABI__) |
77 | + SCMP_SYS(time), | 80 | + SCMP_SYS(time), |
78 | + SCMP_SYS(getrlimit), | 81 | + SCMP_SYS(getrlimit), |
@@ -82,5 +85,8 @@ Subject: [PATCH] chrony: fix build failure for arma9 | |||
82 | + SCMP_SYS(socketcall), | 85 | + SCMP_SYS(socketcall), |
83 | +#endif | 86 | +#endif |
84 | }; | 87 | }; |
85 | 88 | ||
86 | const int denied_any[] = { | 89 | const int denied_any[] = { |
90 | -- | ||
91 | 2.25.1 | ||
92 | |||
diff --git a/meta-networking/recipes-support/chrony/chrony_4.1.bb b/meta-networking/recipes-support/chrony/chrony_4.2.bb index 117451db2e..609aaab880 100644 --- a/meta-networking/recipes-support/chrony/chrony_4.1.bb +++ b/meta-networking/recipes-support/chrony/chrony_4.2.bb | |||
@@ -39,7 +39,7 @@ SRC_URI = "https://download.tuxfamily.org/chrony/chrony-${PV}.tar.gz \ | |||
39 | SRC_URI:append:libc-musl = " \ | 39 | SRC_URI:append:libc-musl = " \ |
40 | file://0001-Fix-compilation-with-musl.patch \ | 40 | file://0001-Fix-compilation-with-musl.patch \ |
41 | " | 41 | " |
42 | SRC_URI[sha256sum] = "ed76f2d3f9347ac6221a91ad4bd553dd0565ac188cd7490d0801d08f7171164c" | 42 | SRC_URI[sha256sum] = "273f9fd15c328ed6f3a5f6ba6baec35a421a34a73bb725605329b1712048db9a" |
43 | 43 | ||
44 | DEPENDS = "pps-tools" | 44 | DEPENDS = "pps-tools" |
45 | 45 | ||