summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/celt051
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2018-05-11 19:21:43 +0000
committerArmin Kuster <akuster808@gmail.com>2018-05-17 08:32:26 -0700
commitc71c4c41a6b3bb00cf20556a9ba45210b1bfc9ad (patch)
tree201c41ef9689b6c4ce59011d8bf45b94732a5b93 /meta-networking/recipes-support/celt051
parentae7bb27c9129c06719de8fd5be452d4fd55cf9e4 (diff)
downloadmeta-openembedded-c71c4c41a6b3bb00cf20556a9ba45210b1bfc9ad.tar.gz
celt051: make ogg support optional
* drop PR * add +git to PV * and support for native and nativesdk needed for spice * the old PACKAGECONFIG didn't work, because both options aren't recognized as shown by do_configure warning: configure: WARNING: unrecognized options: --without-ogg, --disable-oggtest * XIPH_PATH_OGG macro is provided by libogg so we cannot call it without the libogg dependency, so replace it with explicit --enable-tools Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/celt051')
-rw-r--r--meta-networking/recipes-support/celt051/celt051/0001-configure.ac-make-tools-support-optional.patch39
-rw-r--r--meta-networking/recipes-support/celt051/celt051_git.bb16
2 files changed, 48 insertions, 7 deletions
diff --git a/meta-networking/recipes-support/celt051/celt051/0001-configure.ac-make-tools-support-optional.patch b/meta-networking/recipes-support/celt051/celt051/0001-configure.ac-make-tools-support-optional.patch
new file mode 100644
index 000000000..b0809ee94
--- /dev/null
+++ b/meta-networking/recipes-support/celt051/celt051/0001-configure.ac-make-tools-support-optional.patch
@@ -0,0 +1,39 @@
1From 86df4200c9c33d999df0e8cc3c9771f17a297ec4 Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Wed, 13 Sep 2017 15:01:54 +0200
4Subject: [PATCH] configure.ac: make tools support optional
5
6* add --enable-tools option
7* XIPH_PATH_OGG macro is provided by libogg so we cannot call
8 it without the libogg dependency
9
10Upstream-Status: Pending
11
12Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
13---
14 configure.ac | 8 +++++++-
15 1 file changed, 7 insertions(+), 1 deletion(-)
16
17diff --git a/configure.ac b/configure.ac
18index d4b1a3f..7d6b2dc 100644
19--- a/configure.ac
20+++ b/configure.ac
21@@ -68,8 +68,14 @@ AC_MSG_RESULT($has_alloca)
22
23 AC_CHECK_HEADERS(sys/soundcard.h sys/audioio.h)
24
25-XIPH_PATH_OGG([tools="tools"], [tools=""])
26+AC_ARG_ENABLE(tools, [ --enable-tools Compile ogg tools],
27+[if test "$enableval" = yes; then
28+ [tools="tools"]
29+else
30+ [tools=""]
31+fi],
32 AC_SUBST(tools)
33+)
34
35 AC_CHECK_LIB(m, sin)
36
37--
382.14.1
39
diff --git a/meta-networking/recipes-support/celt051/celt051_git.bb b/meta-networking/recipes-support/celt051/celt051_git.bb
index ee3882148..850704f5a 100644
--- a/meta-networking/recipes-support/celt051/celt051_git.bb
+++ b/meta-networking/recipes-support/celt051/celt051_git.bb
@@ -12,19 +12,21 @@ like Speex, GSM, or G.729."
12LICENSE = "BSD" 12LICENSE = "BSD"
13LIC_FILES_CHKSUM = "file://COPYING;md5=375f60ab360d17f0172737036ff155b2" 13LIC_FILES_CHKSUM = "file://COPYING;md5=375f60ab360d17f0172737036ff155b2"
14 14
15PV = "0.5.1.3" 15PV = "0.5.1.3+git${SRCPV}"
16PR = "r0"
17 16
18SRCREV = "5555aae843f57241d005e330b9cb65602d56db0f" 17SRCREV = "5555aae843f57241d005e330b9cb65602d56db0f"
19 18
20SRC_URI = "git://git.xiph.org/celt.git;branch=compat-v0.5.1;protocol=https" 19SRC_URI = "git://git.xiph.org/celt.git;branch=compat-v0.5.1;protocol=https \
20 file://0001-configure.ac-make-tools-support-optional.patch \
21"
21 22
22S = "${WORKDIR}/git" 23S = "${WORKDIR}/git"
23 24
24DEPENDS += "libogg"
25
26inherit pkgconfig autotools-brokensep 25inherit pkgconfig autotools-brokensep
27 26
28PACKAGECONFIG = "" 27PACKAGECONFIG_class-native = ""
28PACKAGECONFIG ??= ""
29
30PACKAGECONFIG[ogg] = "--enable-tools,--disable-tools,libogg,"
29 31
30PACKAGECONFIG[ogg] = "--with-ogg --enable-oggtest,--without-ogg --disable-oggtest,," 32BBCLASSEXTEND = "native nativesdk"