diff options
author | Changqing Li <changqing.li@windriver.com> | 2018-07-25 11:27:23 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-07-27 07:19:11 -0700 |
commit | 7b20dd0f251462fa7ffdd67b7108b0fe3afb4c1b (patch) | |
tree | 684ac4d164c941d83423eb91cf900541567b9c61 /meta-networking/recipes-support/c-ares/c-ares | |
parent | e07b4b020396790673ff8ccb12d49c3b629bb21b (diff) | |
download | meta-openembedded-7b20dd0f251462fa7ffdd67b7108b0fe3afb4c1b.tar.gz |
c-ares: upgrade 1.13.0 -> 1.14.0
License-Update: copyright year updated
Signed-off-by: Changqing Li <changqing.li@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/c-ares/c-ares')
-rw-r--r-- | meta-networking/recipes-support/c-ares/c-ares/cmake-install-libcares.pc.patch | 37 |
1 files changed, 22 insertions, 15 deletions
diff --git a/meta-networking/recipes-support/c-ares/c-ares/cmake-install-libcares.pc.patch b/meta-networking/recipes-support/c-ares/c-ares/cmake-install-libcares.pc.patch index 5dd4c7d77..8cadb2bba 100644 --- a/meta-networking/recipes-support/c-ares/c-ares/cmake-install-libcares.pc.patch +++ b/meta-networking/recipes-support/c-ares/c-ares/cmake-install-libcares.pc.patch | |||
@@ -1,23 +1,27 @@ | |||
1 | From 7e1ae687916fd5878ee755afbdea6b10494e0b92 Mon Sep 17 00:00:00 2001 | 1 | From 12414304245cce6ef0e8b9547949be5109845353 Mon Sep 17 00:00:00 2001 |
2 | From: Alexey Firago <alexey_firago@mentor.com> | 2 | From: Changqing Li <changqing.li@windriver.com> |
3 | Date: Wed, 26 Jul 2017 23:21:25 +0300 | 3 | Date: Tue, 24 Jul 2018 13:33:33 +0800 |
4 | Subject: [PATCH] cmake: Install libcares.pc | 4 | Subject: [PATCH] cmake: Install libcares.pc |
5 | 5 | ||
6 | Prepare and install libcares.pc file during cmake build, so libraries | 6 | Prepare and install libcares.pc file during cmake build, so libraries |
7 | using pkg-config to find libcares will not fail. | 7 | using pkg-config to find libcares will not fail. |
8 | 8 | ||
9 | Signed-off-by: Alexey Firago <alexey_firago@mentor.com> | 9 | Signed-off-by: Alexey Firago <alexey_firago@mentor.com> |
10 | |||
11 | update to 1.14.0, fix patch warning | ||
12 | |||
13 | Signed-off-by: Changqing Li <changqing.li@windriver.com> | ||
10 | --- | 14 | --- |
11 | CMakeLists.txt | 21 +++++++++++++++++++++ | 15 | CMakeLists.txt | 23 +++++++++++++++++++++++ |
12 | libcares.pc.cmakein | 20 ++++++++++++++++++++ | 16 | libcares.pc.cmakein | 20 ++++++++++++++++++++ |
13 | 2 files changed, 41 insertions(+) | 17 | 2 files changed, 43 insertions(+) |
14 | create mode 100644 libcares.pc.cmakein | 18 | create mode 100644 libcares.pc.cmakein |
15 | 19 | ||
16 | diff --git a/CMakeLists.txt b/CMakeLists.txt | 20 | diff --git a/CMakeLists.txt b/CMakeLists.txt |
17 | index 364b6c7..0016b67 100644 | 21 | index 60a880c..71eaa53 100644 |
18 | --- a/CMakeLists.txt | 22 | --- a/CMakeLists.txt |
19 | +++ b/CMakeLists.txt | 23 | +++ b/CMakeLists.txt |
20 | @@ -173,21 +173,29 @@ ADD_DEFINITIONS(${SYSFLAGS}) | 24 | @@ -193,22 +193,30 @@ ADD_DEFINITIONS(${SYSFLAGS}) |
21 | 25 | ||
22 | 26 | ||
23 | # Tell C-Ares about libraries to depend on | 27 | # Tell C-Ares about libraries to depend on |
@@ -43,32 +47,35 @@ index 364b6c7..0016b67 100644 | |||
43 | LIST (APPEND CARES_DEPENDENT_LIBS ws2_32) | 47 | LIST (APPEND CARES_DEPENDENT_LIBS ws2_32) |
44 | + LIST (APPEND CARES_PRIVATE_LIBS_LIST "-lws2_32") | 48 | + LIST (APPEND CARES_PRIVATE_LIBS_LIST "-lws2_32") |
45 | ENDIF () | 49 | ENDIF () |
46 | +string (REPLACE ";" " " CARES_PRIVATE_LIBS "${CARES_PRIVATE_LIBS_LIST}") | ||
47 | 50 | ||
51 | +string (REPLACE ";" " " CARES_PRIVATE_LIBS "${CARES_PRIVATE_LIBS_LIST}") | ||
48 | 52 | ||
49 | # When checking for symbols, we need to make sure we set the proper | 53 | # When checking for symbols, we need to make sure we set the proper |
50 | @@ -489,6 +497,13 @@ CONFIGURE_FILE (ares_build.h.cmake ${PROJECT_BINARY_DIR}/ares_build.h) | 54 | # headers, libraries, and definitions for the detection to work properly |
55 | @@ -514,6 +522,15 @@ CONFIGURE_FILE (ares_build.h.cmake ${PROJECT_BINARY_DIR}/ares_build.h) | ||
51 | # Write ares_config.h configuration file. This is used only for the build. | 56 | # Write ares_config.h configuration file. This is used only for the build. |
52 | CONFIGURE_FILE (ares_config.h.cmake ${PROJECT_BINARY_DIR}/ares_config.h) | 57 | CONFIGURE_FILE (ares_config.h.cmake ${PROJECT_BINARY_DIR}/ares_config.h) |
53 | 58 | ||
54 | +# Pass required CFLAGS to pkg-config in case of static library | 59 | +# Pass required CFLAGS to pkg-config in case of static library |
55 | +IF (CARES_STATIC) | 60 | +IF (CARES_STATIC) |
56 | + SET (CPPFLAG_CARES_STATICLIB "-DCARES_STATICLIB") | 61 | + SET (CPPFLAG_CARES_STATICLIB "-DCARES_STATICLIB") |
57 | +ENDIF() | 62 | +ENDIF() |
58 | + | 63 | + |
59 | +# Write ares_config.h configuration file. This is used only for the build. | 64 | +# Write ares_config.h configuration file. This is used only for the build. |
60 | +CONFIGURE_FILE (libcares.pc.cmakein ${PROJECT_BINARY_DIR}/libcares.pc @ONLY) | 65 | +CONFIGURE_FILE (libcares.pc.cmakein ${PROJECT_BINARY_DIR}/libcares.pc @ONLY) |
66 | + | ||
67 | + | ||
61 | 68 | ||
62 | # TRANSFORM_MAKEFILE_INC | 69 | # TRANSFORM_MAKEFILE_INC |
63 | # | 70 | # |
64 | @@ -625,6 +640,12 @@ IF (CARES_INSTALL) | 71 | @@ -664,6 +681,12 @@ IF (CARES_INSTALL) |
65 | INSTALL (FILES "${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}-config.cmake" DESTINATION ${CMAKECONFIG_INSTALL_DIR}) | 72 | INSTALL (FILES "${CMAKE_CURRENT_BINARY_DIR}/libcares.pc" DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig") |
66 | ENDIF () | 73 | ENDIF () |
67 | 74 | ||
68 | +# pkg-config file | 75 | +# pkg-config file |
69 | +IF (CARES_INSTALL) | 76 | +IF (CARES_INSTALL) |
70 | + SET (PKGCONFIG_INSTALL_DIR "${CMAKE_INSTALL_LIBDIR}/pkgconfig") | 77 | + SET (PKGCONFIG_INSTALL_DIR "${CMAKE_INSTALL_LIBDIR}/pkgconfig") |
71 | + INSTALL (FILES "${CMAKE_CURRENT_BINARY_DIR}/libcares.pc" DESTINATION ${PKGCONFIG_INSTALL_DIR}) | 78 | + INSTALL (FILES "${CMAKE_CURRENT_BINARY_DIR}/libcares.pc" DESTINATION ${PKGCONFIG_INSTALL_DIR}) |
72 | +ENDIF () | 79 | +ENDIF () |
73 | + | 80 | + |
74 | # Legacy chain-building variables (provided for compatibility with old code). | 81 | # Legacy chain-building variables (provided for compatibility with old code). |
@@ -76,7 +83,7 @@ index 364b6c7..0016b67 100644 | |||
76 | SET (CARES_FOUND 1 CACHE INTERNAL "CARES LIBRARY FOUND") | 83 | SET (CARES_FOUND 1 CACHE INTERNAL "CARES LIBRARY FOUND") |
77 | diff --git a/libcares.pc.cmakein b/libcares.pc.cmakein | 84 | diff --git a/libcares.pc.cmakein b/libcares.pc.cmakein |
78 | new file mode 100644 | 85 | new file mode 100644 |
79 | index 0000000..f29fede | 86 | index 0000000..3579256 |
80 | --- /dev/null | 87 | --- /dev/null |
81 | +++ b/libcares.pc.cmakein | 88 | +++ b/libcares.pc.cmakein |
82 | @@ -0,0 +1,20 @@ | 89 | @@ -0,0 +1,20 @@ |