summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/bridge-utils/bridge-utils_1.6.bb
diff options
context:
space:
mode:
authorJoe MacDonald <joe_macdonald@mentor.com>2017-11-01 09:23:42 -0400
committerJoe MacDonald <joe_macdonald@mentor.com>2018-01-08 11:57:34 -0500
commitf0764a12deb3a64c6824669ca41e0c07f4ab8080 (patch)
treecb1ca7c70bfecad5263f08ad8a689d9ffef5c82a /meta-networking/recipes-support/bridge-utils/bridge-utils_1.6.bb
parentf9a1fe6ab2dfb6a53e58fc8da3a1580e76954e5e (diff)
downloadmeta-openembedded-f0764a12deb3a64c6824669ca41e0c07f4ab8080.tar.gz
bridge-utils: update to v1.6
Updating to the latest version (1.6) and taking the opportunity to clean up the old patches, switch to the upstream git repo for SRC_URI and make the requested change to the older AR patch from a while back. Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com> merge conflict with master-next Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/bridge-utils/bridge-utils_1.6.bb')
-rw-r--r--meta-networking/recipes-support/bridge-utils/bridge-utils_1.6.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/bridge-utils/bridge-utils_1.6.bb b/meta-networking/recipes-support/bridge-utils/bridge-utils_1.6.bb
new file mode 100644
index 000000000..1c87c48bf
--- /dev/null
+++ b/meta-networking/recipes-support/bridge-utils/bridge-utils_1.6.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Tools for ethernet bridging"
2HOMEPAGE = "http://www.linuxfoundation.org/collaborate/workgroups/networking/bridge"
3SECTION = "net"
4LICENSE = "GPLv2"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=f9d20a453221a1b7e32ae84694da2c37"
7
8SRCREV = "42c1aefc303fdf891fbb099ea51f00dca83ab606"
9
10SRC_URI = "\
11 git://git.kernel.org/pub/scm/linux/kernel/git/shemminger/bridge-utils.git \
12 file://kernel-headers.patch \
13 file://0005-build-don-t-ignore-CFLAGS-from-environment.patch \
14 file://0006-libbridge-Modifying-the-AR-to-cross-toolchain.patch \
15"
16
17S = "${WORKDIR}/git"
18
19DEPENDS = "sysfsutils"
20
21inherit autotools-brokensep update-alternatives
22
23ALTERNATIVE_${PN} = "brctl"
24ALTERNATIVE_PRIORITY[brctl] = "100"
25ALTERNATIVE_LINK_NAME[brctl] = "${sbindir}/brctl"
26
27EXTRA_OECONF = "--with-linux-headers=${STAGING_INCDIR}"
28
29do_install_append () {
30 install -d ${D}/${datadir}/bridge-utils
31 install -d ${D}/${sysconfdir}/network/if-pre-up.d
32 install -d ${D}/${sysconfdir}/network/if-post-down.d
33}
34
35RRECOMMENDS_${PN} = "kernel-module-bridge"