summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-protocols
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2017-04-27 11:04:51 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-31 10:18:33 +0200
commitec9e5ed06256ad92c818474cdb490dc0d3a0d0a3 (patch)
treee16d2a838f4561d5538928a58f805e5f1373225a /meta-networking/recipes-protocols
parent6775acb048dabd624c5c8197b683aba45ed91569 (diff)
downloadmeta-openembedded-ec9e5ed06256ad92c818474cdb490dc0d3a0d0a3.tar.gz
recipes: remove blacklisted recipes
* as PNBLACKLIST message says, these recipes are blacklisted for long time and nobody showed any interest to fix them * remove all unused .patch and .inc files as well Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-protocols')
-rw-r--r--meta-networking/recipes-protocols/accel-ppp/accel-ppp_git.bb45
1 files changed, 0 insertions, 45 deletions
diff --git a/meta-networking/recipes-protocols/accel-ppp/accel-ppp_git.bb b/meta-networking/recipes-protocols/accel-ppp/accel-ppp_git.bb
deleted file mode 100644
index 0a86504c7..000000000
--- a/meta-networking/recipes-protocols/accel-ppp/accel-ppp_git.bb
+++ /dev/null
@@ -1,45 +0,0 @@
1SUMMARY = "ACCEL-PPP is a high performance VPN server application for linux"
2HOMEPAGE = "http://sourceforge.net/apps/trac/accel-ppp/wiki"
3SECTION = "net"
4
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
7
8DEPENDS = "openssl libpcre"
9
10inherit cmake
11
12PR = "r1"
13PV = "1.7.3+git"
14
15SRCREV = "4acfa46c321a344b9a6ce4128e72d1e02828d8a0"
16SRC_URI = "git://accel-ppp.git.sourceforge.net/gitroot/accel-ppp/accel-ppp;branch=1.7"
17
18S = "${WORKDIR}/git"
19
20EXTRA_OECMAKE = " \
21 -DBUILD_DRIVER=FALSE \
22 -DCMAKE_INSTALL_PREFIX=${prefix} \
23 -DCMAKE_BUILD_TYPE=Release \
24 -DLOG_PGSQL=FALSE \
25 -DRADIUS=FALSE \
26 -DNETSNMP=FALSE \
27"
28FILES_${PN}-dbg += "/usr/lib/${BPN}/.debug/*"
29
30PACKAGES =+ "${PN}-libs"
31FILES_${PN}-libs = "${libdir}/${BPN}/*.so /usr/lib/${BPN}/*.so"
32INSANE_SKIP_${PN}-libs = "dev-so"
33RDEPENDS_${PN} += "${PN}-libs"
34
35do_install_prepend() {
36 cmlist=`find ${S} -name CMakeLists.txt`
37 for file in $cmlist; do
38 sed -i -e "s:LIBRARY DESTINATION lib/accel-ppp:LIBRARY DESTINATION ${baselib}/accel-ppp:g" \
39 -e "s:\${CMAKE_INSTALL_PREFIX}/lib/accel-ppp:\${CMAKE_INSTALL_PREFIX}/${baselib}/accel-ppp:g" \
40 $cmlist
41 done
42}
43
44# http://errors.yoctoproject.org/Errors/Details/81003/
45PNBLACKLIST[accel-ppp] ?= "BROKEN: fails to build with new binutils-2.27 - the recipe will be removed on 2017-09-01 unless the issue is fixed"