summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-protocols
diff options
context:
space:
mode:
authorYi-Soo An <yisooan@gmail.com>2018-10-09 18:58:54 +0900
committerKhem Raj <raj.khem@gmail.com>2018-10-09 19:08:26 -0700
commitc249286bb84763a70ea74474d8a3563cb3e5c50d (patch)
treec92e3318d4c0e9f75868ca1ea56572245113a7be /meta-networking/recipes-protocols
parentccfe7aca8e99cd8ec29e53b8d5d3bf304f29dfec (diff)
downloadmeta-openembedded-c249286bb84763a70ea74474d8a3563cb3e5c50d.tar.gz
babeld: Add Babel routing protocol recipe
Babel is a loop-avoiding distance-vector routing protocol for IPv6 and IPv4 with fast convergence properties. Signed-off-by: Yi-Soo An <yisooan@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-protocols')
-rw-r--r--meta-networking/recipes-protocols/babeld/babeld_1.8.3.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-networking/recipes-protocols/babeld/babeld_1.8.3.bb b/meta-networking/recipes-protocols/babeld/babeld_1.8.3.bb
new file mode 100644
index 000000000..8f028474f
--- /dev/null
+++ b/meta-networking/recipes-protocols/babeld/babeld_1.8.3.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Babel is a loop-avoiding distance-vector routing protocol"
2DESCRIPTION = "\
3Babel is a loop-avoiding distance-vector routing protocol for IPv6 and \
4IPv4 with fast convergence properties. It is based on the ideas in DSDV, AODV \
5and Cisco's EIGRP, but is designed to work well not only in wired networks \
6but also in wireless mesh networks, and has been extended with support \
7for overlay networks. Babel is in the process of becoming an IETF Standard. \
8"
9HOMEPAGE = "https://www.irif.fr/~jch/software/babel/"
10SECTION = "net"
11
12LICENSE = "MIT"
13LIC_FILES_CHKSUM = "file://LICENCE;md5=411a48ac3c2e9e0911b8dd9aed26f754"
14
15SRC_URI = "git://github.com/jech/babeld.git;protocol=git"
16SRCREV = "535184173fcde5ddc43020cd197d01d1ea0e9a8b"
17
18S = "${WORKDIR}/git"
19
20do_compile () {
21 oe_runmake babeld
22}
23
24do_install () {
25 oe_runmake install.minimal PREFIX=${D}
26}
27