diff options
author | Jason Wessel <jason.wessel@windriver.com> | 2015-09-29 15:14:08 -0500 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2015-10-21 15:58:59 -0400 |
commit | 9d923033cb88b8526afc035a73d57340030fca79 (patch) | |
tree | 2dcc0727764a6410bd53dc29f269b6ee57824f5c /meta-networking/recipes-protocols | |
parent | b851e928eacb9c27923a9028618d107fe22136fd (diff) | |
download | meta-openembedded-9d923033cb88b8526afc035a73d57340030fca79.tar.gz |
tsocks: Add tsocks to meta-network/recipes-protocols
The tsocks program is frequently used to easily wrap any generic
program such as telnet, ssh, wget or any other tcp socket program
using an LD_PRELOAD library. One might use an ssh tunnel and wget for
example.
Example of tunnel via ssh to remote url:
ssh -N -D 1080 $REMOTE_HOST_TUNNEL_ENDPOINT &
cat<<EOF>tsocks.conf
server_port = 1080
server = 127.0.0.1
EOF
TSOCKS_CONF_FILE=$PWD/tsocks.conf tsocks curl $REMOTE_URL
Signed-off-by: Jason Wessel <jason.wessel@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-protocols')
-rw-r--r-- | meta-networking/recipes-protocols/tsocks/tsocks_1.8beta5.bb | 23 |
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-networking/recipes-protocols/tsocks/tsocks_1.8beta5.bb b/meta-networking/recipes-protocols/tsocks/tsocks_1.8beta5.bb new file mode 100644 index 0000000000..b3a9620c68 --- /dev/null +++ b/meta-networking/recipes-protocols/tsocks/tsocks_1.8beta5.bb | |||
@@ -0,0 +1,23 @@ | |||
1 | SUMMARY = "Libraries and wrapper for using a SOCKS proxy" | ||
2 | DESCRIPTION = "The role of tsocks is to allow non SOCKS aware \ | ||
3 | applications (e.g telnet, ssh, ftp etc) to use SOCKS without any \ | ||
4 | modification. It does this by intercepting the calls that applications \ | ||
5 | make to establish network connections and negotating them through a \ | ||
6 | SOCKS server as necessary." | ||
7 | HOMEPAGE = "http://sourceforge.net/projects/tsocks/" | ||
8 | SECTION = "net" | ||
9 | LICENSE = "GPL-2.0" | ||
10 | LIC_FILES_CHKSUM = "file://COPYING;md5=18810669f13b87348459e611d31ab760" | ||
11 | |||
12 | SRC_URI = "http://downloads.sourceforge.net/tsocks/tsocks-${PV}.tar.gz" | ||
13 | |||
14 | SRC_URI[md5sum] = "51caefd77e5d440d0bbd6443db4fc0f8" | ||
15 | SRC_URI[sha256sum] = "849d7ef5af80d03e76cc05ed9fb8fa2bcc2b724b51ebfd1b6be11c7863f5b347" | ||
16 | |||
17 | inherit autotools-brokensep | ||
18 | |||
19 | S = "${WORKDIR}/tsocks-1.8" | ||
20 | |||
21 | FILES_${PN} = "${libdir}/* ${bindir}/tsocks" | ||
22 | FILES_${PN}-dev = "" | ||
23 | INSANE_SKIP_${PN} = "dev-so" | ||