summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-protocols
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-09-24 10:57:13 -0700
committerKhem Raj <raj.khem@gmail.com>2018-09-24 11:49:45 -0700
commit4a0e53cb229f97e9cc3dd925b8db334e07b85768 (patch)
tree2d437a41b6e21a22e4c32fac2269183b5d28efc6 /meta-networking/recipes-protocols
parentc467c5d609db3687cc3639849c287ff38c587dfe (diff)
downloadmeta-openembedded-4a0e53cb229f97e9cc3dd925b8db334e07b85768.tar.gz
tsocks: Add -lssp_nonshared to LIBS explicitly on musl
tsocks uses -nostdlib while linking shared library, which is not ideal but instead of chasing that and assuming there is a reason for that, we add -lssp_noshared to linker command at the end so it can build when security flags are enabled Fixes tsocks.c:954: undefined reference to `__stack_chk_fail_local' Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-protocols')
-rw-r--r--meta-networking/recipes-protocols/tsocks/tsocks_1.8beta5.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-networking/recipes-protocols/tsocks/tsocks_1.8beta5.bb b/meta-networking/recipes-protocols/tsocks/tsocks_1.8beta5.bb
index b2757f6dd..72913579a 100644
--- a/meta-networking/recipes-protocols/tsocks/tsocks_1.8beta5.bb
+++ b/meta-networking/recipes-protocols/tsocks/tsocks_1.8beta5.bb
@@ -18,11 +18,13 @@ SRC_URI[sha256sum] = "849d7ef5af80d03e76cc05ed9fb8fa2bcc2b724b51ebfd1b6be11c7863
18 18
19inherit autotools-brokensep 19inherit autotools-brokensep
20 20
21LIBS_append_libc-musl = " -lssp_nonshared"
22
21S = "${WORKDIR}/tsocks-1.8" 23S = "${WORKDIR}/tsocks-1.8"
22 24
23FILES_${PN} = "${libdir}/* ${bindir}/tsocks" 25FILES_${PN} = "${libdir}/* ${bindir}/tsocks"
24FILES_${PN}-dev = "" 26FILES_${PN}-dev = ""
25INSANE_SKIP_${PN} = "dev-so" 27INSANE_SKIP_${PN} = "dev-so"
26 28
27EXTRA_OEMAKE = "SHCC='${CC} -fPIC ${LDFLAGS}'" 29EXTRA_OEMAKE = "SHCC='${CC} -fPIC ${LDFLAGS}' LIBS='${LIBS}'"
28 30