diff options
author | Khem Raj <raj.khem@gmail.com> | 2024-08-14 19:51:28 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-08-15 10:28:11 -0700 |
commit | 3267d1cf307d10eab23b99118d0adcc1f580ae1c (patch) | |
tree | e66e9f8540b5109e77a121b042a316730a85e2fc /meta-networking/recipes-protocols | |
parent | b35cd00fe151408557f3e2f52a36946fd268db9c (diff) | |
download | meta-openembedded-3267d1cf307d10eab23b99118d0adcc1f580ae1c.tar.gz |
freediameter: Fix buildpaths QA error
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-protocols')
2 files changed, 44 insertions, 4 deletions
diff --git a/meta-networking/recipes-protocols/freediameter/files/0001-bison-flex-Add-flags-for-carrying-user-specified-par.patch b/meta-networking/recipes-protocols/freediameter/files/0001-bison-flex-Add-flags-for-carrying-user-specified-par.patch new file mode 100644 index 000000000..98ba4d528 --- /dev/null +++ b/meta-networking/recipes-protocols/freediameter/files/0001-bison-flex-Add-flags-for-carrying-user-specified-par.patch | |||
@@ -0,0 +1,39 @@ | |||
1 | From fa6227d92725af5ae17b8435c0d50d92ff7a575c Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 14 Aug 2024 19:32:25 -0700 | ||
4 | Subject: [PATCH] bison/flex: Add flags for carrying user specified parameters | ||
5 | |||
6 | This helps in passing cmdline to flex and bison e.g. to remove lines | ||
7 | from generated output to avoid absolute paths | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | cmake/Modules/CMakeUserUseBison.cmake | 1 + | ||
13 | cmake/Modules/CMakeUserUseFlex.cmake | 1 + | ||
14 | 2 files changed, 2 insertions(+) | ||
15 | |||
16 | diff --git a/cmake/Modules/CMakeUserUseBison.cmake b/cmake/Modules/CMakeUserUseBison.cmake | ||
17 | index 9257545..b61bd0e 100644 | ||
18 | --- a/cmake/Modules/CMakeUserUseBison.cmake | ||
19 | +++ b/cmake/Modules/CMakeUserUseBison.cmake | ||
20 | @@ -52,6 +52,7 @@ IF(BISON_EXECUTABLE) | ||
21 | OUTPUT "${OUTFILE}" "${HEADER}" | ||
22 | COMMAND "${BISON_EXECUTABLE}" | ||
23 | ARGS "--name-prefix=${PREFIX}" | ||
24 | + "${BISON_TARGET_ARG_COMPILE_FLAGS}" | ||
25 | "--defines" | ||
26 | "--output-file=${OUTFILE}" | ||
27 | "${CMAKE_CURRENT_SOURCE_DIR}/${FILENAME}" | ||
28 | diff --git a/cmake/Modules/CMakeUserUseFlex.cmake b/cmake/Modules/CMakeUserUseFlex.cmake | ||
29 | index 7d0394f..1221dca 100644 | ||
30 | --- a/cmake/Modules/CMakeUserUseFlex.cmake | ||
31 | +++ b/cmake/Modules/CMakeUserUseFlex.cmake | ||
32 | @@ -39,6 +39,7 @@ IF(FLEX_EXECUTABLE) | ||
33 | OUTPUT "${OUTFILE}" | ||
34 | COMMAND "${FLEX_EXECUTABLE}" | ||
35 | ARGS "-P${PREFIX}" | ||
36 | + "${FLEX_TARGET_ARG_COMPILE_FLAGS}" | ||
37 | "-o${OUTFILE}" | ||
38 | "${CMAKE_CURRENT_SOURCE_DIR}/${FILENAME}" | ||
39 | DEPENDS "${CMAKE_CURRENT_SOURCE_DIR}/${FILENAME}") | ||
diff --git a/meta-networking/recipes-protocols/freediameter/freediameter_1.5.0.bb b/meta-networking/recipes-protocols/freediameter/freediameter_1.5.0.bb index c7c329a5d..cf50a92af 100644 --- a/meta-networking/recipes-protocols/freediameter/freediameter_1.5.0.bb +++ b/meta-networking/recipes-protocols/freediameter/freediameter_1.5.0.bb | |||
@@ -7,7 +7,7 @@ Accounting needs." | |||
7 | 7 | ||
8 | HOMEPAGE = "http://www.freediameter.net" | 8 | HOMEPAGE = "http://www.freediameter.net" |
9 | 9 | ||
10 | DEPENDS = "flex bison cmake-native libgcrypt gnutls libidn2 lksctp-tools virtual/kernel bison-native" | 10 | DEPENDS = "flex-native bison-native cmake-native libgcrypt gnutls libidn2 lksctp-tools virtual/kernel bison-native" |
11 | 11 | ||
12 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 12 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
13 | 13 | ||
@@ -23,6 +23,7 @@ SRC_URI = "git://github.com/freeDiameter/freeDiameter;protocol=https;branch=mast | |||
23 | file://freeDiameter.conf \ | 23 | file://freeDiameter.conf \ |
24 | file://install_test.patch \ | 24 | file://install_test.patch \ |
25 | file://0001-tests-use-EXTENSIONS_DIR.patch \ | 25 | file://0001-tests-use-EXTENSIONS_DIR.patch \ |
26 | file://0001-bison-flex-Add-flags-for-carrying-user-specified-par.patch \ | ||
26 | " | 27 | " |
27 | 28 | ||
28 | S = "${WORKDIR}/git" | 29 | S = "${WORKDIR}/git" |
@@ -49,6 +50,8 @@ EXTRA_OECMAKE = " \ | |||
49 | -DEXTENSIONS_DIR:PATH=${libdir}/${fd_pkgname} \ | 50 | -DEXTENSIONS_DIR:PATH=${libdir}/${fd_pkgname} \ |
50 | -DINSTALL_TEST_SUFFIX:PATH=${PTEST_PATH}-tests \ | 51 | -DINSTALL_TEST_SUFFIX:PATH=${PTEST_PATH}-tests \ |
51 | -DCMAKE_SKIP_RPATH:BOOL=ON \ | 52 | -DCMAKE_SKIP_RPATH:BOOL=ON \ |
53 | -DFLEX_TARGET_ARG_COMPILE_FLAGS='--noline' \ | ||
54 | -DBISON_TARGET_ARG_COMPILE_FLAGS='--no-lines' \ | ||
52 | " | 55 | " |
53 | # INSTALL_LIBRARY_SUFFIX is relative to CMAKE_INSTALL_PREFIX | 56 | # INSTALL_LIBRARY_SUFFIX is relative to CMAKE_INSTALL_PREFIX |
54 | # specify it on cmd line will fix the SET bug in CMakeList.txt | 57 | # specify it on cmd line will fix the SET bug in CMakeList.txt |
@@ -107,15 +110,13 @@ EOF | |||
107 | # create self cert | 110 | # create self cert |
108 | openssl req -x509 -config ${STAGING_DIR_NATIVE}/etc/ssl/openssl.cnf -newkey rsa:4096 -sha256 -nodes -out ${D}${sysconfdir}/freeDiameter/${FD_PEM} -keyout ${D}${sysconfdir}/freeDiameter/${FD_KEY} -days 3650 -subj '/CN=${FD_HOSTNAME}.${FD_REALM}' | 111 | openssl req -x509 -config ${STAGING_DIR_NATIVE}/etc/ssl/openssl.cnf -newkey rsa:4096 -sha256 -nodes -out ${D}${sysconfdir}/freeDiameter/${FD_PEM} -keyout ${D}${sysconfdir}/freeDiameter/${FD_KEY} -days 3650 -subj '/CN=${FD_HOSTNAME}.${FD_REALM}' |
109 | openssl dhparam -out ${D}${sysconfdir}/freeDiameter/${FD_DH_PEM} 1024 | 112 | openssl dhparam -out ${D}${sysconfdir}/freeDiameter/${FD_DH_PEM} 1024 |
110 | |||
111 | find ${B} \( -name "*.c" -o -name "*.h" \) -exec sed -i -e 's#${UNPACKDIR}##g' {} \; | ||
112 | } | 113 | } |
113 | 114 | ||
114 | do_install_ptest() { | 115 | do_install_ptest() { |
115 | mv ${D}${PTEST_PATH}-tests/* ${D}${PTEST_PATH}/ | 116 | mv ${D}${PTEST_PATH}-tests/* ${D}${PTEST_PATH}/ |
116 | rmdir ${D}${PTEST_PATH}-tests | 117 | rmdir ${D}${PTEST_PATH}-tests |
117 | install -m 0644 ${B}/tests/CTestTestfile.cmake ${D}${PTEST_PATH}/ | 118 | install -m 0644 ${B}/tests/CTestTestfile.cmake ${D}${PTEST_PATH}/ |
118 | sed -i -e 's#${UNPACKDIR}##g' ${D}${PTEST_PATH}/CTestTestfile.cmake | 119 | sed -i -e 's#${WORKDIR}##g' ${D}${PTEST_PATH}/CTestTestfile.cmake |
119 | sed -i "/^set_tests_properties/d" ${D}${PTEST_PATH}/CTestTestfile.cmake | 120 | sed -i "/^set_tests_properties/d" ${D}${PTEST_PATH}/CTestTestfile.cmake |
120 | } | 121 | } |
121 | 122 | ||