summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-protocols/quagga/quagga.inc
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2016-12-29 14:11:23 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-01-19 09:26:15 +0100
commit807be0aeed9706f2c8b95340a9b4c391e8513200 (patch)
tree258b3cecac78704e0be6326801528ee8299b4a85 /meta-networking/recipes-protocols/quagga/quagga.inc
parentc0ff097fae3c7ad35a7cbdf4170363875316271c (diff)
downloadmeta-openembedded-807be0aeed9706f2c8b95340a9b4c391e8513200.tar.gz
quagga: update to 1.1.0
* remove the following 3 patches which already fixed in upstream: 0001-ospf6d-check-ospf6-before-using-it-in-ospf6_clean.patch quagga-Avoid-duplicate-connected-address.patch ripd-fix-two-bugs-after-received-SIGHUP.patch * inherit pkgconfig to fix configure errors: | configure.ac:97: error: possibly undefined macro: AC_MSG_RESULT | If this token and others are legitimate, please use m4_pattern_allow. | See the Autoconf documentation. * add user quagga to quaggavty supplementary group to fix startup error: Starting Quagga daemons: zebra privs_init: user(quagga) is not part of vty group specified(quaggavty) * remove babeld related code from initscript becasue it had been removed from quagga Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-protocols/quagga/quagga.inc')
-rw-r--r--meta-networking/recipes-protocols/quagga/quagga.inc6
1 files changed, 2 insertions, 4 deletions
diff --git a/meta-networking/recipes-protocols/quagga/quagga.inc b/meta-networking/recipes-protocols/quagga/quagga.inc
index ae08a2d32..bf0b89efd 100644
--- a/meta-networking/recipes-protocols/quagga/quagga.inc
+++ b/meta-networking/recipes-protocols/quagga/quagga.inc
@@ -28,8 +28,6 @@ SRC_URI = "${SAVANNAH_GNU_MIRROR}/quagga${QUAGGASUBDIR}/quagga-${PV}.tar.gz; \
28 file://watchquagga.default \ 28 file://watchquagga.default \
29 file://volatiles.03_quagga \ 29 file://volatiles.03_quagga \
30 file://quagga.pam \ 30 file://quagga.pam \
31 file://ripd-fix-two-bugs-after-received-SIGHUP.patch \
32 file://quagga-Avoid-duplicate-connected-address.patch \
33 file://bgpd.service \ 31 file://bgpd.service \
34 file://isisd.service \ 32 file://isisd.service \
35 file://ospf6d.service \ 33 file://ospf6d.service \
@@ -43,7 +41,7 @@ PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)}
43PACKAGECONFIG[cap] = "--enable-capabilities,--disable-capabilities,libcap" 41PACKAGECONFIG[cap] = "--enable-capabilities,--disable-capabilities,libcap"
44PACKAGECONFIG[pam] = "--with-libpam, --without-libpam, libpam" 42PACKAGECONFIG[pam] = "--with-libpam, --without-libpam, libpam"
45 43
46inherit autotools update-rc.d useradd systemd 44inherit autotools update-rc.d useradd systemd pkgconfig
47 45
48SYSTEMD_PACKAGES = "${PN} ${PN}-bgpd ${PN}-isisd ${PN}-ospf6d ${PN}-ospfd ${PN}-ripd ${PN}-ripngd" 46SYSTEMD_PACKAGES = "${PN} ${PN}-bgpd ${PN}-isisd ${PN}-ospf6d ${PN}-ospfd ${PN}-ripd ${PN}-ripngd"
49SYSTEMD_SERVICE_${PN}-bgpd = "bgpd.service" 47SYSTEMD_SERVICE_${PN}-bgpd = "bgpd.service"
@@ -202,7 +200,7 @@ INITSCRIPT_PARAMS_${PN}-watchquagga = "defaults 90 10"
202# Add quagga's user and group 200# Add quagga's user and group
203USERADD_PACKAGES = "${PN}" 201USERADD_PACKAGES = "${PN}"
204GROUPADD_PARAM_${PN} = "--system quagga ; --system quaggavty" 202GROUPADD_PARAM_${PN} = "--system quagga ; --system quaggavty"
205USERADD_PARAM_${PN} = "--system --home ${localstatedir}/run/quagga/ -M -g quagga --shell /bin/false quagga" 203USERADD_PARAM_${PN} = "--system --home ${localstatedir}/run/quagga/ -M -g quagga -G quaggavty --shell /bin/false quagga"
206 204
207pkg_postinst_${PN} () { 205pkg_postinst_${PN} () {
208 if [ -z "$D" ] && [ -e /etc/init.d/populate-volatile.sh ] ; then 206 if [ -z "$D" ] && [ -e /etc/init.d/populate-volatile.sh ] ; then