diff options
author | Khem Raj <raj.khem@gmail.com> | 2022-10-04 09:27:39 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-10-04 09:29:47 -0700 |
commit | 111e73d7128ec7d0fc2720b3a7a9ec714f14a061 (patch) | |
tree | 0f37741cc06ff64cf465bd12a2c88520b6dc05a2 /meta-networking/recipes-protocols/opcua | |
parent | 3d65e0460ca72ac6b9a91fc2a5fd1cf6665cdeb9 (diff) | |
download | meta-openembedded-111e73d7128ec7d0fc2720b3a7a9ec714f14a061.tar.gz |
open62541: Disable lto on riscv/clang
clang errors out linking lto objects
riscv64-yoe-linux-musl-ld: /tmp/lto-llvm-d497c5.o: can't link soft-float modules with double-float modules
This is something needs to be addressed in clang for riscv
as of now disable lto for rv32/rv64 when using clang
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-protocols/opcua')
-rw-r--r-- | meta-networking/recipes-protocols/opcua/open62541_1.3.3.bb | 9 |
1 files changed, 9 insertions, 0 deletions
diff --git a/meta-networking/recipes-protocols/opcua/open62541_1.3.3.bb b/meta-networking/recipes-protocols/opcua/open62541_1.3.3.bb index 317697262c..5af856ad34 100644 --- a/meta-networking/recipes-protocols/opcua/open62541_1.3.3.bb +++ b/meta-networking/recipes-protocols/opcua/open62541_1.3.3.bb | |||
@@ -36,3 +36,12 @@ PACKAGECONFIG[amalgamation] = "-DUA_ENABLE_AMALGAMATION=ON, -DUA_ENABLE_AMALGAMA | |||
36 | PACKAGECONFIG[encryption] = "-DUA_ENABLE_ENCRYPTION=ON, -DUA_ENABLE_ENCRYPTION=OFF, mbedtls" | 36 | PACKAGECONFIG[encryption] = "-DUA_ENABLE_ENCRYPTION=ON, -DUA_ENABLE_ENCRYPTION=OFF, mbedtls" |
37 | PACKAGECONFIG[pubsub] = "-DUA_ENABLE_PUBSUB=ON, -DUA_ENABLE_PUBSUB=OFF" | 37 | PACKAGECONFIG[pubsub] = "-DUA_ENABLE_PUBSUB=ON, -DUA_ENABLE_PUBSUB=OFF" |
38 | PACKAGECONFIG[pubsub-eth] = "-DUA_ENABLE_PUBSUB_ETH_UADP=ON, -DUA_ENABLE_PUBSUB_ETH_UADP=OFF" | 38 | PACKAGECONFIG[pubsub-eth] = "-DUA_ENABLE_PUBSUB_ETH_UADP=ON, -DUA_ENABLE_PUBSUB_ETH_UADP=OFF" |
39 | |||
40 | do_configure:prepend:toolchain-clang:riscv64() { | ||
41 | sed -i -e 's/set(CMAKE_INTERPROCEDURAL_OPTIMIZATION ON)/set(CMAKE_INTERPROCEDURAL_OPTIMIZATION OFF)/' ${S}/CMakeLists.txt | ||
42 | } | ||
43 | |||
44 | do_configure:prepend:toolchain-clang:riscv32() { | ||
45 | sed -i -e 's/set(CMAKE_INTERPROCEDURAL_OPTIMIZATION ON)/set(CMAKE_INTERPROCEDURAL_OPTIMIZATION OFF)/' ${S}/CMakeLists.txt | ||
46 | } | ||
47 | |||