summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-netkit
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-05-11 20:07:51 -0700
committerArmin Kuster <akuster808@gmail.com>2018-05-17 08:32:26 -0700
commitf1230ec9b1cf5f689e8c362582044415f131a4f8 (patch)
tree3d43bd530e7cc900d07ae2dbfe5632545f8afe78 /meta-networking/recipes-netkit
parent9ad55bf1e6d4c7b0cc58d44a011f387aa5a69dc3 (diff)
downloadmeta-openembedded-f1230ec9b1cf5f689e8c362582044415f131a4f8.tar.gz
netkit-rusers: Fix build when libc does not have nis builtin
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-networking/recipes-netkit')
-rw-r--r--meta-networking/recipes-netkit/netkit-rusers/netkit-rusers/0001-Link-with-libtirpc.patch79
-rw-r--r--meta-networking/recipes-netkit/netkit-rusers/netkit-rusers_0.17.bb2
2 files changed, 81 insertions, 0 deletions
diff --git a/meta-networking/recipes-netkit/netkit-rusers/netkit-rusers/0001-Link-with-libtirpc.patch b/meta-networking/recipes-netkit/netkit-rusers/netkit-rusers/0001-Link-with-libtirpc.patch
new file mode 100644
index 000000000..55926468d
--- /dev/null
+++ b/meta-networking/recipes-netkit/netkit-rusers/netkit-rusers/0001-Link-with-libtirpc.patch
@@ -0,0 +1,79 @@
1From 5746b68ba9dda87586b3ac88fe84031cbc0015f7 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 11 May 2018 12:20:03 -0700
4Subject: [PATCH] Link with libtirpc
5
6Signed-off-by: Khem Raj <raj.khem@gmail.com>
7---
8Upstream-Status: Pending
9
10 configure | 2 +-
11 rpc.rusersd/rusers_proc.c | 7 +------
12 rpc.rusersd/rusersd.c | 6 +-----
13 rup/rup.c | 2 +-
14 4 files changed, 4 insertions(+), 13 deletions(-)
15
16diff --git a/configure b/configure
17index 85f6ca6..2d2d4b7 100755
18--- a/configure
19+++ b/configure
20@@ -147,7 +147,7 @@ else
21 fi
22
23 LDFLAGS=
24-LIBS=
25+LIBS="-ltirpc"
26
27 rm -f __conftest*
28
29diff --git a/rpc.rusersd/rusers_proc.c b/rpc.rusersd/rusers_proc.c
30index 9ae6306..f9e237c 100644
31--- a/rpc.rusersd/rusers_proc.c
32+++ b/rpc.rusersd/rusers_proc.c
33@@ -57,12 +57,7 @@ char rp_rcsid[] =
34 #define RUT_TIME ut_time
35 #endif
36
37-/* Glibc strikes again */
38-#ifdef __GLIBC__
39- #include <rpcsvc/rusers.h>
40-#else
41- #include "rusers.h"
42-#endif
43+#include "rusers.h"
44
45 void rusers_service(struct svc_req *rqstp, SVCXPRT *transp);
46
47diff --git a/rpc.rusersd/rusersd.c b/rpc.rusersd/rusersd.c
48index 762be9b..dd355ac 100644
49--- a/rpc.rusersd/rusersd.c
50+++ b/rpc.rusersd/rusersd.c
51@@ -38,11 +38,7 @@ char rusersd_rcsid[] =
52 #include <rpc/pmap_clnt.h>
53 #include <unistd.h>
54 #include <grp.h>
55-#ifdef __GLIBC__
56- #include <rpcsvc/rusers.h>
57-#else
58- #include "rusers.h"
59-#endif
60+#include "rusers.h"
61
62 #include "../version.h"
63
64diff --git a/rup/rup.c b/rup/rup.c
65index e5669ff..887f89d 100644
66--- a/rup/rup.c
67+++ b/rup/rup.c
68@@ -48,7 +48,7 @@ char rcsid[] = "$Id: rup.c,v 1.8 2000/07/22 19:51:40 dholland Exp $";
69
70 #undef FSHIFT /* Use protocol's shift and scale values */
71 #undef FSCALE
72-#include <rpcsvc/rstat.h>
73+#include "rstat.h"
74
75 #include "../version.h"
76
77--
782.17.0
79
diff --git a/meta-networking/recipes-netkit/netkit-rusers/netkit-rusers_0.17.bb b/meta-networking/recipes-netkit/netkit-rusers/netkit-rusers_0.17.bb
index a7d19182c..113f89b7f 100644
--- a/meta-networking/recipes-netkit/netkit-rusers/netkit-rusers_0.17.bb
+++ b/meta-networking/recipes-netkit/netkit-rusers/netkit-rusers_0.17.bb
@@ -9,6 +9,7 @@ DEPENDS = " tcp-wrappers libtirpc rpcbind"
9SRC_URI = "http://http.debian.net/debian/pool/main/n/${BPN}/${BPN}_${PV}.orig.tar.gz;name=archive \ 9SRC_URI = "http://http.debian.net/debian/pool/main/n/${BPN}/${BPN}_${PV}.orig.tar.gz;name=archive \
10 http://http.debian.net/debian/pool/main/n/${BPN}/${BPN}_${PV}-8.diff.gz;name=patch8 \ 10 http://http.debian.net/debian/pool/main/n/${BPN}/${BPN}_${PV}-8.diff.gz;name=patch8 \
11 file://rpc.rusersd-Makefile-fix-parallel-build-issue.patch \ 11 file://rpc.rusersd-Makefile-fix-parallel-build-issue.patch \
12 file://0001-Link-with-libtirpc.patch \
12" 13"
13 14
14SRC_URI[archive.md5sum] = "dc99a80b9fde2ab427c874f88f1c1602" 15SRC_URI[archive.md5sum] = "dc99a80b9fde2ab427c874f88f1c1602"
@@ -25,6 +26,7 @@ do_configure () {
25 ./configure --prefix=${prefix} 26 ./configure --prefix=${prefix}
26 echo "LDFLAGS=${LDFLAGS}" >> MCONFIG 27 echo "LDFLAGS=${LDFLAGS}" >> MCONFIG
27 echo "USE_GLIBC=1" >> MCONFIG 28 echo "USE_GLIBC=1" >> MCONFIG
29 echo "LIBS=${LIBS}" >> MCONFIG
28} 30}
29 31
30do_install () { 32do_install () {