diff options
author | Armin Kuster <akuster808@gmail.com> | 2016-05-23 21:30:34 -0700 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2016-06-01 19:35:50 -0400 |
commit | 62e3df2ddbeff9f2293027af6f159260cd2ab134 (patch) | |
tree | 028b4d7e555d1205d3beef444deaf2c1e44a5c60 /meta-networking/recipes-netkit | |
parent | 880c3dce369255e468cdd8dc0be6e15e913f806c (diff) | |
download | meta-openembedded-62e3df2ddbeff9f2293027af6f159260cd2ab134.tar.gz |
netkit-rsh: fix build issue.
glibc deprecate union wait and remove support from wait functions
https://sourceware.org/ml/libc-alpha/2016-02/msg00342.html
change rlogin.c accordingly
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-netkit')
-rw-r--r-- | meta-networking/recipes-netkit/netkit-rsh/netkit-rsh/fixup_wait3_api_change.patch | 34 | ||||
-rw-r--r-- | meta-networking/recipes-netkit/netkit-rsh/netkit-rsh_0.17.bb | 1 |
2 files changed, 35 insertions, 0 deletions
diff --git a/meta-networking/recipes-netkit/netkit-rsh/netkit-rsh/fixup_wait3_api_change.patch b/meta-networking/recipes-netkit/netkit-rsh/netkit-rsh/fixup_wait3_api_change.patch new file mode 100644 index 0000000000..cd6df62fb3 --- /dev/null +++ b/meta-networking/recipes-netkit/netkit-rsh/netkit-rsh/fixup_wait3_api_change.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | Fix build issue do to Deprecate union wait and remove support from wait functions [BZ #19613] | ||
2 | |||
3 | | rlogin.c: In function 'catch_child': | ||
4 | | rlogin.c:463:13: error: storage size of 'status' isn't known | ||
5 | | union wait status; | ||
6 | |||
7 | https://sourceware.org/ml/libc-alpha/2016-02/msg00342.html | ||
8 | |||
9 | Upstream-Status: Inappropriate [ no upstream maintaner ] | ||
10 | |||
11 | Signed-off-by Armin Kuster <akuster@mvista.com> | ||
12 | |||
13 | Index: netkit-rsh-0.17/rlogin/rlogin.c | ||
14 | =================================================================== | ||
15 | --- netkit-rsh-0.17.orig/rlogin/rlogin.c | ||
16 | +++ netkit-rsh-0.17/rlogin/rlogin.c | ||
17 | @@ -460,7 +460,7 @@ writeroob(int ignore) | ||
18 | void | ||
19 | catch_child(int ignore) | ||
20 | { | ||
21 | - union wait status; | ||
22 | + int status; | ||
23 | int pid; | ||
24 | |||
25 | (void)ignore; | ||
26 | @@ -471,7 +471,7 @@ catch_child(int ignore) | ||
27 | return; | ||
28 | /* if the child (reader) dies, just quit */ | ||
29 | if (pid < 0 || (pid == childpid && !WIFSTOPPED(status))) | ||
30 | - done((int)(status.w_termsig | status.w_retcode)); | ||
31 | + done((int)(WTERMSIG(status) | WEXITSTATUS(status))); | ||
32 | } | ||
33 | /* NOTREACHED */ | ||
34 | } | ||
diff --git a/meta-networking/recipes-netkit/netkit-rsh/netkit-rsh_0.17.bb b/meta-networking/recipes-netkit/netkit-rsh/netkit-rsh_0.17.bb index 66bb4cce3d..4803d7b807 100644 --- a/meta-networking/recipes-netkit/netkit-rsh/netkit-rsh_0.17.bb +++ b/meta-networking/recipes-netkit/netkit-rsh/netkit-rsh_0.17.bb | |||
@@ -15,6 +15,7 @@ SRC_URI = "${DEBIAN_MIRROR}/main/n/netkit-rsh/netkit-rsh_${PV}.orig.tar.gz;name= | |||
15 | file://rsh.xinetd.netkit \ | 15 | file://rsh.xinetd.netkit \ |
16 | file://netkit-rsh-0.17-rexec-ipv6.patch \ | 16 | file://netkit-rsh-0.17-rexec-ipv6.patch \ |
17 | file://fix-host-variable.patch \ | 17 | file://fix-host-variable.patch \ |
18 | file://fixup_wait3_api_change.patch \ | ||
18 | " | 19 | " |
19 | 20 | ||
20 | SRC_URI[archive.md5sum] = "65f5f28e2fe22d9ad8b17bb9a10df096" | 21 | SRC_URI[archive.md5sum] = "65f5f28e2fe22d9ad8b17bb9a10df096" |