summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-netkit
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-04-22 20:48:50 +0100
committerJoe MacDonald <joe_macdonald@mentor.com>2016-05-05 11:41:28 -0400
commit275b6c30fbe4f2e6d8c607e9f2eedd5c230c0802 (patch)
tree4fd20a242b848ec8497066801b86706de3defdce /meta-networking/recipes-netkit
parent7a9c626092c7d3b10206c7ca4ea2827cca9cba4f (diff)
downloadmeta-openembedded-275b6c30fbe4f2e6d8c607e9f2eedd5c230c0802.tar.gz
meta-networking: use bb.utils.contains() instead of base_contains()
base_contains() is a compatibility wrapper and may warn in the future, so replace all instances with bb.utils.contains(). Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-netkit')
-rw-r--r--meta-networking/recipes-netkit/netkit-rsh/netkit-rsh_0.17.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-networking/recipes-netkit/netkit-rsh/netkit-rsh_0.17.bb b/meta-networking/recipes-netkit/netkit-rsh/netkit-rsh_0.17.bb
index e29369c49..66bb4cce3 100644
--- a/meta-networking/recipes-netkit/netkit-rsh/netkit-rsh_0.17.bb
+++ b/meta-networking/recipes-netkit/netkit-rsh/netkit-rsh_0.17.bb
@@ -26,7 +26,7 @@ SRC_URI[patch15.sha256sum] = "2bc071c438e8b0ed42a0bd2db2d8b681b27a1e9b1798694d98
26PAM_SRC_URI = "file://rexec.pam \ 26PAM_SRC_URI = "file://rexec.pam \
27 file://rlogin.pam \ 27 file://rlogin.pam \
28 file://rsh.pam" 28 file://rsh.pam"
29SRC_URI += "${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)}" 29SRC_URI += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)}"
30 30
31inherit pkgconfig 31inherit pkgconfig
32 32
@@ -41,7 +41,7 @@ do_configure () {
41 ./configure --prefix=${prefix} --exec-prefix=${exec_prefix} 41 ./configure --prefix=${prefix} --exec-prefix=${exec_prefix}
42 echo "INSTALLROOT=${D}" > MCONFIG 42 echo "INSTALLROOT=${D}" > MCONFIG
43 43
44 if [ "${@base_contains('PACKAGECONFIG', 'pam', 'pam', '', d)}" != "" ]; then 44 if [ "${@bb.utils.contains('PACKAGECONFIG', 'pam', 'pam', '', d)}" != "" ]; then
45 echo "USE_PAM=1" >> MCONFIG 45 echo "USE_PAM=1" >> MCONFIG
46 fi 46 fi
47 47
@@ -63,7 +63,7 @@ do_install () {
63 'BINDIR=${bindir}' 'SBINDIR=${sbindir}' \ 63 'BINDIR=${bindir}' 'SBINDIR=${sbindir}' \
64 'MANDIR=${mandir}' install 64 'MANDIR=${mandir}' install
65 65
66 if [ "${@base_contains('PACKAGECONFIG', 'pam', 'pam', '', d)}" != "" ]; then 66 if [ "${@bb.utils.contains('PACKAGECONFIG', 'pam', 'pam', '', d)}" != "" ]; then
67 install -d ${D}${sysconfdir}/pam.d 67 install -d ${D}${sysconfdir}/pam.d
68 install -m 0644 debian/hosts.equiv ${D}/${sysconfdir} 68 install -m 0644 debian/hosts.equiv ${D}/${sysconfdir}
69 install -m 0644 ${WORKDIR}/rexec.pam ${D}/${sysconfdir}/pam.d/rexec 69 install -m 0644 ${WORKDIR}/rexec.pam ${D}/${sysconfdir}/pam.d/rexec