summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-netkit
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2014-12-13 10:03:32 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-12-19 20:10:56 +0100
commit2114db3000396d849f0a13501151f60cf717afab (patch)
tree17af333bfd3edcf1879333f30781507ab1bbd150 /meta-networking/recipes-netkit
parentaf8ff37714da2f9b231014bbf1d5be30536ddc1d (diff)
downloadmeta-openembedded-2114db3000396d849f0a13501151f60cf717afab.tar.gz
netkit-tftp: new package
Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-netkit')
-rw-r--r--meta-networking/recipes-netkit/netkit-tftp/netkit-tftp/tftp.conf11
-rw-r--r--meta-networking/recipes-netkit/netkit-tftp/netkit-tftp_0.17.bb54
2 files changed, 65 insertions, 0 deletions
diff --git a/meta-networking/recipes-netkit/netkit-tftp/netkit-tftp/tftp.conf b/meta-networking/recipes-netkit/netkit-tftp/netkit-tftp/tftp.conf
new file mode 100644
index 000000000..7bc6ca96b
--- /dev/null
+++ b/meta-networking/recipes-netkit/netkit-tftp/netkit-tftp/tftp.conf
@@ -0,0 +1,11 @@
1service tftp
2{
3 disable = no
4 socket_type = dgram
5 port = 69
6 protocol = udp
7 wait = yes
8 user = nobody
9 server = /usr/sbin/in.tftpd
10 server_args = /tftpboot
11}
diff --git a/meta-networking/recipes-netkit/netkit-tftp/netkit-tftp_0.17.bb b/meta-networking/recipes-netkit/netkit-tftp/netkit-tftp_0.17.bb
new file mode 100644
index 000000000..bd54c0a81
--- /dev/null
+++ b/meta-networking/recipes-netkit/netkit-tftp/netkit-tftp_0.17.bb
@@ -0,0 +1,54 @@
1SUMMARY = "tftp - Trivial file transfer protocol client"
2SECTION = "networking"
3LICENSE = "BSD-4-Clause"
4DEPENDS = "tcp-wrappers"
5
6LIC_FILES_CHKSUM = "file://tftp/tftp.c;beginline=2;endline=3;md5=84d2cfe1e60863a7d82648734ba4d30c"
7
8SRC_URI = "${DEBIAN_MIRROR}/main/n/${BPN}/${BPN}_${PV}.orig.tar.gz;name=archive \
9 ${DEBIAN_MIRROR}/main/n/${BPN}/${BPN}_${PV}-18.diff.gz;name=patch18 \
10 file://tftp.conf \
11"
12
13SRC_URI[archive.md5sum] = "b7262c798e2ff50e29c2ff50dfd8d6a8"
14SRC_URI[archive.sha256sum] = "3a43c0010d4e61f412563fd83769d4667d8b8e82903526d21cb9205fe55ad14d"
15SRC_URI[patch18.md5sum] = "cb29e7a33dd85105ba6e6ec4f971e42c"
16SRC_URI[patch18.sha256sum] = "092437d27b4fa88c044ef6290372fee5ce06d223607f0e22a6e527065c8930e7"
17
18inherit autotools-brokensep
19
20do_configure () {
21 ./configure --prefix=${prefix}
22 echo "CFLAGS=${CFLAGS}" > MCONFIG
23}
24
25do_compile () {
26 oe_runmake 'CC=${CC}' 'LD=${LD}' 'LDFLAGS=${LDFLAGS}' 'CFLAGS=${CFLAGS}'
27}
28
29do_install () {
30 install -d ${D}${bindir}
31 install -d ${D}${sbindir}
32 install -d ${D}${mandir}/man1
33 install -d ${D}${mandir}/man8
34 install -d ${D}${sysconfdir}/xinetd.d
35
36 sed -i 's/install -s/install/' tftp/Makefile
37 sed -i 's/install -s/install/' tftpd/Makefile
38
39 oe_runmake 'INSTALLROOT=${D}' 'BINMODE=0755' \
40 'DAEMONMODE=0755' 'MANMODE=0644' \
41 'BINDIR=${bindir}' 'SBINDIR=${sbindir}' \
42 'MANDIR=${mandir}' install
43
44 install ${WORKDIR}/tftp.conf ${D}/${sysconfdir}/xinetd.d/tftp
45}
46
47PACKAGES = "${PN}-client ${PN}-server ${PN}-doc ${BPN}-dbg"
48FILES_${PN}-client = "${bindir}/*"
49FILES_${PN}-server = "${sbindir}/* ${sysconfdir}/xinetd.d/*"
50FILES_${PN}-doc = "${mandir}"
51FILES_${PN}-dbg = "${prefix}/src/debug \
52 ${bindir}/.debug ${sbindir}/.debug"
53
54RDEPENDS_${PN}-server = "tcp-wrappers xinetd"