summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-netkit
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2015-04-16 16:35:05 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-05-11 10:25:52 +0200
commit02436486ba62ac6a4489eb2cc3428b140d9e8422 (patch)
treeb8e419a69b2899b4e590b9bea620c84cf7859f2d /meta-networking/recipes-netkit
parent91fd102139313dcc7acc50e0aa54b936c46746d4 (diff)
downloadmeta-openembedded-02436486ba62ac6a4489eb2cc3428b140d9e8422.tar.gz
netkit-telnet: support the cross-compile
when check the CC, only compile the object by CC, not run the object. MCONFIG file includes more configuration, we can not clear it Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-netkit')
-rw-r--r--meta-networking/recipes-netkit/netkit-telnet/files/cross-compile.patch48
-rw-r--r--meta-networking/recipes-netkit/netkit-telnet/netkit-telnet_0.17.bb6
2 files changed, 53 insertions, 1 deletions
diff --git a/meta-networking/recipes-netkit/netkit-telnet/files/cross-compile.patch b/meta-networking/recipes-netkit/netkit-telnet/files/cross-compile.patch
new file mode 100644
index 000000000..b3fe36b7b
--- /dev/null
+++ b/meta-networking/recipes-netkit/netkit-telnet/files/cross-compile.patch
@@ -0,0 +1,48 @@
1To support the cross-compile
2
3Upstream-Status: Pending
4
5make the configure to support the cross-compile, by only to compile the
6target, and not to run it
7
8Roy Li <rongqing.li@windriver.com>
9Index: netkit-telnet-0.17/configure
10===================================================================
11--- netkit-telnet-0.17.orig/configure 2008-11-23 22:01:26.000000000 +0100
12+++ netkit-telnet-0.17/configure 2008-11-23 22:05:00.000000000 +0100
13@@ -94,7 +94,7 @@
14 echo -n 'Checking if C compiler works... '
15 if (
16 $CC __conftest.c -o __conftest || exit 1
17- ./__conftest || exit 1
18+ # Idiots belong shot! ./__conftest || exit 1
19 ) >/dev/null 2>&1; then
20 echo 'yes'
21 else
22@@ -141,7 +141,7 @@
23 echo -n 'Checking if C++ compiler works... '
24 if (
25 $CXX __conftest.cc -o __conftest || exit 1
26- ./__conftest || exit 1
27+ # Iditios belong shot! ./__conftest || exit 1
28 ) >/dev/null 2>&1; then
29 echo 'yes'
30 else
31@@ -284,7 +284,7 @@
32 else
33 if (
34 $CXX $CXXFLAGS -D__USE_BSD_SIGNAL __conftest.cc -o __conftest || exit 1
35- ./__conftest || exit 1
36+ # running still does not work./__conftest || exit 1
37 ) >/dev/null 2>&1; then
38 echo '-D__USE_BSD_SIGNAL'
39 CFLAGS="$CFLAGS -D__USE_BSD_SIGNAL"
40@@ -501,7 +501,7 @@
41 EOF
42 if (
43 $CXX $CXXFLAGS __conftest.cc $LIBBSD -o __conftest || exit 1
44- ./__conftest || exit 1
45+ # argh! morons!./__conftest || exit 1
46 ) >/dev/null 2>&1; then
47 echo 'ok'
48 else
diff --git a/meta-networking/recipes-netkit/netkit-telnet/netkit-telnet_0.17.bb b/meta-networking/recipes-netkit/netkit-telnet/netkit-telnet_0.17.bb
index a2dc1c270..6b2e72f8e 100644
--- a/meta-networking/recipes-netkit/netkit-telnet/netkit-telnet_0.17.bb
+++ b/meta-networking/recipes-netkit/netkit-telnet/netkit-telnet_0.17.bb
@@ -8,6 +8,7 @@ SRC_URI = "ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/${BP}.tar.gz \
8 file://To-aviod-buffer-overflow-in-telnet.patch \ 8 file://To-aviod-buffer-overflow-in-telnet.patch \
9 file://Warning-fix-in-the-step-of-install.patch \ 9 file://Warning-fix-in-the-step-of-install.patch \
10 file://telnet-xinetd \ 10 file://telnet-xinetd \
11 file://cross-compile.patch \
11" 12"
12 13
13EXTRA_OEMAKE = "INSTALLROOT=${D} SBINDIR=${sbindir} DAEMONMODE=755 \ 14EXTRA_OEMAKE = "INSTALLROOT=${D} SBINDIR=${sbindir} DAEMONMODE=755 \
@@ -15,7 +16,10 @@ EXTRA_OEMAKE = "INSTALLROOT=${D} SBINDIR=${sbindir} DAEMONMODE=755 \
15 16
16do_configure () { 17do_configure () {
17 ./configure --prefix=${prefix} 18 ./configure --prefix=${prefix}
18 echo "LDFLAGS=${LDFLAGS}" > MCONFIG 19 sed -e 's#^CFLAGS=\(.*\)$#CFLAGS= -D_GNU_SOURCE \1#' \
20 -e 's#^CXXFLAGS=\(.*\)$#CXXFLAGS= -D_GNU_SOURCE \1#' \
21 -e 's#^LDFLAGS=.*$#LDFLAGS= ${LDFLAGS}#' \
22 -i MCONFIG
19} 23}
20 24
21do_compile () { 25do_compile () {