summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-kernel
diff options
context:
space:
mode:
authorDaiane Angolini <daiane.angolini@foundries.io>2023-11-09 09:04:35 -0300
committerKhem Raj <raj.khem@gmail.com>2023-11-09 20:47:44 -0800
commit865411fbde1f3489e77ad186e669b5c315485ce1 (patch)
treeb4a5f1003e7ae6344b720769541d3ab8d6d2ea57 /meta-networking/recipes-kernel
parent9281dbcc217c3517e45106af36ae422f5af01d65 (diff)
downloadmeta-openembedded-865411fbde1f3489e77ad186e669b5c315485ce1.tar.gz
wireguard-tools: Use PACKAGECONFIG to select wg-quick and bash-completion
Condition the creation of some files and their consequences to a PACKAGECONFIG, which can be overridden outside the meta layer. It removes the sub package wireguard-tools-wg-quick as PACKAGECONFIG is supposed to work to configure a package only, and not deal with sub packages. Signed-off-by: Daiane Angolini <daiane.angolini@foundries.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-kernel')
-rw-r--r--meta-networking/recipes-kernel/wireguard/wireguard-tools_1.0.20210914.bb12
1 files changed, 5 insertions, 7 deletions
diff --git a/meta-networking/recipes-kernel/wireguard/wireguard-tools_1.0.20210914.bb b/meta-networking/recipes-kernel/wireguard/wireguard-tools_1.0.20210914.bb
index 20435338c..8def54ece 100644
--- a/meta-networking/recipes-kernel/wireguard/wireguard-tools_1.0.20210914.bb
+++ b/meta-networking/recipes-kernel/wireguard/wireguard-tools_1.0.20210914.bb
@@ -11,24 +11,22 @@ do_install () {
11 oe_runmake DESTDIR="${D}" PREFIX="${prefix}" SYSCONFDIR="${sysconfdir}" \ 11 oe_runmake DESTDIR="${D}" PREFIX="${prefix}" SYSCONFDIR="${sysconfdir}" \
12 SYSTEMDUNITDIR="${systemd_system_unitdir}" \ 12 SYSTEMDUNITDIR="${systemd_system_unitdir}" \
13 WITH_SYSTEMDUNITS=${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'yes', '', d)} \ 13 WITH_SYSTEMDUNITS=${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'yes', '', d)} \
14 WITH_BASHCOMPLETION=yes \ 14 ${PACKAGECONFIG_CONFARGS} \
15 WITH_WGQUICK=yes \
16 install 15 install
17} 16}
18 17
19PACKAGES += "${PN}-wg-quick" 18PACKAGECONFIG ??= "bash-completion wg-quick"
19
20PACKAGECONFIG[bash-completion] = "WITH_BASHCOMPLETION=yes,WITH_BASHCOMPLETION=no,,bash,,"
21PACKAGECONFIG[wg-quick] = "WITH_WGQUICK=yes,WITH_WGQUICK=no,,bash,,"
20 22
21FILES:${PN} = " \ 23FILES:${PN} = " \
22 ${bindir}/wg \ 24 ${bindir}/wg \
23 ${sysconfdir} \ 25 ${sysconfdir} \
24"
25FILES:${PN}-wg-quick = " \
26 ${bindir}/wg-quick \ 26 ${bindir}/wg-quick \
27 ${systemd_system_unitdir} \ 27 ${systemd_system_unitdir} \
28" 28"
29 29
30RDEPENDS:${PN}-wg-quick = "${PN} bash"
31RRECOMMENDS:${PN} = " \ 30RRECOMMENDS:${PN} = " \
32 kernel-module-wireguard \ 31 kernel-module-wireguard \
33 ${PN}-wg-quick \
34 " 32 "