summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-irc
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2015-07-13 15:08:25 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2015-07-30 11:34:07 -0400
commit768811216f87c30b3f41db2cffb2c0a6deaca912 (patch)
tree2ac15354f48d8d26a7b3d77c273fbd628386d07f /meta-networking/recipes-irc
parent8064196b93ca1ce2ad5cea86b84737a77b401c7c (diff)
downloadmeta-openembedded-768811216f87c30b3f41db2cffb2c0a6deaca912.tar.gz
znc: upgrade to 1.6.0
Upgrade to fix CVE-2014-9403 Remove backport patch Add CSocket submodule, which split from znc Add the dependency on icu Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-irc')
-rw-r--r--meta-networking/recipes-irc/znc/znc/0001-Fix-NULL-pointer-dereference-in-webadmin.patch58
-rw-r--r--meta-networking/recipes-irc/znc/znc_git.bb13
2 files changed, 7 insertions, 64 deletions
diff --git a/meta-networking/recipes-irc/znc/znc/0001-Fix-NULL-pointer-dereference-in-webadmin.patch b/meta-networking/recipes-irc/znc/znc/0001-Fix-NULL-pointer-dereference-in-webadmin.patch
deleted file mode 100644
index 68e441470..000000000
--- a/meta-networking/recipes-irc/znc/znc/0001-Fix-NULL-pointer-dereference-in-webadmin.patch
+++ /dev/null
@@ -1,58 +0,0 @@
1Subject: [PATCH] Fix NULL pointer dereference in webadmin.
2
3Upstream-Status: Backport
4
5commit 2bd410ee5570cea127233f1133ea22f25174eb28 upstream
6
7Triggerable by any non-admin, if webadmin is loaded.
8
9The only affected version is 1.0
10
11Thanks to ChauffeR (Simone Esposito) for reporting this.
12---
13 modules/webadmin.cpp | 8 ++++----
14 1 file changed, 4 insertions(+), 4 deletions(-)
15
16diff --git a/modules/webadmin.cpp b/modules/webadmin.cpp
17index b793c02..816f217 100644
18--- a/modules/webadmin.cpp
19+++ b/modules/webadmin.cpp
20@@ -419,7 +419,7 @@ public:
21 CIRCNetwork* pNetwork = SafeGetNetworkFromParam(WebSock);
22
23 // Admin||Self Check
24- if (!spSession->IsAdmin() && (!spSession->GetUser() || spSession->GetUser() != pNetwork->GetUser())) {
25+ if (!spSession->IsAdmin() && (!spSession->GetUser() || !pNetwork || spSession->GetUser() != pNetwork->GetUser())) {
26 return false;
27 }
28
29@@ -448,7 +448,7 @@ public:
30 CIRCNetwork* pNetwork = SafeGetNetworkFromParam(WebSock);
31
32 // Admin||Self Check
33- if (!spSession->IsAdmin() && (!spSession->GetUser() || spSession->GetUser() != pNetwork->GetUser())) {
34+ if (!spSession->IsAdmin() && (!spSession->GetUser() || !pNetwork || spSession->GetUser() != pNetwork->GetUser())) {
35 return false;
36 }
37
38@@ -472,7 +472,7 @@ public:
39 CIRCNetwork* pNetwork = SafeGetNetworkFromParam(WebSock);
40
41 // Admin||Self Check
42- if (!spSession->IsAdmin() && (!spSession->GetUser() || spSession->GetUser() != pNetwork->GetUser())) {
43+ if (!spSession->IsAdmin() && (!spSession->GetUser() || !pNetwork || spSession->GetUser() != pNetwork->GetUser())) {
44 return false;
45 }
46
47@@ -486,7 +486,7 @@ public:
48 CIRCNetwork* pNetwork = SafeGetNetworkFromParam(WebSock);
49
50 // Admin||Self Check
51- if (!spSession->IsAdmin() && (!spSession->GetUser() || spSession->GetUser() != pNetwork->GetUser())) {
52+ if (!spSession->IsAdmin() && (!spSession->GetUser() || !pNetwork || spSession->GetUser() != pNetwork->GetUser())) {
53 return false;
54 }
55
56--
571.8.5.2.233.g932f7e4
58
diff --git a/meta-networking/recipes-irc/znc/znc_git.bb b/meta-networking/recipes-irc/znc/znc_git.bb
index 2e35e4dd3..d81c17052 100644
--- a/meta-networking/recipes-irc/znc/znc_git.bb
+++ b/meta-networking/recipes-irc/znc/znc_git.bb
@@ -1,16 +1,17 @@
1SUMMARY = "ZNC, an advanced IRC bouncer" 1SUMMARY = "ZNC, an advanced IRC bouncer"
2SECTION = "net" 2SECTION = "net"
3LICENSE = "GPLv2" 3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
5 5
6DEPENDS = "openssl" 6DEPENDS = "openssl zlib icu"
7 7
8PV = "1.0+git" 8PV = "1.6.0"
9 9
10SRCREV = "ef59c23068547c132cb678092fba9a21317fd5f2" 10SRC_URI = "git://github.com/znc/znc.git;name=znc \
11SRC_URI = "git://github.com/znc/znc.git \ 11 git://github.com/jimloco/Csocket.git;destsuffix=git/third_party/Csocket;name=Csocket \
12 file://0001-Fix-NULL-pointer-dereference-in-webadmin.patch \
13 " 12 "
13SRCREV_znc = "f47e8465efa4e1cd948b9caae93ac401b4355df8"
14SRCREV_Csocket = "07b4437396122650e5b8fb3d014e820a5decf4ee"
14 15
15S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
16 17