summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-extended/corosync
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2019-12-13 10:13:42 +0800
committerKhem Raj <raj.khem@gmail.com>2019-12-15 19:30:15 -0800
commit57bc5310812d5e3c549b7744d5de3b32712563b1 (patch)
treea7511004b3db4e12823aa5578fdb2d109179a3c3 /meta-networking/recipes-extended/corosync
parent69bc6ff2fb3226c28cef532ffdc79d93581fcb6b (diff)
downloadmeta-openembedded-57bc5310812d5e3c549b7744d5de3b32712563b1.tar.gz
corosync: fix build error when package config rdma enabled
Fix corosync build error when package config rdma enabled. * replace dependency librdmacm from layer meta-cloud-services with rdma-core from meta-networking * add patch to fix issue that fail to find rdma library via pkgconfig Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-extended/corosync')
-rw-r--r--meta-networking/recipes-extended/corosync/corosync/0001-configure.ac-fix-pkgconfig-issue-of-rdma.patch32
-rw-r--r--meta-networking/recipes-extended/corosync/corosync_2.4.5.bb3
2 files changed, 34 insertions, 1 deletions
diff --git a/meta-networking/recipes-extended/corosync/corosync/0001-configure.ac-fix-pkgconfig-issue-of-rdma.patch b/meta-networking/recipes-extended/corosync/corosync/0001-configure.ac-fix-pkgconfig-issue-of-rdma.patch
new file mode 100644
index 000000000..bdc7645ce
--- /dev/null
+++ b/meta-networking/recipes-extended/corosync/corosync/0001-configure.ac-fix-pkgconfig-issue-of-rdma.patch
@@ -0,0 +1,32 @@
1Subject: [PATCH] configure.ac: fix pkgconfig issue of rdma
2
3pkgconfig files from rdma-core(https://github.com/linux-rdma/rdma-core)
4are named start with lib, such as librdmacm.pc and libibverbs.pc. When
5rdma support is enabled, it fails to find rdma related libraries. Update
6configure.ac to the issue.
7
8Upstream-Status: Submitted [https://github.com/corosync/corosync/pull/515]
9
10Signed-off-by: Kai Kang <kai.kang@windriver.com>
11---
12 configure.ac | 4 ++--
13 1 file changed, 2 insertions(+), 2 deletions(-)
14
15diff --git a/configure.ac b/configure.ac
16index ac513e93..240cfed4 100644
17--- a/configure.ac
18+++ b/configure.ac
19@@ -459,8 +459,8 @@ if test "x${enable_testagents}" = xyes; then
20 fi
21
22 if test "x${enable_rdma}" = xyes; then
23- PKG_CHECK_MODULES([rdmacm],[rdmacm])
24- PKG_CHECK_MODULES([ibverbs],[ibverbs])
25+ PKG_CHECK_MODULES([rdmacm],[librdmacm])
26+ PKG_CHECK_MODULES([ibverbs],[libibverbs])
27 AC_DEFINE_UNQUOTED([HAVE_RDMA], 1, [have rdmacm])
28 PACKAGE_FEATURES="$PACKAGE_FEATURES rdma"
29 WITH_LIST="$WITH_LIST --with rdma"
30--
312.20.1
32
diff --git a/meta-networking/recipes-extended/corosync/corosync_2.4.5.bb b/meta-networking/recipes-extended/corosync/corosync_2.4.5.bb
index 1f4a3e1c6..eefbcca8a 100644
--- a/meta-networking/recipes-extended/corosync/corosync_2.4.5.bb
+++ b/meta-networking/recipes-extended/corosync/corosync_2.4.5.bb
@@ -9,6 +9,7 @@ inherit autotools pkgconfig systemd useradd
9 9
10SRC_URI = "http://build.clusterlabs.org/corosync/releases/${BP}.tar.gz \ 10SRC_URI = "http://build.clusterlabs.org/corosync/releases/${BP}.tar.gz \
11 file://corosync.conf \ 11 file://corosync.conf \
12 file://0001-configure.ac-fix-pkgconfig-issue-of-rdma.patch \
12 " 13 "
13 14
14SRC_URI[md5sum] = "e36a056b893c313c4ec1fe0d7e6cdebd" 15SRC_URI[md5sum] = "e36a056b893c313c4ec1fe0d7e6cdebd"
@@ -36,7 +37,7 @@ PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
36PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus" 37PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus"
37PACKAGECONFIG[qdevice] = "--enable-qdevices,--disable-qdevices" 38PACKAGECONFIG[qdevice] = "--enable-qdevices,--disable-qdevices"
38PACKAGECONFIG[qnetd] = "--enable-qnetd,--disable-qnetd" 39PACKAGECONFIG[qnetd] = "--enable-qnetd,--disable-qnetd"
39PACKAGECONFIG[rdma] = "--enable-rdma,--disable-rdma,librdmacm" 40PACKAGECONFIG[rdma] = "--enable-rdma,--disable-rdma,rdma-core"
40PACKAGECONFIG[snmp] = "--enable-snmp,--disable-snmp,net-snmp" 41PACKAGECONFIG[snmp] = "--enable-snmp,--disable-snmp,net-snmp"
41PACKAGECONFIG[systemd] = "--enable-systemd --with-systemddir=${systemd_system_unitdir},--disable-systemd --without-systemddir,systemd" 42PACKAGECONFIG[systemd] = "--enable-systemd --with-systemddir=${systemd_system_unitdir},--disable-systemd --without-systemddir,systemd"
42 43