summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-devtools/python
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2022-05-02 07:33:41 -0700
committerKhem Raj <raj.khem@gmail.com>2022-05-02 17:51:58 -0700
commit39024689fa8c688ac3073050b0a02ba36ef8397d (patch)
tree43f3851f5903f7023a9248ee2a4210524587e887 /meta-networking/recipes-devtools/python
parent94f82e548fe9075426800cc47142398dd6e51b90 (diff)
downloadmeta-openembedded-39024689fa8c688ac3073050b0a02ba36ef8397d.tar.gz
python3-ldap: move to meta-python
Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-devtools/python')
-rw-r--r--meta-networking/recipes-devtools/python/python3-ldap_3.4.0.bb29
1 files changed, 0 insertions, 29 deletions
diff --git a/meta-networking/recipes-devtools/python/python3-ldap_3.4.0.bb b/meta-networking/recipes-devtools/python/python3-ldap_3.4.0.bb
deleted file mode 100644
index 429905831..000000000
--- a/meta-networking/recipes-devtools/python/python3-ldap_3.4.0.bb
+++ /dev/null
@@ -1,29 +0,0 @@
1SUMMARY = "Provides a wrapper in Python to LDAP"
2DESCRIPTION = "This module provides access to the LDAP \
3(Lightweight Directory Access Protocol) through Python operations \
4instead of C API. The module mainly acts as a wrapper for the \
5OpenLDAP 2.x libraries. Errors will appear as exceptions."
6HOMEPAGE = "http://www.python-ldap.org/"
7LICENSE = "PSF-2.0"
8LIC_FILES_CHKSUM = "file://LICENCE;md5=36ce9d726d0321b73c1521704d07db1b"
9
10DEPENDS = "python3 openldap cyrus-sasl"
11
12PYPI_PACKAGE = "python-ldap"
13
14inherit pypi setuptools3
15
16SRC_URI[sha256sum] = "60464c8fc25e71e0fd40449a24eae482dcd0fb7fcf823e7de627a6525b3e0d12"
17
18do_configure:prepend() {
19 sed -i -e 's:^library_dirs =.*::' \
20 -e 's:^include_dirs =.*:include_dirs = =/usr/include/sasl/:' \
21 -e 's/= ldap_r/= ldap/g' ${S}/setup.cfg
22}
23
24RDEPENDS:${PN} = " \
25 ${PYTHON_PN}-pprint \
26 ${PYTHON_PN}-threading \
27 ${PYTHON_PN}-pyasn1 \
28 ${PYTHON_PN}-pyasn1-modules \
29"