summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-05-01 17:04:31 -0700
committerJoe MacDonald <joe_macdonald@mentor.com>2017-05-09 12:29:15 -0400
commitace4f7a15b1a9c67cecffe0dea102eb8342feb37 (patch)
tree39aed641410d11181255aea28ac028057c50869d /meta-networking/recipes-daemons
parent7670d9ec3215e5d7a54142d6497d175d1fc184bd (diff)
downloadmeta-openembedded-ace4f7a15b1a9c67cecffe0dea102eb8342feb37.tar.gz
openhpi: Fix build with gcc7
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-daemons')
-rw-r--r--meta-networking/recipes-daemons/openhpi/files/0001-Fix-build-failures-with-gcc7.patch49
-rw-r--r--meta-networking/recipes-daemons/openhpi/openhpi_3.6.1.bb1
2 files changed, 50 insertions, 0 deletions
diff --git a/meta-networking/recipes-daemons/openhpi/files/0001-Fix-build-failures-with-gcc7.patch b/meta-networking/recipes-daemons/openhpi/files/0001-Fix-build-failures-with-gcc7.patch
new file mode 100644
index 000000000..4f493f7b8
--- /dev/null
+++ b/meta-networking/recipes-daemons/openhpi/files/0001-Fix-build-failures-with-gcc7.patch
@@ -0,0 +1,49 @@
1From 398c6db66c643ed6133cc2b028ab1e27a17c5295 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 1 May 2017 19:10:09 +0000
4Subject: [PATCH] Fix build failures with gcc7
5
6Signed-off-by: Khem Raj <raj.khem@gmail.com>
7---
8 plugins/ipmidirect/ipmi_mc_vendor.cpp | 2 +-
9 plugins/ipmidirect/ipmi_resource.cpp | 4 ++--
10 2 files changed, 3 insertions(+), 3 deletions(-)
11
12diff --git a/plugins/ipmidirect/ipmi_mc_vendor.cpp b/plugins/ipmidirect/ipmi_mc_vendor.cpp
13index 2c6c090..557771c 100644
14--- a/plugins/ipmidirect/ipmi_mc_vendor.cpp
15+++ b/plugins/ipmidirect/ipmi_mc_vendor.cpp
16@@ -322,7 +322,7 @@ cIpmiMcVendor::CreateResources( cIpmiDomain *domain, cIpmiMc *source_mc, cIpmiSd
17 if ( addr.m_channel != source_mc->GetChannel() )
18 stdlog << "WARNING : SDR channel " << addr.m_channel << " NOT equal to MC channel " << source_mc->GetChannel() << "\n";
19
20- if ( FindOrCreateResource( domain, source_mc, fru_id, sdr, sdrs ) == false ) {
21+ if ( !FindOrCreateResource( domain, source_mc, fru_id, sdr, sdrs ) ) {
22 return false;
23 }
24 }
25diff --git a/plugins/ipmidirect/ipmi_resource.cpp b/plugins/ipmidirect/ipmi_resource.cpp
26index c438e74..2552673 100644
27--- a/plugins/ipmidirect/ipmi_resource.cpp
28+++ b/plugins/ipmidirect/ipmi_resource.cpp
29@@ -73,7 +73,7 @@ cIpmiResource::SendCommandReadLock( const cIpmiMsg &msg, cIpmiMsg &rsp,
30
31 domain->ReadLock();
32
33- if ( domain->VerifyResource( resource ) == false )
34+ if ( !domain->VerifyResource( resource ) )
35 return SA_ERR_HPI_NOT_PRESENT;
36
37 return rv;
38@@ -91,7 +91,7 @@ cIpmiResource::SendCommandReadLock( cIpmiRdr *rdr, const cIpmiMsg &msg, cIpmiMsg
39
40 domain->ReadLock();
41
42- if ( domain->VerifyRdr( rdr ) == false )
43+ if ( !domain->VerifyRdr( rdr ) )
44 return SA_ERR_HPI_NOT_PRESENT;
45
46 return rv;
47--
481.9.1
49
diff --git a/meta-networking/recipes-daemons/openhpi/openhpi_3.6.1.bb b/meta-networking/recipes-daemons/openhpi/openhpi_3.6.1.bb
index b9b0437b2..db2a24a9b 100644
--- a/meta-networking/recipes-daemons/openhpi/openhpi_3.6.1.bb
+++ b/meta-networking/recipes-daemons/openhpi/openhpi_3.6.1.bb
@@ -35,6 +35,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.gz \
35 file://openhpi-invalide-session.patch \ 35 file://openhpi-invalide-session.patch \
36 file://openhpi-use-serial-tests-config-needed-by-ptest.patch \ 36 file://openhpi-use-serial-tests-config-needed-by-ptest.patch \
37 file://openhpi-fix-alignment-issue.patch \ 37 file://openhpi-fix-alignment-issue.patch \
38 file://0001-Fix-build-failures-with-gcc7.patch \
38 \ 39 \
39 file://openhpi.init \ 40 file://openhpi.init \
40 file://openhpid.service \ 41 file://openhpid.service \