summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.z@gmail.com>2020-01-27 21:02:42 +0000
committerKhem Raj <raj.khem@gmail.com>2020-01-27 13:10:31 -0800
commit7cb54068b3994569b80841d685667a55823e7075 (patch)
tree43061eaaed14a2cbebde1e12bff16ec3e936c0a1 /meta-networking/recipes-daemons
parent4043bcc714d4aa7abaee7e8e5911f76701207497 (diff)
downloadmeta-openembedded-7cb54068b3994569b80841d685667a55823e7075.tar.gz
opensaf: update recipe to use python3
Update recipe to include support for python3. Introduce a patch which converts samples to utilize pytho3 on the target. Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-daemons')
-rw-r--r--meta-networking/recipes-daemons/opensaf/opensaf/0001-immom_python-convert-to-python3.patch50
-rw-r--r--meta-networking/recipes-daemons/opensaf/opensaf_5.19.10.bb5
2 files changed, 53 insertions, 2 deletions
diff --git a/meta-networking/recipes-daemons/opensaf/opensaf/0001-immom_python-convert-to-python3.patch b/meta-networking/recipes-daemons/opensaf/opensaf/0001-immom_python-convert-to-python3.patch
new file mode 100644
index 000000000..f45874680
--- /dev/null
+++ b/meta-networking/recipes-daemons/opensaf/opensaf/0001-immom_python-convert-to-python3.patch
@@ -0,0 +1,50 @@
1From ffc829603a2c50674c8e04de5221e43f80bfc1b2 Mon Sep 17 00:00:00 2001
2From: Andrey Zhizhikin <andrey.z@gmail.com>
3Date: Mon, 27 Jan 2020 13:00:53 +0000
4Subject: [PATCH] immom_python: convert to python3
5
6Convert immom_python to use python3, python2 is EOL and is not supported
7by all distributions anymore.
8
9Upstream-Status: Pending
10
11Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
12---
13 samples/immsv/immom_python/immom.py | 2 +-
14 samples/immsv/immom_python/immomexamples.py | 2 +-
15 samples/immsv/immom_python/immomtest.py | 2 +-
16 3 files changed, 3 insertions(+), 3 deletions(-)
17
18diff --git a/samples/immsv/immom_python/immom.py b/samples/immsv/immom_python/immom.py
19index 4f68625ed..f88197000 100755
20--- a/samples/immsv/immom_python/immom.py
21+++ b/samples/immsv/immom_python/immom.py
22@@ -1,4 +1,4 @@
23-#! /usr/bin/python
24+#!/usr/bin/env python3
25 """
26 immom -- An IMM Object Manager in Python
27
28diff --git a/samples/immsv/immom_python/immomexamples.py b/samples/immsv/immom_python/immomexamples.py
29index 70c579265..bd693c25f 100755
30--- a/samples/immsv/immom_python/immomexamples.py
31+++ b/samples/immsv/immom_python/immomexamples.py
32@@ -1,4 +1,4 @@
33-#! /usr/bin/env python
34+#!/usr/bin/env python3
35
36 import immom
37
38diff --git a/samples/immsv/immom_python/immomtest.py b/samples/immsv/immom_python/immomtest.py
39index 4b98bea8c..ed2463ba9 100755
40--- a/samples/immsv/immom_python/immomtest.py
41+++ b/samples/immsv/immom_python/immomtest.py
42@@ -1,4 +1,4 @@
43-#!/usr/bin/env python
44+#!/usr/bin/env python3
45 # -*- coding: utf-8 -*-
46
47 import immom
48--
492.17.1
50
diff --git a/meta-networking/recipes-daemons/opensaf/opensaf_5.19.10.bb b/meta-networking/recipes-daemons/opensaf/opensaf_5.19.10.bb
index a7eb4c849..8ce8fce59 100644
--- a/meta-networking/recipes-daemons/opensaf/opensaf_5.19.10.bb
+++ b/meta-networking/recipes-daemons/opensaf/opensaf_5.19.10.bb
@@ -14,7 +14,7 @@ SECTION = "admin"
14LICENSE = "LGPLv2.1" 14LICENSE = "LGPLv2.1"
15LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=a916467b91076e631dd8edb7424769c7" 15LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=a916467b91076e631dd8edb7424769c7"
16 16
17DEPENDS = "libxml2 python" 17DEPENDS = "libxml2 python3"
18TOOLCHAIN = "gcc" 18TOOLCHAIN = "gcc"
19 19
20SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}" 20SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}"
@@ -26,6 +26,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/releases/${BPN}-${PV}.tar.gz \
26 file://0001-immpbe_dump.cc-Use-sys-wait.h-instead-of-wait.h.patch \ 26 file://0001-immpbe_dump.cc-Use-sys-wait.h-instead-of-wait.h.patch \
27 file://0001-Add-configure-time-check-for-gettid-API.patch \ 27 file://0001-Add-configure-time-check-for-gettid-API.patch \
28 file://0001-create_empty_library-Use-CC-variable-intead-of-hardc.patch \ 28 file://0001-create_empty_library-Use-CC-variable-intead-of-hardc.patch \
29 file://0001-immom_python-convert-to-python3.patch \
29 " 30 "
30SRC_URI[md5sum] = "9b61df01d1a092101c4a626692edae19" 31SRC_URI[md5sum] = "9b61df01d1a092101c4a626692edae19"
31SRC_URI[sha256sum] = "6da9af96e8ee58d11031d305bf4804a00deb6108e12e422722882a2091bd34bd" 32SRC_URI[sha256sum] = "6da9af96e8ee58d11031d305bf4804a00deb6108e12e422722882a2091bd34bd"
@@ -66,7 +67,7 @@ FILES_${PN}-staticdev += "${PKGLIBDIR}/*.a"
66 67
67INSANE_SKIP_${PN} = "dev-so" 68INSANE_SKIP_${PN} = "dev-so"
68 69
69RDEPENDS_${PN} += "bash python" 70RDEPENDS_${PN} += "bash python3-core"
70 71
71# http://errors.yoctoproject.org/Errors/Details/186970/ 72# http://errors.yoctoproject.org/Errors/Details/186970/
72COMPATIBLE_HOST_libc-musl = 'null' 73COMPATIBLE_HOST_libc-musl = 'null'