summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-10-21 09:20:27 -0700
committerKhem Raj <raj.khem@gmail.com>2020-10-21 09:37:38 -0700
commit409032dcc59bed5051cca454f7344b3cd207cebf (patch)
tree0551ccb086864d04e1f331d940dcd65b6678ddb8 /meta-networking/recipes-daemons
parentbb460fb3cbe1953c7b2f9a40d2226989e8b07670 (diff)
downloadmeta-openembedded-409032dcc59bed5051cca454f7344b3cd207cebf.tar.gz
iscsi-initiator-utils: Silence a clang warning on 64bit systems
This unbreaks the build with clang as well. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-daemons')
-rw-r--r--meta-networking/recipes-daemons/iscsi-initiator-utils/files/0001-libopeniscsiusr-Compare-with-max-int-instead-of-max-.patch48
-rw-r--r--meta-networking/recipes-daemons/iscsi-initiator-utils/iscsi-initiator-utils_2.1.2.bb1
2 files changed, 49 insertions, 0 deletions
diff --git a/meta-networking/recipes-daemons/iscsi-initiator-utils/files/0001-libopeniscsiusr-Compare-with-max-int-instead-of-max-.patch b/meta-networking/recipes-daemons/iscsi-initiator-utils/files/0001-libopeniscsiusr-Compare-with-max-int-instead-of-max-.patch
new file mode 100644
index 000000000..c71f01299
--- /dev/null
+++ b/meta-networking/recipes-daemons/iscsi-initiator-utils/files/0001-libopeniscsiusr-Compare-with-max-int-instead-of-max-.patch
@@ -0,0 +1,48 @@
1From 7bdaa32c80bb7d37668c1ff6d88bb02428459a0f Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 21 Oct 2020 09:11:20 -0700
4Subject: [PATCH] libopeniscsiusr: Compare with max int instead of max long
5
6This compares value member of int_list_tbl struct which is of unsigned
7int type.
8
9struct int_list_tbl {
10const char *name;
11unsigned int value;
12};
13
14Clang compiler reports this comparison when
15-Wtautological-constant-out-of-range-compare is enabled
16
17| idbm.c:1042:2: error: result of comparison of constant 18446744073709551615 with expression of type 'unsigned int' is always true [-Werror,-Wtautological-constant-out-of-range-compare]
18| _rec_int_list(SESSION_CHAP_ALGS, recs, node, session.auth.chap_algs,
19| ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
20| idbm.c:263:23: note: expanded from macro '_rec_int_list'
21| if (_org->_name[_i] != ~0UL) { \
22| ~~~~~~~~~~~~~~~ ^ ~~~~
23
24Since max value for int can be less than unsinged long e.g. on LP64 its
25better to use UINT_MAX here
26
27Upstream-Status: Submitted [https://github.com/open-iscsi/open-iscsi/pull/227]
28Signed-off-by: Khem Raj <raj.khem@gmail.com>
29---
30 libopeniscsiusr/idbm.c | 2 +-
31 1 file changed, 1 insertion(+), 1 deletion(-)
32
33diff --git a/libopeniscsiusr/idbm.c b/libopeniscsiusr/idbm.c
34index 7bc2381..060196f 100644
35--- a/libopeniscsiusr/idbm.c
36+++ b/libopeniscsiusr/idbm.c
37@@ -260,7 +260,7 @@ do {\
38 _recs[_n].type = TYPE_INT_LIST; \
39 _strncpy(_recs[_n].name, _key, NAME_MAXVAL); \
40 for (unsigned int _i = 0; _i < ARRAY_LEN(_org->_name); _i++) { \
41- if (_org->_name[_i] != ~0UL) { \
42+ if (_org->_name[_i] != UINT_MAX) { \
43 for (unsigned int _j = 0; _j < ARRAY_LEN(_tbl); _j++) { \
44 if (_tbl[_j].value == _org->_name[_i]) { \
45 strcat(_recs[_n].value, _tbl[_j].name); \
46--
472.29.0
48
diff --git a/meta-networking/recipes-daemons/iscsi-initiator-utils/iscsi-initiator-utils_2.1.2.bb b/meta-networking/recipes-daemons/iscsi-initiator-utils/iscsi-initiator-utils_2.1.2.bb
index 254362881..dfcd4ee3c 100644
--- a/meta-networking/recipes-daemons/iscsi-initiator-utils/iscsi-initiator-utils_2.1.2.bb
+++ b/meta-networking/recipes-daemons/iscsi-initiator-utils/iscsi-initiator-utils_2.1.2.bb
@@ -16,6 +16,7 @@ SRCREV ?= "802688debcd88c48edabe86deb7e7ed47ebadc26"
16 16
17SRC_URI = "git://github.com/open-iscsi/open-iscsi \ 17SRC_URI = "git://github.com/open-iscsi/open-iscsi \
18 file://0001-Makefile-Do-not-set-Werror.patch \ 18 file://0001-Makefile-Do-not-set-Werror.patch \
19 file://0001-libopeniscsiusr-Compare-with-max-int-instead-of-max-.patch \
19 file://initd.debian \ 20 file://initd.debian \
20 file://99_iscsi-initiator-utils \ 21 file://99_iscsi-initiator-utils \
21 file://iscsi-initiator \ 22 file://iscsi-initiator \