summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons
diff options
context:
space:
mode:
authorJoe MacDonald <joe@deserted.net>2013-11-01 14:24:36 -0400
committerJoe MacDonald <joe@deserted.net>2013-11-04 09:59:57 -0500
commit3cf6fd9961b290f6346be94a98b28a44508176e4 (patch)
tree676b1c7038490f4ad3b7689180179b7082a25bb3 /meta-networking/recipes-daemons
parent153372542a75625cda97b864afc25b3cac54772d (diff)
downloadmeta-openembedded-3cf6fd9961b290f6346be94a98b28a44508176e4.tar.gz
autofs: correct QA issues with orphaned systemd files
If we build a project without systemd support on a system that has systemd enabled, the following QA items get flagged: /lib /lib/systemd /lib/systemd/system /lib/systemd/system/autofs.service Trying to keep the solution to the problem as contained as possible in a way that may be accepted up-stream by adding an optional parameter to the --with-systemd flag. Signed-off-by: Joe MacDonald <joe@deserted.net>
Diffstat (limited to 'meta-networking/recipes-daemons')
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs-5.0.7/0001-systemd-allow-with-systemd-to-take-a-path-arg.patch47
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb4
2 files changed, 49 insertions, 2 deletions
diff --git a/meta-networking/recipes-daemons/autofs/autofs-5.0.7/0001-systemd-allow-with-systemd-to-take-a-path-arg.patch b/meta-networking/recipes-daemons/autofs/autofs-5.0.7/0001-systemd-allow-with-systemd-to-take-a-path-arg.patch
new file mode 100644
index 000000000..742f25de1
--- /dev/null
+++ b/meta-networking/recipes-daemons/autofs/autofs-5.0.7/0001-systemd-allow-with-systemd-to-take-a-path-arg.patch
@@ -0,0 +1,47 @@
1From 40971911d653bf53de295d7462c643e4073916b9 Mon Sep 17 00:00:00 2001
2From: Joe MacDonald <joe@deserted.net>
3Date: Fri, 1 Nov 2013 12:47:18 -0400
4Subject: [PATCH] systemd: allow --with-systemd to take a path arg
5
6If building for a cross-compile environment with systemd it is convenient
7to be able to specify a systemd path for the target that may not be the
8same as that on the host.
9
10Upstream-status: Submitted [http://www.spinics.net/lists/autofs/msg00740.html]
11
12Signed-off-by: Joe MacDonald <joe@deserted.net>
13---
14 aclocal.m4 | 10 ++++++++--
15 1 file changed, 8 insertions(+), 2 deletions(-)
16
17diff --git a/aclocal.m4 b/aclocal.m4
18index 3e6f223..105e3e9 100644
19--- a/aclocal.m4
20+++ b/aclocal.m4
21@@ -229,8 +229,10 @@ dnl Check the location of the systemd unit files directory
22 dnl --------------------------------------------------------------------------
23 AC_DEFUN([AF_WITH_SYSTEMD],
24 [AC_ARG_WITH(systemd,
25-[ --with-systemd install systemd unit file if systemd unit directory
26- is found on system],
27+[ --with-systemd@<:@=systemddir@:>@ install systemd unit file. If 'yes'
28+ probe the system for unit directory.
29+ If a path is specified, assume that
30+ is a valid install path.],
31 [if test "$withval" = yes; then
32 if test -z "$systemddir"; then
33 AC_MSG_CHECKING([location of the systemd unit files directory])
34@@ -247,6 +249,10 @@ AC_DEFUN([AF_WITH_SYSTEMD],
35 else
36 AC_MSG_RESULT(not found)
37 fi
38+else
39+ if test "$withval" != no; then
40+ systemddir=$withval
41+ fi
42 fi])
43 ])
44
45--
461.7.10.4
47
diff --git a/meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb b/meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb
index c4eea317b..54e89f548 100644
--- a/meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb
+++ b/meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb
@@ -60,6 +60,7 @@ SRC_URI = "${KERNELORG_MIRROR}/linux/daemons/autofs/v5/autofs-${PV}.tar.bz2 \
60 file://autofs-5.0.7-do-not-check-for-modprobe.patch \ 60 file://autofs-5.0.7-do-not-check-for-modprobe.patch \
61 file://fix_disable_ldap.patch \ 61 file://fix_disable_ldap.patch \
62 file://autofs-5.0.7-fix-lib-deps.patch \ 62 file://autofs-5.0.7-fix-lib-deps.patch \
63 file://0001-systemd-allow-with-systemd-to-take-a-path-arg.patch \
63" 64"
64 65
65SRC_URI[md5sum] = "bc46838dece83c02d800ff144ed9f431" 66SRC_URI[md5sum] = "bc46838dece83c02d800ff144ed9f431"
@@ -73,7 +74,7 @@ INITSCRIPT_PARAMS = "defaults"
73# FIXME: modules/Makefile has crappy rules that don't obey LDFLAGS 74# FIXME: modules/Makefile has crappy rules that don't obey LDFLAGS
74CFLAGS += "${LDFLAGS}" 75CFLAGS += "${LDFLAGS}"
75 76
76PACKAGECONFIG[systemd] = "--with-systemd,--without-systemd,systemd" 77PACKAGECONFIG[systemd] = "--with-systemd=${systemd_unitdir}/system,--without-systemd,systemd"
77 78
78PACKAGECONFIG ?= "${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}" 79PACKAGECONFIG ?= "${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
79 80
@@ -85,7 +86,6 @@ EXTRA_OECONF += "--disable-mount-locking \
85" 86"
86CACHED_CONFIGUREVARS = "ac_cv_path_RANLIB=${RANLIB} \ 87CACHED_CONFIGUREVARS = "ac_cv_path_RANLIB=${RANLIB} \
87 ac_cv_path_RPCGEN=rpcgen \ 88 ac_cv_path_RPCGEN=rpcgen \
88 systemddir=${systemd_unitdir}/system \
89" 89"
90 90
91do_configure_prepend () { 91do_configure_prepend () {