summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-05-05 23:18:04 -0700
committerArmin Kuster <akuster808@gmail.com>2018-05-17 08:32:26 -0700
commit309963b2f1966be69f02311daa86a0d4b5ac52da (patch)
tree3669fb0366e549f2032866771f27ed894a64c3ba /meta-networking/recipes-daemons
parent12e8c3ea698905e2ed0edd9b7f351a497a1bd68d (diff)
downloadmeta-openembedded-309963b2f1966be69f02311daa86a0d4b5ac52da.tar.gz
squid: Upgrade to 3.5.27
Drop upstreamed/backported patches Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-networking/recipes-daemons')
-rw-r--r--meta-networking/recipes-daemons/squid/files/0001-SquidNew-use-noexcept-instead-of-throw-for-C-11-comp.patch46
-rw-r--r--meta-networking/recipes-daemons/squid/files/gcc7-fixes.patch26
-rw-r--r--meta-networking/recipes-daemons/squid/squid_3.5.27.bb (renamed from meta-networking/recipes-daemons/squid/squid_3.5.26.bb)6
3 files changed, 2 insertions, 76 deletions
diff --git a/meta-networking/recipes-daemons/squid/files/0001-SquidNew-use-noexcept-instead-of-throw-for-C-11-comp.patch b/meta-networking/recipes-daemons/squid/files/0001-SquidNew-use-noexcept-instead-of-throw-for-C-11-comp.patch
deleted file mode 100644
index f482f8088..000000000
--- a/meta-networking/recipes-daemons/squid/files/0001-SquidNew-use-noexcept-instead-of-throw-for-C-11-comp.patch
+++ /dev/null
@@ -1,46 +0,0 @@
1From 27e10667bf27baf5f119a791e3473bb9435a786a Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 23 Apr 2017 10:28:28 -0700
4Subject: [PATCH] SquidNew: use noexcept instead of throw for C++11 compilers
5
6Fixes errors with gcc7 which is more pedantic about c++11
7conformance regarding deprecated features
8
9include/SquidNew.h:21:51: error: dynamic exception specifications are deprecated in C++11
10_SQUID_EXTERNNEW_ void *operator new[] (size_t size) throw (std::bad_alloc)
11 ^~~~~
12
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14
15---
16 include/SquidNew.h | 8 ++++----
17 1 file changed, 4 insertions(+), 4 deletions(-)
18
19diff --git a/include/SquidNew.h b/include/SquidNew.h
20index 39fcee0..c960347 100644
21--- a/include/SquidNew.h
22+++ b/include/SquidNew.h
23@@ -18,19 +18,19 @@
24 */
25 #include <new>
26
27-_SQUID_EXTERNNEW_ void *operator new(size_t size) throw (std::bad_alloc)
28+_SQUID_EXTERNNEW_ void *operator new(size_t size) noexcept(false)
29 {
30 return xmalloc(size);
31 }
32-_SQUID_EXTERNNEW_ void operator delete (void *address) throw()
33+_SQUID_EXTERNNEW_ void operator delete (void *address) noexcept(true)
34 {
35 xfree(address);
36 }
37-_SQUID_EXTERNNEW_ void *operator new[] (size_t size) throw (std::bad_alloc)
38+_SQUID_EXTERNNEW_ void *operator new[] (size_t size) noexcept(false)
39 {
40 return xmalloc(size);
41 }
42-_SQUID_EXTERNNEW_ void operator delete[] (void *address) throw()
43+_SQUID_EXTERNNEW_ void operator delete[] (void *address) noexcept(true)
44 {
45 xfree(address);
46 }
diff --git a/meta-networking/recipes-daemons/squid/files/gcc7-fixes.patch b/meta-networking/recipes-daemons/squid/files/gcc7-fixes.patch
deleted file mode 100644
index 2feca4986..000000000
--- a/meta-networking/recipes-daemons/squid/files/gcc7-fixes.patch
+++ /dev/null
@@ -1,26 +0,0 @@
1From 660fce9cfa00a57e5b7cec46116a31e21595c306 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 19 Jun 2017 23:47:01 -0700
4Subject: [PATCH] squid: Upgrade to 3.5.26
5
6../../squid-3.5.26/src/DiskIO/DiskThreads/aiops.cc: In function 'void squidaio_init()': ../../squid-3.5.26/src/DiskIO/DiskThreads/DiskThreads.h:30:50: error: '*' in boolean context, suggest '&&' instead [-Werror=int-in-bool-context] #define NUMTHREADS (Config.cacheSwap.n_configured*16)
7
8Upstream-Status: Backport
9
10---
11 src/DiskIO/DiskThreads/aiops.cc | 2 +-
12 1 file changed, 1 insertion(+), 1 deletion(-)
13
14diff --git a/src/DiskIO/DiskThreads/aiops.cc b/src/DiskIO/DiskThreads/aiops.cc
15index b44adfa..e11f948 100644
16--- a/src/DiskIO/DiskThreads/aiops.cc
17+++ b/src/DiskIO/DiskThreads/aiops.cc
18@@ -290,7 +290,7 @@ squidaio_init(void)
19 /* Create threads and get them to sit in their wait loop */
20 squidaio_thread_pool = memPoolCreate("aio_thread", sizeof(squidaio_thread_t));
21
22- assert(NUMTHREADS);
23+ assert(NUMTHREADS != 0);
24
25 for (i = 0; i < NUMTHREADS; ++i) {
26 threadp = (squidaio_thread_t *)squidaio_thread_pool->alloc();
diff --git a/meta-networking/recipes-daemons/squid/squid_3.5.26.bb b/meta-networking/recipes-daemons/squid/squid_3.5.27.bb
index 3ee96abb7..7dae3cd83 100644
--- a/meta-networking/recipes-daemons/squid/squid_3.5.26.bb
+++ b/meta-networking/recipes-daemons/squid/squid_3.5.27.bb
@@ -21,16 +21,14 @@ SRC_URI = "http://www.squid-cache.org/Versions/v${MAJ_VER}/${MIN_VER}/${BPN}-${P
21 file://volatiles.03_squid \ 21 file://volatiles.03_squid \
22 file://set_sysroot_patch.patch \ 22 file://set_sysroot_patch.patch \
23 file://squid-don-t-do-squid-conf-tests-at-build-time.patch \ 23 file://squid-don-t-do-squid-conf-tests-at-build-time.patch \
24 file://0001-SquidNew-use-noexcept-instead-of-throw-for-C-11-comp.patch \
25 file://0001-configure-Check-for-Wno-error-format-truncation-comp.patch \ 24 file://0001-configure-Check-for-Wno-error-format-truncation-comp.patch \
26 file://gcc7-fixes.patch \
27 file://0001-tools.cc-fixed-unused-result-warning.patch \ 25 file://0001-tools.cc-fixed-unused-result-warning.patch \
28 " 26 "
29 27
30SRC_URI_remove_toolchain-clang = "file://0001-configure-Check-for-Wno-error-format-truncation-comp.patch" 28SRC_URI_remove_toolchain-clang = "file://0001-configure-Check-for-Wno-error-format-truncation-comp.patch"
31 29
32SRC_URI[md5sum] = "dc1830cd361e077814aa39bcc3691d8b" 30SRC_URI[md5sum] = "c17a3ed3a40cd59c23f48b8539dafcd8"
33SRC_URI[sha256sum] = "41d8845863dcd026c856508cd1599d417c8947ffd96e86e24085f9893cb8b8c2" 31SRC_URI[sha256sum] = "467da134eaf0f7962ba5881793d106772fb05fefa4aea7d9569eec0412c52433"
34 32
35LIC_FILES_CHKSUM = "file://COPYING;md5=c492e2d6d32ec5c1aad0e0609a141ce9 \ 33LIC_FILES_CHKSUM = "file://COPYING;md5=c492e2d6d32ec5c1aad0e0609a141ce9 \
36 file://errors/COPYRIGHT;md5=8861130fae91400bcf99b66f133172b3 \ 34 file://errors/COPYRIGHT;md5=8861130fae91400bcf99b66f133172b3 \