summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2018-04-07 23:43:52 -0700
committerArmin Kuster <akuster808@gmail.com>2018-04-13 12:43:44 -0700
commit224549c911c656ea0529a2f87316b5e46cfb761b (patch)
tree178dd8fdd5276338e6d0197dedfa73e73488126f /meta-networking/recipes-daemons
parent7579acbbc479fe8ee631ea7e21a92961055d04a2 (diff)
downloadmeta-openembedded-224549c911c656ea0529a2f87316b5e46cfb761b.tar.gz
openhpi: refresh patches
WARNING: openhpi-3.6.1-r0 do_patch: Some of the context lines in patches were ignored. This can lead to incorrectly applied patches. The context lines in the patches can be updated with devtool: devtool modify <recipe> devtool finish --force-patch-refresh <recipe> <layer_path> Then the updated patches and the source tree (in devtool's workspace) should be reviewed to make sure the patches apply in the correct place and don't introduce duplicate lines (which can, and does happen when some of the context is ignored). Further information: http://lists.openembedded.org/pipermail/openembedded-core/2018-March/148675.html https://bugzilla.yoctoproject.org/show_bug.cgi?id=10450 Details: Applying patch openhpi-use-serial-tests-config-needed-by-ptest.patch patching file configure.ac Hunk #1 succeeded at 7 with fuzz 2. Now at patch openhpi-use-serial-tests-config-needed-by-ptest.patch Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-networking/recipes-daemons')
-rw-r--r--meta-networking/recipes-daemons/openhpi/files/openhpi-fix-host-gcc.patch10
-rw-r--r--meta-networking/recipes-daemons/openhpi/files/openhpi-fix-testfail-errors.patch18
-rw-r--r--meta-networking/recipes-daemons/openhpi/files/openhpi-hpi-shell-thread-fix.patch10
-rw-r--r--meta-networking/recipes-daemons/openhpi/files/openhpi-libxml2-cross-compile.patch10
-rw-r--r--meta-networking/recipes-daemons/openhpi/files/openhpi-use-serial-tests-config-needed-by-ptest.patch15
5 files changed, 31 insertions, 32 deletions
diff --git a/meta-networking/recipes-daemons/openhpi/files/openhpi-fix-host-gcc.patch b/meta-networking/recipes-daemons/openhpi/files/openhpi-fix-host-gcc.patch
index 029b857bc..97c515e00 100644
--- a/meta-networking/recipes-daemons/openhpi/files/openhpi-fix-host-gcc.patch
+++ b/meta-networking/recipes-daemons/openhpi/files/openhpi-fix-host-gcc.patch
@@ -6,11 +6,11 @@ Upstream-Status: Pending
6 6
7Signed-of-by: Aws Ismail <aws.ismail@windriver.com> 7Signed-of-by: Aws Ismail <aws.ismail@windriver.com>
8 8
9diff --git a/configure.ac b/configure.ac 9Index: openhpi-3.6.1/configure.ac
10index f5a5b74..4a20154 100644 10===================================================================
11--- a/configure.ac 11--- openhpi-3.6.1.orig/configure.ac
12+++ b/configure.ac 12+++ openhpi-3.6.1/configure.ac
13@@ -605,11 +605,6 @@ AC_ARG_ENABLE([werror], 13@@ -656,11 +656,6 @@ AC_ARG_ENABLE([werror],
14 fi], 14 fi],
15 []) 15 [])
16 16
diff --git a/meta-networking/recipes-daemons/openhpi/files/openhpi-fix-testfail-errors.patch b/meta-networking/recipes-daemons/openhpi/files/openhpi-fix-testfail-errors.patch
index 205696e65..60e2e7919 100644
--- a/meta-networking/recipes-daemons/openhpi/files/openhpi-fix-testfail-errors.patch
+++ b/meta-networking/recipes-daemons/openhpi/files/openhpi-fix-testfail-errors.patch
@@ -4,10 +4,11 @@ Upstream-Status: Pending
4 4
5Signed-off-by: yanjun.zhu <yanjun.zhu@windriver.com> 5Signed-off-by: yanjun.zhu <yanjun.zhu@windriver.com>
6 6
7diff -urpN a/openhpid/safhpi.c b/openhpid/safhpi.c 7Index: openhpi-3.6.1/openhpid/safhpi.c
8--- a/openhpid/safhpi.c 8===================================================================
9+++ b/openhpid/safhpi.c 9--- openhpi-3.6.1.orig/openhpid/safhpi.c
10@@ -1976,7 +1976,7 @@ SaErrorT SAHPI_API saHpiSensorThresholds 10+++ openhpi-3.6.1/openhpid/safhpi.c
11@@ -1933,7 +1933,7 @@ SaErrorT SAHPI_API saHpiSensorThresholds
11 oh_release_domain(d); /* Unlock domain */ 12 oh_release_domain(d); /* Unlock domain */
12 13
13 OH_CALL_ABI(h, set_sensor_thresholds, SA_ERR_HPI_INVALID_CMD, rv, 14 OH_CALL_ABI(h, set_sensor_thresholds, SA_ERR_HPI_INVALID_CMD, rv,
@@ -16,10 +17,11 @@ diff -urpN a/openhpid/safhpi.c b/openhpid/safhpi.c
16 oh_release_handler(h); 17 oh_release_handler(h);
17 18
18 return rv; 19 return rv;
19diff -urpN a/utils/sahpi_struct_utils.c b/utils/sahpi_struct_utils.c 20Index: openhpi-3.6.1/utils/sahpi_struct_utils.c
20--- a/utils/sahpi_struct_utils.c 21===================================================================
21+++ b/utils/sahpi_struct_utils.c 22--- openhpi-3.6.1.orig/utils/sahpi_struct_utils.c
22@@ -3855,6 +3855,9 @@ SaHpiBoolT oh_valid_textbuffer(SaHpiText 23+++ openhpi-3.6.1/utils/sahpi_struct_utils.c
24@@ -3861,6 +3861,9 @@ SaHpiBoolT oh_valid_textbuffer(SaHpiText
23 /* found a unpaired surrogate */ 25 /* found a unpaired surrogate */
24 return SAHPI_FALSE; 26 return SAHPI_FALSE;
25 } 27 }
diff --git a/meta-networking/recipes-daemons/openhpi/files/openhpi-hpi-shell-thread-fix.patch b/meta-networking/recipes-daemons/openhpi/files/openhpi-hpi-shell-thread-fix.patch
index 7dac45318..cc21ff8c7 100644
--- a/meta-networking/recipes-daemons/openhpi/files/openhpi-hpi-shell-thread-fix.patch
+++ b/meta-networking/recipes-daemons/openhpi/files/openhpi-hpi-shell-thread-fix.patch
@@ -14,11 +14,11 @@ Date: Mon Dec 17 16:23:45 2012 -0500
14 14
15 Signed-off-by: Aws Ismail <aws.ismail@windriver.com> 15 Signed-off-by: Aws Ismail <aws.ismail@windriver.com>
16 16
17diff --git a/hpi_shell/session.c b/hpi_shell/session.c 17Index: openhpi-3.6.1/hpi_shell/session.c
18index 85c31bf..187da4c 100644 18===================================================================
19--- a/hpi_shell/session.c 19--- openhpi-3.6.1.orig/hpi_shell/session.c
20+++ b/hpi_shell/session.c 20+++ openhpi-3.6.1/hpi_shell/session.c
21@@ -66,7 +66,7 @@ static void* progress_bar(void *unused) 21@@ -73,7 +73,7 @@ static void* progress_bar(void *unused)
22 if (i < (PROGRESS_BUF_SIZE - mes_len - 1)) i++; 22 if (i < (PROGRESS_BUF_SIZE - mes_len - 1)) i++;
23 t++; 23 t++;
24 }; 24 };
diff --git a/meta-networking/recipes-daemons/openhpi/files/openhpi-libxml2-cross-compile.patch b/meta-networking/recipes-daemons/openhpi/files/openhpi-libxml2-cross-compile.patch
index 6d3b6648a..c848b3502 100644
--- a/meta-networking/recipes-daemons/openhpi/files/openhpi-libxml2-cross-compile.patch
+++ b/meta-networking/recipes-daemons/openhpi/files/openhpi-libxml2-cross-compile.patch
@@ -6,11 +6,11 @@ Upstream-Status: Pending
6 6
7Signed-of-by: Aws Ismail <aws.ismail@windriver.com> 7Signed-of-by: Aws Ismail <aws.ismail@windriver.com>
8 8
9diff --git a/configure.ac b/configure.ac 9Index: openhpi-3.6.1/configure.ac
10index 30a792c..b5f5aad 100644 10===================================================================
11--- a/configure.ac 11--- openhpi-3.6.1.orig/configure.ac
12+++ b/configure.ac 12+++ openhpi-3.6.1/configure.ac
13@@ -175,7 +175,7 @@ AC_CHECK_HEADERS([openssl/md2.h openssl/md5.h openssl/bio.h openssl/ssl.h openss 13@@ -177,7 +177,7 @@ AC_CHECK_HEADERS([openssl/md2.h openssl/
14 14
15 dnl xml is used for XML-based communication in ilo2_ribcl and oa_soap 15 dnl xml is used for XML-based communication in ilo2_ribcl and oa_soap
16 AC_CHECK_LIB([xml2],[xmlParseMemory],[XML2_LIB=-lxml2],[XML2_LIB=]) 16 AC_CHECK_LIB([xml2],[xmlParseMemory],[XML2_LIB=-lxml2],[XML2_LIB=])
diff --git a/meta-networking/recipes-daemons/openhpi/files/openhpi-use-serial-tests-config-needed-by-ptest.patch b/meta-networking/recipes-daemons/openhpi/files/openhpi-use-serial-tests-config-needed-by-ptest.patch
index 51537ef12..3e09180d4 100644
--- a/meta-networking/recipes-daemons/openhpi/files/openhpi-use-serial-tests-config-needed-by-ptest.patch
+++ b/meta-networking/recipes-daemons/openhpi/files/openhpi-use-serial-tests-config-needed-by-ptest.patch
@@ -13,19 +13,16 @@ Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
13 configure.ac | 2 +- 13 configure.ac | 2 +-
14 1 files changed, 1 insertions(+), 1 deletions(-) 14 1 files changed, 1 insertions(+), 1 deletions(-)
15 15
16diff --git a/configure.ac b/configure.ac 16Index: openhpi-3.6.1/configure.ac
17index 4b51971..16136b3 100644 17===================================================================
18--- a/configure.ac 18--- openhpi-3.6.1.orig/configure.ac
19+++ b/configure.ac 19+++ openhpi-3.6.1/configure.ac
20@@ -7,7 +7,7 @@ dnl various hacks by Sean Dague <http://dague.net/sean> 4/23/03 20@@ -7,7 +7,7 @@ dnl various hacks by Sean Dague <http:
21 AC_PREREQ(2.57) 21 AC_PREREQ(2.57)
22 AC_INIT(openhpi, 3.5.0) 22 AC_INIT(openhpi, 3.6.1)
23 AC_CONFIG_SRCDIR(openhpi.spec.in) 23 AC_CONFIG_SRCDIR(openhpi.spec.in)
24-AM_INIT_AUTOMAKE([1.8]) 24-AM_INIT_AUTOMAKE([1.8])
25+AM_INIT_AUTOMAKE([1.8 serial-tests]) 25+AM_INIT_AUTOMAKE([1.8 serial-tests])
26 26
27 AM_CONFIG_HEADER(config.h) 27 AM_CONFIG_HEADER(config.h)
28 AH_TOP([#ifndef __OPENHPI_CONFIG_H 28 AH_TOP([#ifndef __OPENHPI_CONFIG_H
29--
301.7.1
31