summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons/squid
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2016-08-25 17:36:36 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2016-09-05 13:34:12 -0400
commit31431932237266d37f75ebcc2c3bcc701720c01a (patch)
tree3b41190de29a4013d481c36162ad68ed77bd4114 /meta-networking/recipes-daemons/squid
parent615872a8af631f205f21affbfddeb3f2cd6e80d5 (diff)
downloadmeta-openembedded-31431932237266d37f75ebcc2c3bcc701720c01a.tar.gz
squid: don't do squid-conf-tests at build time
* squid-conf-tests is a test to run "squid -k parse -f" to perse the config files, which should not be run at build time since we are cross compiling, so remove it when compiling test-suite * Fix the directories of the conf files for squid-conf-tests so that it can run on the target and add it for ptest Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-daemons/squid')
-rw-r--r--meta-networking/recipes-daemons/squid/files/squid-don-t-do-squid-conf-tests-at-build-time.patch63
-rw-r--r--meta-networking/recipes-daemons/squid/squid_3.5.20.bb6
2 files changed, 69 insertions, 0 deletions
diff --git a/meta-networking/recipes-daemons/squid/files/squid-don-t-do-squid-conf-tests-at-build-time.patch b/meta-networking/recipes-daemons/squid/files/squid-don-t-do-squid-conf-tests-at-build-time.patch
new file mode 100644
index 000000000..a5e554736
--- /dev/null
+++ b/meta-networking/recipes-daemons/squid/files/squid-don-t-do-squid-conf-tests-at-build-time.patch
@@ -0,0 +1,63 @@
1From 54a9c2ba60adc7ec2724786662fd398e7c03999f Mon Sep 17 00:00:00 2001
2From: Jackie Huang <jackie.huang@windriver.com>
3Date: Thu, 25 Aug 2016 15:22:57 +0800
4Subject: [PATCH] squid: don't do squid-conf-tests at build time
5
6* squid-conf-tests is a test to run "squid -k parse -f"
7 to perse the config files, which should not be run
8 at build time since we are cross compiling, so remove
9 it but it will be added back for the runtime ptest.
10
11* Fix the directories of the conf files for squid-conf-tests
12 so that it can run on the target board.
13
14Upstream-Status: Inappropriate [cross compile specific]
15
16Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
17---
18 test-suite/Makefile.am | 15 +++++++--------
19 1 file changed, 7 insertions(+), 8 deletions(-)
20
21diff --git a/test-suite/Makefile.am b/test-suite/Makefile.am
22index d5468be..77fc480 100644
23--- a/test-suite/Makefile.am
24+++ b/test-suite/Makefile.am
25@@ -41,8 +41,7 @@ TESTS += debug \
26 MemPoolTest\
27 mem_node_test\
28 mem_hdr_test\
29- $(ESI_TESTS) \
30- squid-conf-tests
31+ $(ESI_TESTS)
32
33 ## Sort by alpha - any build failures are significant.
34 check_PROGRAMS += debug \
35@@ -125,19 +124,19 @@ VirtualDeleteOperator_SOURCES = VirtualDeleteOperator.cc $(DEBUG_SOURCE)
36 ##$(TARGLIB): $(LIBOBJS)
37 ## $(AR_R) $(TARGLIB) $(LIBOBJS)
38
39-squid-conf-tests: $(top_builddir)/src/squid.conf.default $(srcdir)/squidconf/*
40+squid-conf-tests: /etc/squid.conf.default squidconf/*
41 @failed=0; cfglist="$?"; rm -f $@ || $(TRUE); \
42 for cfg in $$cfglist ; do \
43- $(top_builddir)/src/squid -k parse -f $$cfg || \
44+ squid -k parse -f $$cfg || \
45 { echo "FAIL: squid.conf test: $$cfg" | \
46- sed s%$(top_builddir)/src/%% | \
47- sed s%$(srcdir)/squidconf/%% ; \
48+ sed s%/etc/%% | \
49+ sed s%squidconf/%% ; \
50 failed=1; break; \
51 }; \
52 if test "$$failed" -eq 0; then \
53 echo "PASS: squid.conf test: $$cfg" | \
54- sed s%$(top_builddir)/src/%% | \
55- sed s%$(srcdir)/squidconf/%% ; \
56+ sed s%/etc/%% | \
57+ sed s%squidconf/%% ; \
58 else break; fi; \
59 done; \
60 if test "$$failed" -eq 0; then cp $(TRUE) $@ ; fi
61--
622.8.3
63
diff --git a/meta-networking/recipes-daemons/squid/squid_3.5.20.bb b/meta-networking/recipes-daemons/squid/squid_3.5.20.bb
index 760eca8c1..fe1b0277a 100644
--- a/meta-networking/recipes-daemons/squid/squid_3.5.20.bb
+++ b/meta-networking/recipes-daemons/squid/squid_3.5.20.bb
@@ -20,6 +20,7 @@ SRC_URI = "http://www.squid-cache.org/Versions/v${MAJ_VER}/${MIN_VER}/${BPN}-${P
20 file://run-ptest \ 20 file://run-ptest \
21 file://volatiles.03_squid \ 21 file://volatiles.03_squid \
22 file://set_sysroot_patch.patch \ 22 file://set_sysroot_patch.patch \
23 file://squid-don-t-do-squid-conf-tests-at-build-time.patch \
23" 24"
24 25
25LIC_FILES_CHKSUM = "file://COPYING;md5=c492e2d6d32ec5c1aad0e0609a141ce9 \ 26LIC_FILES_CHKSUM = "file://COPYING;md5=c492e2d6d32ec5c1aad0e0609a141ce9 \
@@ -66,6 +67,11 @@ do_install_ptest() {
66 67
67 # do NOT need to rebuild Makefile itself 68 # do NOT need to rebuild Makefile itself
68 sed -i 's/^Makefile:.*$/Makefile:/' ${D}${PTEST_PATH}/${TESTDIR}/Makefile 69 sed -i 's/^Makefile:.*$/Makefile:/' ${D}${PTEST_PATH}/${TESTDIR}/Makefile
70
71 # Add squid-conf-tests for runtime tests
72 sed -e 's/^\(runtest-TESTS:\)/\1 squid-conf-tests/' \
73 -e "s/\(list=' \$(TESTS)\)/\1 squid-conf-tests/" \
74 -i ${D}${PTEST_PATH}/${TESTDIR}/Makefile
69} 75}
70 76
71do_install_append() { 77do_install_append() {