summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons/postfix/postfix.inc
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2018-10-12 16:22:34 +0800
committerKhem Raj <raj.khem@gmail.com>2018-10-12 02:07:52 -0700
commit47a9cc6c5397fbc482e2eb895d1139b1b67aa555 (patch)
tree0b403ee2506024d2ce7436efc8a93778c170edaf /meta-networking/recipes-daemons/postfix/postfix.inc
parent69e5fa1485aa58ad1d664070b0d9e4db413fdd62 (diff)
downloadmeta-openembedded-47a9cc6c5397fbc482e2eb895d1139b1b67aa555.tar.gz
postfix: add -lnsl and -lresolv to SYSLIBS by default
When building native package, the do_compile function tries to check libnsl.so and libresolv.so on host machine and add -lnsl and -lresolv to SYSLIBS if they exist. But finally it will link the libnsl.so from ${STAGING_LIBDIR_NATIVE}. Actually there is no need to check them since the libnsl2 is specified in DEPENDS and libresolv.so is from c libarary. So add -lnsl and -lresolv to SYSLIBS directly. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-daemons/postfix/postfix.inc')
-rw-r--r--meta-networking/recipes-daemons/postfix/postfix.inc18
1 files changed, 0 insertions, 18 deletions
diff --git a/meta-networking/recipes-daemons/postfix/postfix.inc b/meta-networking/recipes-daemons/postfix/postfix.inc
index 882b27b6e..3d4f1df43 100644
--- a/meta-networking/recipes-daemons/postfix/postfix.inc
+++ b/meta-networking/recipes-daemons/postfix/postfix.inc
@@ -97,27 +97,9 @@ do_compile () {
97 "s:\$(SHELL) makedefs):\$(SHELL) makedefs $SYSTEM $RELEASE):" \ 97 "s:\$(SHELL) makedefs):\$(SHELL) makedefs $SYSTEM $RELEASE):" \
98 ${S}/Makefile.in 98 ${S}/Makefile.in
99 export BUILD_SYSROOT="${STAGING_DIR_HOST}" 99 export BUILD_SYSROOT="${STAGING_DIR_HOST}"
100 export BUILD_SYSROOT_NSL_PATH="${STAGING_BASELIBDIR} \
101 ${STAGING_LIBDIR}"
102 else 100 else
103 # native build 101 # native build
104 export BUILD_SYSROOT="${STAGING_DIR_NATIVE}" 102 export BUILD_SYSROOT="${STAGING_DIR_NATIVE}"
105
106 # ubuntu x86 host: /lib/x86_64-linux-gnu(64) /lib/i386-linux-gnu (32)
107 # on 64 bits, 32 libs in i386-linux-gnu
108 # let makedefs finds nsl and resolv libs, host CC will link
109 # the correct libraries
110 BUILD_SYSROOT_NSL_PATH="$(${CC} -print-search-dirs 2>/dev/null | \
111 sed -n '/^libraries: =/s/libraries: =//p' | \
112 sed -e 's/:/\n/g' | xargs -n1 readlink -f | \
113 grep -v 'gcc\|/[0-9.]\+$' | sort -u)"
114 if [ -z "$BUILD_SYSROOT_NSL_PATH" ]; then
115 BUILD_SYSROOT_NSL_PATH="/usr/lib64 /lib64 \
116 /lib/x86_64-linux-gnu \
117 /usr/lib /lib \
118 /lib/i386-linux-gnu"
119 fi
120 export BUILD_SYSROOT_NSL_PATH
121 fi 103 fi
122 104
123 oe_runmake makefiles 105 oe_runmake makefiles