summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-networking/recipes-connectivity
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-networking/recipes-connectivity')
-rw-r--r--meta-networking/recipes-connectivity/crda/crda_1.1.3.bb12
-rw-r--r--meta-networking/recipes-connectivity/inetutils/inetutils_1.9.1.bb50
-rw-r--r--meta-networking/recipes-connectivity/vpnc/vpnc_0.5.3.bb8
3 files changed, 35 insertions, 35 deletions
diff --git a/meta-networking/recipes-connectivity/crda/crda_1.1.3.bb b/meta-networking/recipes-connectivity/crda/crda_1.1.3.bb
index d736c7a2d..dc1fc21cf 100644
--- a/meta-networking/recipes-connectivity/crda/crda_1.1.3.bb
+++ b/meta-networking/recipes-connectivity/crda/crda_1.1.3.bb
@@ -9,7 +9,7 @@ DEPENDS = "python-m2crypto-native python-native libgcrypt libnl"
9 9
10SRC_URI = "http://wireless.kernel.org/download/crda/${P}.tar.bz2;name=crda \ 10SRC_URI = "http://wireless.kernel.org/download/crda/${P}.tar.bz2;name=crda \
11 http://wireless.kernel.org/download/wireless-regdb/regulatory.bins/2013.01.11-regulatory.bin;name=bin \ 11 http://wireless.kernel.org/download/wireless-regdb/regulatory.bins/2013.01.11-regulatory.bin;name=bin \
12 " 12"
13SRC_URI[crda.md5sum] = "29579185e06a75675507527243d28e5c" 13SRC_URI[crda.md5sum] = "29579185e06a75675507527243d28e5c"
14SRC_URI[crda.sha256sum] = "aa8a7fe92f0765986c421a5b6768a185375ac210393df0605ee132f6754825f0" 14SRC_URI[crda.sha256sum] = "aa8a7fe92f0765986c421a5b6768a185375ac210393df0605ee132f6754825f0"
15SRC_URI[bin.md5sum] = "e0c8a5ca63fb8bf803213f9a0c90b50b" 15SRC_URI[bin.md5sum] = "e0c8a5ca63fb8bf803213f9a0c90b50b"
@@ -20,19 +20,19 @@ inherit python-dir pythonnative
20EXTRA_OEMAKE = "MAKEFLAGS= DESTDIR=${D}" 20EXTRA_OEMAKE = "MAKEFLAGS= DESTDIR=${D}"
21 21
22do_compile() { 22do_compile() {
23 oe_runmake all_noverify 23 oe_runmake all_noverify
24} 24}
25 25
26do_install() { 26do_install() {
27 oe_runmake install 27 oe_runmake install
28 28
29 install -d ${D}${libdir}/crda/ 29 install -d ${D}${libdir}/crda/
30 30
31 install -m 0644 ${WORKDIR}/2013.01.11-regulatory.bin ${D}${libdir}/crda/regulatory.bin 31 install -m 0644 ${WORKDIR}/2013.01.11-regulatory.bin ${D}${libdir}/crda/regulatory.bin
32} 32}
33 33
34 34
35RDEPENDS_${PN} = "udev" 35RDEPENDS_${PN} = "udev"
36FILES_${PN} += "${libdir}crda/regulatory.bin \ 36FILES_${PN} += "${libdir}crda/regulatory.bin \
37 ${base_libdir}/udev/rules.d/85-regulatory.rules \ 37 ${base_libdir}/udev/rules.d/85-regulatory.rules \
38 " 38"
diff --git a/meta-networking/recipes-connectivity/inetutils/inetutils_1.9.1.bb b/meta-networking/recipes-connectivity/inetutils/inetutils_1.9.1.bb
index 155befec1..603bf0176 100644
--- a/meta-networking/recipes-connectivity/inetutils/inetutils_1.9.1.bb
+++ b/meta-networking/recipes-connectivity/inetutils/inetutils_1.9.1.bb
@@ -25,40 +25,40 @@ inherit autotools gettext
25 25
26noipv6="${@base_contains('DISTRO_FEATURES', 'ipv6', '', '--disable-ipv6 gl_cv_socket_ipv6=no', d)}" 26noipv6="${@base_contains('DISTRO_FEATURES', 'ipv6', '', '--disable-ipv6 gl_cv_socket_ipv6=no', d)}"
27EXTRA_OECONF = "--with-ncurses-include-dir=${STAGING_INCDIR} \ 27EXTRA_OECONF = "--with-ncurses-include-dir=${STAGING_INCDIR} \
28 --with-path-procnet-dev=/proc/net/dev \ 28 --with-path-procnet-dev=/proc/net/dev \
29 ${noipv6} \ 29 ${noipv6} \
30 " 30"
31 31
32do_configure_prepend () { 32do_configure_prepend () {
33 export HELP2MAN='true' 33 export HELP2MAN='true'
34 cp ${STAGING_DATADIR_NATIVE}/gettext/config.rpath ${S}/build-aux/config.rpath 34 cp ${STAGING_DATADIR_NATIVE}/gettext/config.rpath ${S}/build-aux/config.rpath
35 rm -f ${S}/glob/configure* 35 rm -f ${S}/glob/configure*
36} 36}
37 37
38do_install () { 38do_install () {
39 autotools_do_install 39 autotools_do_install
40 install -d ${D}${base_sbindir} ${D}${base_bindir} 40 install -d ${D}${base_sbindir} ${D}${base_bindir}
41 mv ${D}${bindir}/tftp ${D}${bindir}/tftp.${BPN} 41 mv ${D}${bindir}/tftp ${D}${bindir}/tftp.${BPN}
42 mv ${D}${bindir}/telnet ${D}${bindir}/telnet.${BPN} 42 mv ${D}${bindir}/telnet ${D}${bindir}/telnet.${BPN}
43 mv ${D}${bindir}/logger ${D}${bindir}/logger.${BPN} 43 mv ${D}${bindir}/logger ${D}${bindir}/logger.${BPN}
44 mv ${D}${bindir}/traceroute ${D}${bindir}/traceroute.${BPN} 44 mv ${D}${bindir}/traceroute ${D}${bindir}/traceroute.${BPN}
45 mv ${D}${bindir}/hostname ${D}${base_bindir}/hostname.${BPN} 45 mv ${D}${bindir}/hostname ${D}${base_bindir}/hostname.${BPN}
46 mv ${D}${bindir}/ifconfig ${D}${base_sbindir}/ifconfig.${BPN} 46 mv ${D}${bindir}/ifconfig ${D}${base_sbindir}/ifconfig.${BPN}
47} 47}
48 48
49pkg_postinst_${PN} () { 49pkg_postinst_${PN} () {
50 update-alternatives --install ${bindir}/tftp tftp tftp.${BPN} 100 50 update-alternatives --install ${bindir}/tftp tftp tftp.${BPN} 100
51 update-alternatives --install ${bindir}/telnet telnet telnet.${BPN} 100 51 update-alternatives --install ${bindir}/telnet telnet telnet.${BPN} 100
52 update-alternatives --install ${bindir}/logger logger logger.${BPN} 100 52 update-alternatives --install ${bindir}/logger logger logger.${BPN} 100
53 update-alternatives --install ${bindir}/traceroute traceroute traceroute.${BPN} 100 53 update-alternatives --install ${bindir}/traceroute traceroute traceroute.${BPN} 100
54 update-alternatives --install ${base_bindir}/hostname hostname hostname.${BPN} 100 54 update-alternatives --install ${base_bindir}/hostname hostname hostname.${BPN} 100
55 update-alternatives --install ${base_sbindir}/ifconfig ifconfig ifconfig.${BPN} 100 55 update-alternatives --install ${base_sbindir}/ifconfig ifconfig ifconfig.${BPN} 100
56} 56}
57 57
58pkg_prerm_${PN} () { 58pkg_prerm_${PN} () {
59 update-alternatives --remove tftp tftp.${BPN} 59 update-alternatives --remove tftp tftp.${BPN}
60 update-alternatives --remove telnet telnet.${BPN} 60 update-alternatives --remove telnet telnet.${BPN}
61 update-alternatives --remove logger logger.${BPN} 61 update-alternatives --remove logger logger.${BPN}
62 update-alternatives --remove traceroute traceroute.${BPN} 62 update-alternatives --remove traceroute traceroute.${BPN}
63 update-alternatives --remove ifconfig ifconfig.${BPN} 63 update-alternatives --remove ifconfig ifconfig.${BPN}
64} 64}
diff --git a/meta-networking/recipes-connectivity/vpnc/vpnc_0.5.3.bb b/meta-networking/recipes-connectivity/vpnc/vpnc_0.5.3.bb
index 1b2b8bf66..2ce9530d0 100644
--- a/meta-networking/recipes-connectivity/vpnc/vpnc_0.5.3.bb
+++ b/meta-networking/recipes-connectivity/vpnc/vpnc_0.5.3.bb
@@ -12,10 +12,10 @@ CFLAGS_append = ' -DVERSION=\\"${PV}\\"'
12LDFLAGS_append = " -lgcrypt -lgpg-error" 12LDFLAGS_append = " -lgcrypt -lgpg-error"
13 13
14do_install () { 14do_install () {
15 sed -i s:m600:m\ 600:g Makefile 15 sed -i s:m600:m\ 600:g Makefile
16 oe_runmake 'DESTDIR=${D}' 'PREFIX=/usr' install 16 oe_runmake 'DESTDIR=${D}' 'PREFIX=/usr' install
17 rm -f ${D}${sysconfdir}/vpnc/vpnc.conf #This file is useless 17 rm -f ${D}${sysconfdir}/vpnc/vpnc.conf #This file is useless
18 install ${WORKDIR}/default.conf ${D}${sysconfdir}/vpnc/default.conf 18 install ${WORKDIR}/default.conf ${D}${sysconfdir}/vpnc/default.conf
19} 19}
20 20
21CONFFILES_${PN} = "${sysconfdir}/vpnc/default.conf" 21CONFFILES_${PN} = "${sysconfdir}/vpnc/default.conf"