summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-06-02 21:58:33 -0700
committerJoe MacDonald <joe_macdonald@mentor.com>2017-06-28 10:27:52 -0400
commit91d77d978fc6ad83777ed077d6acbb8b59a949ba (patch)
tree4ccc8c2ba87970e609a29c7e6af2038f348ac34b /meta-networking/recipes-connectivity
parentde124b8dba0deee37b03708743ade9b8f0ab43be (diff)
downloadmeta-openembedded-91d77d978fc6ad83777ed077d6acbb8b59a949ba.tar.gz
samba: Fix build with musl
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-connectivity')
-rw-r--r--meta-networking/recipes-connectivity/samba/samba/glibc_only.patch15
-rw-r--r--meta-networking/recipes-connectivity/samba/samba/netdb_defines.patch19
-rw-r--r--meta-networking/recipes-connectivity/samba/samba_4.6.2.bb2
3 files changed, 36 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/samba/samba/glibc_only.patch b/meta-networking/recipes-connectivity/samba/samba/glibc_only.patch
new file mode 100644
index 000000000..894bc8bb2
--- /dev/null
+++ b/meta-networking/recipes-connectivity/samba/samba/glibc_only.patch
@@ -0,0 +1,15 @@
1Index: samba-4.6.2/ctdb/tests/src/test_mutex_raw.c
2===================================================================
3--- samba-4.6.2.orig/ctdb/tests/src/test_mutex_raw.c
4+++ samba-4.6.2/ctdb/tests/src/test_mutex_raw.c
5@@ -166,8 +166,10 @@ int main(int argc, const char **argv)
6 if (ret == 0) {
7 pthread_mutex_unlock(mutex);
8 }
9+#ifdef __GLIBC__
10 } else if (ret == EBUSY) {
11 printf("pid=%u\n", mutex->__data.__owner);
12+#endif
13 } else if (ret == 0) {
14 pthread_mutex_unlock(mutex);
15 }
diff --git a/meta-networking/recipes-connectivity/samba/samba/netdb_defines.patch b/meta-networking/recipes-connectivity/samba/samba/netdb_defines.patch
new file mode 100644
index 000000000..eb06866f4
--- /dev/null
+++ b/meta-networking/recipes-connectivity/samba/samba/netdb_defines.patch
@@ -0,0 +1,19 @@
1Index: samba-4.6.2/nsswitch/wins.c
2===================================================================
3--- samba-4.6.2.orig/nsswitch/wins.c
4+++ samba-4.6.2/nsswitch/wins.c
5@@ -39,6 +39,14 @@ static pthread_mutex_t wins_nss_mutex =
6 #define INADDRSZ 4
7 #endif
8
9+#ifndef NETDB_INTERNAL
10+#define NETDB_INTERNAL (-1)
11+#endif
12+
13+#ifndef NETDB_SUCCESS
14+#define NETDB_SUCCESS 0
15+#endif
16+
17 NSS_STATUS _nss_wins_gethostbyname_r(const char *hostname,
18 struct hostent *he,
19 char *buffer,
diff --git a/meta-networking/recipes-connectivity/samba/samba_4.6.2.bb b/meta-networking/recipes-connectivity/samba/samba_4.6.2.bb
index 38876c2c3..7574aefb4 100644
--- a/meta-networking/recipes-connectivity/samba/samba_4.6.2.bb
+++ b/meta-networking/recipes-connectivity/samba/samba_4.6.2.bb
@@ -18,6 +18,8 @@ SRC_URI = "${SAMBA_MIRROR}/stable/samba-${PV}.tar.gz \
18 file://21-add-config-option-without-valgrind.patch \ 18 file://21-add-config-option-without-valgrind.patch \
19 file://0001-packaging-Avoid-timeout-for-nmbd-if-started-offline-.patch \ 19 file://0001-packaging-Avoid-timeout-for-nmbd-if-started-offline-.patch \
20 file://0006-avoid-using-colon-in-the-checking-msg.patch \ 20 file://0006-avoid-using-colon-in-the-checking-msg.patch \
21 file://netdb_defines.patch \
22 file://glibc_only.patch \
21 file://volatiles.03_samba \ 23 file://volatiles.03_samba \
22 " 24 "
23SRC_URI_append_libc-musl = " \ 25SRC_URI_append_libc-musl = " \