summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2019-07-12 13:36:45 +0800
committerKhem Raj <raj.khem@gmail.com>2019-07-11 23:18:54 -0700
commit826898d8783e70772af9876c0219fb31c4b01763 (patch)
treee45cd32b2dca064820ccc9a41b790e83374589a6 /meta-networking/recipes-connectivity
parentda057468d72cbb897e655507aa4401b14005b9a7 (diff)
downloadmeta-openembedded-826898d8783e70772af9876c0219fb31c4b01763.tar.gz
adcli: added new recipe.
-radiusclient-ng is too old. So, added a substitute. -Has fixed the build on musl. Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-connectivity')
-rw-r--r--meta-networking/recipes-connectivity/adcli/adcli_0.8.2.bb27
-rw-r--r--meta-networking/recipes-connectivity/adcli/files/Fixed-build-error-on-musl.patch26
2 files changed, 53 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/adcli/adcli_0.8.2.bb b/meta-networking/recipes-connectivity/adcli/adcli_0.8.2.bb
new file mode 100644
index 000000000..75f303068
--- /dev/null
+++ b/meta-networking/recipes-connectivity/adcli/adcli_0.8.2.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Active Directory enrollment"
2DESCRIPTION = "A helper library and tools for Active Directory client operations."
3
4HOMEPAGE = "http://cgit.freedesktop.org/realmd/adcli"
5SECTION = "net"
6
7SRCREV = "cc3ef52884a48863a81acbfc741735fe09cd85f7"
8
9SRC_URI = "git://gitlab.freedesktop.org/realmd/adcli;branch=master \
10 file://Fixed-build-error-on-musl.patch \
11 "
12
13S = "${WORKDIR}/git"
14
15LICENSE = "LGPLv2+"
16LIC_FILES_CHKSUM = "file://COPYING;md5=23c2a5e0106b99d75238986559bb5fc6"
17
18inherit autotools xmlcatalog
19
20DEPENDS += "virtual/crypt krb5 openldap gettext libxslt xmlto libxml2-native \
21 cyrus-sasl libxslt-native xmlto-native coreutils-native\
22 "
23
24EXTRA_OECONF += "--disable-static \
25 --disable-silent-rules \
26 --disable-doc \
27 "
diff --git a/meta-networking/recipes-connectivity/adcli/files/Fixed-build-error-on-musl.patch b/meta-networking/recipes-connectivity/adcli/files/Fixed-build-error-on-musl.patch
new file mode 100644
index 000000000..87bcdfebd
--- /dev/null
+++ b/meta-networking/recipes-connectivity/adcli/files/Fixed-build-error-on-musl.patch
@@ -0,0 +1,26 @@
1From 0e64782a45cba9753d1210ee7d7c9dbd42f74ceb Mon Sep 17 00:00:00 2001
2From: Zang Ruochen <zangrc.fnst@cn.fujitsu.com>
3Date: Fri, 12 Jul 2019 12:46:54 +0800
4Subject: [PATCH] Fixed build error on musl.
5
6Signed-off-by: Khem Raj <raj.khem@gmail.com>
7Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com>
8---
9 library/adutil.c | 1 +
10 1 file changed, 1 insertion(+)
11
12diff --git a/library/adutil.c b/library/adutil.c
13index 9b0c47f..b673edd 100644
14--- a/library/adutil.c
15+++ b/library/adutil.c
16@@ -30,6 +30,7 @@
17 #include <assert.h>
18 #include <ctype.h>
19 #include <errno.h>
20+#include <endian.h>
21 #include <stdio.h>
22 #include <stdlib.h>
23 #include <string.h>
24--
252.20.1
26