summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity
diff options
context:
space:
mode:
authorchunrong guo <b40290@freescale.com>2012-11-20 07:10:37 +0000
committerJoe MacDonald <joe.macdonald@windriver.com>2012-11-27 14:43:58 -0500
commit11a6ce97f710fe6578a92edc5409b0aa315da79f (patch)
tree6ad2b7bc3c56c13a5296ac617dfa9909f07d095c /meta-networking/recipes-connectivity
parenteb63724f431a0fb6b2fec1bd84ae7f04cb8744df (diff)
downloadmeta-openembedded-11a6ce97f710fe6578a92edc5409b0aa315da79f.tar.gz
inetutils : Update to 1.9.1
* There are difference spaces between inetutils-1.8/COPYING and inetutils-1.9.1/COPYING,so md5sum is changed. * the following patches are accepted by inetutils 1.9.1 upstream inetutils-1.8-1005-ftpd-add-daemon-D-nommu-support.patch inetutils-1.8-1004-detect-fork-support.patch inetutils-1.8-1003-use-daemon-from-the-C-library-when-possible.patch inetutils-1.8-1002-rshd-detect-__rcmd_errstr-support-in-the-C-lib.patch inetutils-1.8-1001-ftp-rename-ruserpass-to-avoid-C-library-collision.patch inetutils-1.8-0002-argp-fix-program_invocation_name-detection.patch Signed-off-by: Chunrong Guo <b40290@freescale.com>
Diffstat (limited to 'meta-networking/recipes-connectivity')
-rw-r--r--meta-networking/recipes-connectivity/inetutils/inetutils-1.9.1/disable-pre-ANSI-compilers.patch16
-rw-r--r--meta-networking/recipes-connectivity/inetutils/inetutils-1.9.1/fix-disable-ipv6.patch60
-rw-r--r--meta-networking/recipes-connectivity/inetutils/inetutils-1.9.1/inetutils-1.8-0001-printf-parse-pull-in-features.h-for-__GLIBC__.patch29
-rw-r--r--meta-networking/recipes-connectivity/inetutils/inetutils-1.9.1/inetutils-1.8-0003-wchar.patch14
-rw-r--r--meta-networking/recipes-connectivity/inetutils/inetutils-1.9.1/remove-gets.patch21
-rw-r--r--meta-networking/recipes-connectivity/inetutils/inetutils-1.9.1/version.patch17
-rw-r--r--meta-networking/recipes-connectivity/inetutils/inetutils_1.9.1.bb63
7 files changed, 220 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.1/disable-pre-ANSI-compilers.patch b/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.1/disable-pre-ANSI-compilers.patch
new file mode 100644
index 000000000..a7fa61c79
--- /dev/null
+++ b/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.1/disable-pre-ANSI-compilers.patch
@@ -0,0 +1,16 @@
1Upstream-Status: Pending
2
3disable pre-ANSI compilers
4
5Signed-off-by: Chunrong Guo <b40290@freescale.com>
6--- inetutils-1.9.1/configure.ac 2012-01-06 22:05:05.000000000 +0800
7+++ inetutils-1.9.1/configure.ac 2012-11-12 14:05:30.756957063 +0800
8@@ -586,7 +586,7 @@
9 #include <arpa/tftp.h>])
10
11 ### Checks for compiler characteristics.
12-AM_C_PROTOTYPES dnl FIXME: Does inetutils even compile on pre-ANSI compilers?
13+#AM_C_PROTOTYPES dnl FIXME: Does inetutils even compile on pre-ANSI compilers?
14 AC_C_CONST
15
16 dnl See if `weak refs' are possible; these make it possible (with shared
diff --git a/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.1/fix-disable-ipv6.patch b/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.1/fix-disable-ipv6.patch
new file mode 100644
index 000000000..bd3ae476b
--- /dev/null
+++ b/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.1/fix-disable-ipv6.patch
@@ -0,0 +1,60 @@
1Upstream: http://www.mail-archive.com/bug-inetutils@gnu.org/msg02103.html
2
3Upstream-Status: Pending
4
5diff -ur inetutils-1.8.orig/ping/ping_common.h inetutils-1.8/ping/ping_common.h
6--- inetutils-1.8.orig/ping/ping_common.h 2010-05-15 20:55:47.000000000 +0930
7+++ inetutils-1.8/ping/ping_common.h 2010-12-01 12:19:08.000000000 +1030
8@@ -17,10 +17,14 @@
9 You should have received a copy of the GNU General Public License
10 along with this program. If not, see `http://www.gnu.org/licenses/'. */
11
12+#include <config.h>
13+
14 #include <netinet/in_systm.h>
15 #include <netinet/in.h>
16 #include <netinet/ip.h>
17+#ifdef HAVE_IPV6
18 #include <netinet/icmp6.h>
19+#endif
20 #include <icmp.h>
21 #include <error.h>
22 #include <progname.h>
23@@ -66,13 +70,19 @@
24 (t).tv_usec = ((i)%PING_PRECISION)*(1000000/PING_PRECISION) ;\
25 } while (0)
26
27+#ifdef HAVE_IPV6
28 /* Not sure about this step*/
29 #define _PING_BUFLEN(p, USE_IPV6) ((USE_IPV6)? ((p)->ping_datalen + sizeof (struct icmp6_hdr)) : \
30 ((p)->ping_datalen + sizeof (icmphdr_t)))
31+#else
32+#define _PING_BUFLEN(p, USE_IPV6) ((p)->ping_datalen + sizeof (icmphdr_t))
33+#endif
34
35+#ifdef HAVE_IPV6
36 typedef int (*ping_efp6) (int code, void *closure, struct sockaddr_in6 * dest,
37 struct sockaddr_in6 * from, struct icmp6_hdr * icmp,
38 int datalen);
39+#endif
40
41 typedef int (*ping_efp) (int code,
42 void *closure,
43@@ -81,13 +91,17 @@
44 struct ip * ip, icmphdr_t * icmp, int datalen);
45
46 union event {
47+#ifdef HAVE_IPV6
48 ping_efp6 handler6;
49+#endif
50 ping_efp handler;
51 };
52
53 union ping_address {
54 struct sockaddr_in ping_sockaddr;
55+#ifdef HAVE_IPV6
56 struct sockaddr_in6 ping_sockaddr6;
57+#endif
58 };
59
60 typedef struct ping_data PING;
diff --git a/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.1/inetutils-1.8-0001-printf-parse-pull-in-features.h-for-__GLIBC__.patch b/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.1/inetutils-1.8-0001-printf-parse-pull-in-features.h-for-__GLIBC__.patch
new file mode 100644
index 000000000..3da4e9f55
--- /dev/null
+++ b/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.1/inetutils-1.8-0001-printf-parse-pull-in-features.h-for-__GLIBC__.patch
@@ -0,0 +1,29 @@
1From 552a7d64ad4a7188a9b7cd89933ae7caf7ebfe90 Mon Sep 17 00:00:00 2001
2From: Mike Frysinger <vapier at gentoo.org>
3Date: Thu, 18 Nov 2010 16:59:14 -0500
4Subject: [PATCH gnulib] printf-parse: pull in features.h for __GLIBC__
5
6Upstream-Status: Pending
7
8Signed-off-by: Mike Frysinger <vapier at gentoo.org>
9---
10 lib/printf-parse.h | 3 +++
11 1 files changed, 3 insertions(+), 0 deletions(-)
12
13diff --git a/lib/printf-parse.h b/lib/printf-parse.h
14index 67a4a2a..3bd6152 100644
15--- a/lib/printf-parse.h
16+++ b/lib/printf-parse.h
17@@ -25,6 +25,9 @@
18
19 #include "printf-args.h"
20
21+#ifdef HAVE_FEATURES_H
22+# include <features.h> /* for __GLIBC__ */
23+#endif
24
25 /* Flags */
26 #define FLAG_GROUP 1 /* ' flag */
27--
281.7.3.2
29
diff --git a/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.1/inetutils-1.8-0003-wchar.patch b/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.1/inetutils-1.8-0003-wchar.patch
new file mode 100644
index 000000000..b13bb9229
--- /dev/null
+++ b/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.1/inetutils-1.8-0003-wchar.patch
@@ -0,0 +1,14 @@
1Upstream-Status: Pending
2
3--- inetutils-1.8/lib/wchar.in.h
4+++ inetutils-1.8/lib/wchar.in.h
5@@ -70,6 +70,9 @@
6 /* The include_next requires a split double-inclusion guard. */
7 #if @HAVE_WCHAR_H@
8 # @INCLUDE_NEXT@ @NEXT_WCHAR_H@
9+#else
10+# include <stddef.h>
11+# define MB_CUR_MAX 1
12 #endif
13
14 #undef _GL_ALREADY_INCLUDING_WCHAR_H
diff --git a/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.1/remove-gets.patch b/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.1/remove-gets.patch
new file mode 100644
index 000000000..61d16e3a7
--- /dev/null
+++ b/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.1/remove-gets.patch
@@ -0,0 +1,21 @@
1Uptream-Status: Pending
2
3remove gets function
4
5Signed-off-by: Chunrong Guo <b40290@freescale.com>
6--- inetutils-1.9.1.org/lib/stdio.in.h 2012-01-06 22:11:13.000000000 +0800
7+++ inetutils-1.9.1/lib/stdio.in.h 2012-11-12 14:30:49.044958001 +0800
8@@ -715,9 +715,13 @@
9 /* It is very rare that the developer ever has full control of stdin,
10 so any use of gets warrants an unconditional warning. Assume it is
11 always declared, since it is required by C89. */
12+#if defined gets
13+#undef gets
14 _GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
15 #endif
16
17+#endif
18+
19
20 #if @GNULIB_OBSTACK_PRINTF@ || @GNULIB_OBSTACK_PRINTF_POSIX@
21 struct obstack;
diff --git a/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.1/version.patch b/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.1/version.patch
new file mode 100644
index 000000000..ac3181ddb
--- /dev/null
+++ b/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.1/version.patch
@@ -0,0 +1,17 @@
1Upstream-Status: Pending
2
3remove m4_esyscmd function
4
5Signed-off-by: Chunrong Guo <b40290@freescale.com>
6--- inetutils-1.9.1/configure.ac 2012-01-06 22:05:05.000000000 +0800
7+++ inetutils-1.9.1/configure.ac 2012-11-12 14:01:11.732957019 +0800
8@@ -20,8 +20,7 @@
9
10 AC_PREREQ(2.59)
11
12-AC_INIT([GNU inetutils],
13- m4_esyscmd([build-aux/git-version-gen .tarball-version 's/inetutils-/v/;s/_/./g']),
14+AC_INIT([GNU inetutils],[1.9.1],
15 [bug-inetutils@gnu.org])
16
17 AC_CONFIG_SRCDIR([src/inetd.c])
diff --git a/meta-networking/recipes-connectivity/inetutils/inetutils_1.9.1.bb b/meta-networking/recipes-connectivity/inetutils/inetutils_1.9.1.bb
new file mode 100644
index 000000000..81457d7d6
--- /dev/null
+++ b/meta-networking/recipes-connectivity/inetutils/inetutils_1.9.1.bb
@@ -0,0 +1,63 @@
1DESCRIPTION = "The GNU inetutils are a collection of common \
2networking utilities and servers including ftp, ftpd, rcp, \
3rexec, rlogin, rlogind, rsh, rshd, syslog, syslogd, talk, \
4talkd, telnet, telnetd, tftp, tftpd, and uucpd."
5SECTION = "libs"
6DEPENDS = "ncurses"
7LICENSE = "GPLv3"
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=0c7051aef9219dc7237f206c5c4179a7"
10
11
12SRC_URI = "${GNU_MIRROR}/inetutils/inetutils-${PV}.tar.gz \
13 file://disable-pre-ANSI-compilers.patch \
14 file://version.patch \
15 file://remove-gets.patch \
16 file://inetutils-1.8-0001-printf-parse-pull-in-features.h-for-__GLIBC__.patch \
17 file://inetutils-1.8-0003-wchar.patch \
18 file://fix-disable-ipv6.patch \
19"
20SRC_URI[md5sum] = "944f7196a2b3dba2d400e9088576000c"
21SRC_URI[sha256sum] = "02a9ebde8a198cb85f87545b9d88fb103a183958139864a85fe9e027ad79ff2b"
22
23inherit autotools gettext
24
25noipv6="${@base_contains('DISTRO_FEATURES', 'ipv6', '', '--disable-ipv6 gl_cv_socket_ipv6=no', d)}"
26EXTRA_OECONF = "--with-ncurses-include-dir=${STAGING_INCDIR} \
27 --with-path-procnet-dev=/proc/net/dev \
28 ${noipv6} \
29 "
30
31do_configure_prepend () {
32 export HELP2MAN='true'
33 cp ${STAGING_DATADIR_NATIVE}/gettext/config.rpath ${S}/build-aux/config.rpath
34 rm -f ${S}/glob/configure*
35}
36
37do_install () {
38 autotools_do_install
39 install -d ${D}${base_sbindir} ${D}${base_bindir}
40 mv ${D}${bindir}/tftp ${D}${bindir}/tftp.${PN}
41 mv ${D}${bindir}/telnet ${D}${bindir}/telnet.${PN}
42 mv ${D}${bindir}/logger ${D}${bindir}/logger.${PN}
43 mv ${D}${bindir}/traceroute ${D}${bindir}/traceroute.${PN}
44 mv ${D}${bindir}/hostname ${D}${base_bindir}/hostname.${PN}
45 mv ${D}${bindir}/ifconfig ${D}${base_sbindir}/ifconfig.${PN}
46}
47
48pkg_postinst_${PN} () {
49 update-alternatives --install ${bindir}/tftp tftp tftp.${PN} 100
50 update-alternatives --install ${bindir}/telnet telnet telnet.${PN} 100
51 update-alternatives --install ${bindir}/logger logger logger.${PN} 100
52 update-alternatives --install ${bindir}/traceroute traceroute traceroute.${PN} 100
53 update-alternatives --install ${base_bindir}/hostname hostname hostname.${PN} 100
54 update-alternatives --install ${base_sbindir}/ifconfig ifconfig ifconfig.${PN} 100
55}
56
57pkg_prerm_${PN} () {
58 update-alternatives --remove tftp tftp.${PN}
59 update-alternatives --remove telnet telnet.${PN}
60 update-alternatives --remove logger logger.${PN}
61 update-alternatives --remove traceroute traceroute.${PN}
62 update-alternatives --remove ifconfig ifconfig.${PN}
63}