summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/snort/snort3_git.bb
diff options
context:
space:
mode:
authorKhawaja Shaheryar <behzadshaheryar@gmail.com>2024-02-13 20:18:06 +0500
committerKhem Raj <raj.khem@gmail.com>2024-02-21 19:59:51 -0800
commitbe6deab87e96fe93f12676ba42a2ed3fa89308dc (patch)
tree924193120668b82c47d8aaf61afac4d560da9fab /meta-networking/recipes-connectivity/snort/snort3_git.bb
parent26511bb42a0965dbeafd9efc8d00a52e26dc2c11 (diff)
downloadmeta-openembedded-be6deab87e96fe93f12676ba42a2ed3fa89308dc.tar.gz
snort: add snort3 initial recipe
I am adding this recipe as snort2 is legacy now. See more: https://github.com/snort3/snort3 Signed-off-by: Khawaja Shaheryar <behzadshaheryar@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-connectivity/snort/snort3_git.bb')
-rw-r--r--meta-networking/recipes-connectivity/snort/snort3_git.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/snort/snort3_git.bb b/meta-networking/recipes-connectivity/snort/snort3_git.bb
new file mode 100644
index 000000000..f40a1d7d6
--- /dev/null
+++ b/meta-networking/recipes-connectivity/snort/snort3_git.bb
@@ -0,0 +1,34 @@
1SUMMARY = "snort3"
2DESCRIPTION = "snort3 - a free lightweight network intrusion detection system for UNIX and Windows."
3HOMEPAGE = "http://www.snort.org/"
4SECTION = "net"
5LICENSE = "GPL-2.0-only"
6LIC_FILES_CHKSUM = "file://COPYING;md5=78fa8ef966b48fbf9095e13cc92377c5"
7
8PV = "3+git${SRCPV}"
9
10DEPENDS = "flex hwloc libdaq libdnet libpcap libpcre libtirpc libunwind luajit zlib"
11
12SRC_URI = "git://github.com/snort3/snort3.git;protocol=https;branch=master"
13SRCREV = "e1760a8dbb829bb3fcf1a340ab6cc4bb80a47ecd"
14
15S = "${WORKDIR}/git"
16
17PACKAGES =+ "${PN}-scripts"
18
19inherit cmake pkgconfig
20
21FILES:${PN} += "${libdir}/snort/daq/*.so"
22
23FILES:${PN}-scripts = "${bindir}/appid_detector_builder.sh"
24
25RDEPENDS:${PN}-scripts += "bash"
26
27# mips64/ppc/ppc64/riscv64/riscv32 is not supported in this release
28COMPATIBLE_HOST:mipsarchn32 = "null"
29COMPATIBLE_HOST:mipsarchn64 = "null"
30COMPATIBLE_HOST:powerpc = "null"
31COMPATIBLE_HOST:powerpc64 = "null"
32COMPATIBLE_HOST:powerpc64le = "null"
33COMPATIBLE_HOST:riscv64 = "null"
34COMPATIBLE_HOST:riscv32 = "null"