diff options
author | Wang Mingyu <wangmy@fujitsu.com> | 2022-02-23 07:44:46 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-02-23 09:25:19 -0800 |
commit | 6ed9d2d546ae1a70df148483f4a0f28ce429e90a (patch) | |
tree | 8ea0e3072077b523434698eab9f246a165eda305 /meta-networking/recipes-connectivity/netplan/netplan_0.104.bb | |
parent | 124c19a0a661615468482f82b52d6c254517a4ff (diff) | |
download | meta-openembedded-6ed9d2d546ae1a70df148483f4a0f28ce429e90a.tar.gz |
netplan: upgrade 0.103 -> 0.104
refresh patches for 0.104:
0001-Makefile-do-not-use-Werror.patch
0001-don-t-fail-if-GLOB_BRACE-is-not-defined.patch
0001-parse-nm-fix-32bit-format-string.patch
removed since it's included in 0.104
Changelog:
=========
Enable embedded-switch-mode setting on SmartNICs (#253)
Permit multiple patterns for the driver globs in match (#202), LP#1918421
Improve routing capabilities (#248), LP#1892272, LP#1805038
Support additional link offload options for networkd (#225) (#242), LP#1771740
Consolidate enum-to-string arrays (#230)
Handle differing ip6-privacy default value for NetworkManager (#263)
YAML state tracking (--state rootdir) for DBus API and netplan try (#231), LP#1943120
Support ConfigureWithoutCarrier (ignore-carrier) for networkd (#215)
Move primary git branch master to main
Documentation improvements (#226)
Compatibility for glib-2.70 (#235)
Cleanup Makefile, install only public headers
Improve test reliability & enable integration testing CI for autopkgtests
Netplan get to use the libnetplan parser (#252)
libnetplan:
- introduce the notion of NetplanState (#232)
- use an explicit parser context (#233)
- expose coherent generator APIs (#239)
- improve overall error handling (#234)
- consolidation of YAML parsing into the library (#241, #249, #250, #251)
Restrict the symbol export to a determined public API (#227)
- WARNING: We dropped some internal symbols from the API that we know
have no external consumers (that we are aware of)
- 0.103: _serialize_yaml, contains_netdef_type, tmp, validate_default_route_consistency
- 0.102: cur_filename, netplan_netdef_new
- 0.100: address_option_handlers, is_hostname, validate_ovs_target, wireguard_peer_handlers
- 0.99: current_file, is_ip4_address, is_ip6_address, missing_id,
missing_ids_found, parser_error, validate_backend_rules, validate_netdef_grammar,
yaml_error
Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-connectivity/netplan/netplan_0.104.bb')
-rw-r--r-- | meta-networking/recipes-connectivity/netplan/netplan_0.104.bb | 63 |
1 files changed, 63 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/netplan/netplan_0.104.bb b/meta-networking/recipes-connectivity/netplan/netplan_0.104.bb new file mode 100644 index 000000000..6a32f55d4 --- /dev/null +++ b/meta-networking/recipes-connectivity/netplan/netplan_0.104.bb | |||
@@ -0,0 +1,63 @@ | |||
1 | SUMMARY = "The network configuration abstraction renderer" | ||
2 | DESCRIPTION = "Netplan is a utility for easily configuring networking on a \ | ||
3 | linux system. You simply create a YAML description of the required network \ | ||
4 | interfaces and what each should be configured to do. From this description \ | ||
5 | Netplan will generate all the necessary configuration for your chosen renderer \ | ||
6 | tool." | ||
7 | HOMEPAGE = "https://netplan.io" | ||
8 | SECTION = "net/misc" | ||
9 | |||
10 | LICENSE = "GPLv3" | ||
11 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | ||
12 | |||
13 | S = "${WORKDIR}/git" | ||
14 | SRCREV = "3e522b7255310bdecca6c781137741dfc4abc021" | ||
15 | PV = "0.104" | ||
16 | |||
17 | SRC_URI = "git://github.com/CanonicalLtd/netplan.git;branch=main;protocol=https \ | ||
18 | file://0001-Makefile-do-not-use-Werror.patch \ | ||
19 | " | ||
20 | |||
21 | SRC_URI:append:libc-musl = " file://0001-don-t-fail-if-GLOB_BRACE-is-not-defined.patch" | ||
22 | |||
23 | DEPENDS = "glib-2.0 libyaml ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" | ||
24 | |||
25 | RDEPENDS:${PN} = "python3 python3-core python3-pyyaml python3-netifaces python3-nose python3-coverage python3-pycodestyle python3-pyflakes util-linux-libuuid libnetplan" | ||
26 | |||
27 | inherit pkgconfig systemd | ||
28 | |||
29 | TARGET_CC_ARCH += "${LDFLAGS}" | ||
30 | |||
31 | EXTRA_OEMAKE = "generate netplan/_features.py" | ||
32 | EXTRA_OEMAKE =+ "${@bb.utils.contains('DISTRO_FEATURES','systemd','netplan-dbus dbus/io.netplan.Netplan.service','',d)}" | ||
33 | |||
34 | do_install() { | ||
35 | install -d ${D}${sbindir} ${D}${libdir} ${D}${base_libdir}/netplan ${D}${datadir}/netplan/netplan/cli/commands ${D}${sysconfdir}/netplan | ||
36 | install -m 755 ${S}/generate ${D}${base_libdir}/netplan/ | ||
37 | install -m 644 ${S}/netplan/*.py ${D}${datadir}/netplan/netplan | ||
38 | install -m 644 ${S}/netplan/cli/*.py ${D}${datadir}/netplan/netplan/cli | ||
39 | install -m 644 ${S}/netplan/cli/commands/*.py ${D}${datadir}/netplan/netplan/cli/commands | ||
40 | install -m 755 ${S}/src/netplan.script ${D}${datadir}/netplan/ | ||
41 | ln -srf ${D}${datadir}/netplan/netplan.script ${D}${sbindir}/netplan | ||
42 | sed -i -e "s#/lib/netplan/generate#${base_libdir}/netplan/generate#" ${D}${datadir}/netplan/netplan/cli/utils.py | ||
43 | |||
44 | install -d ${D}/${systemd_unitdir}/system ${D}${systemd_unitdir}/system-generators | ||
45 | ln -srf ${D}/${base_libdir}/netplan/generate ${D}${systemd_unitdir}/system-generators | ||
46 | |||
47 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then | ||
48 | install -d ${D}${datadir}/dbus-1/system.d ${D}${datadir}/dbus-1/system-services | ||
49 | install -m 755 ${S}/netplan-dbus ${D}${base_libdir}/netplan | ||
50 | install -m 644 ${S}/dbus/io.netplan.Netplan.conf ${D}${datadir}/dbus-1/system.d | ||
51 | install -m 644 ${S}/dbus/io.netplan.Netplan.service ${D}${datadir}/dbus-1/system-services | ||
52 | sed -i -e "s#^Exec=/lib/#Exec=${base_libdir}/#" ${D}${datadir}/dbus-1/system-services/io.netplan.Netplan.service | ||
53 | fi | ||
54 | |||
55 | install -m 755 ${S}/libnetplan.so.0.0 ${D}${libdir} | ||
56 | ln -rfs ${D}${libdir}/libnetplan.so.0.0 ${D}${libdir}/libnetplan.so | ||
57 | } | ||
58 | |||
59 | PACKAGES += "${PN}-dbus libnetplan" | ||
60 | |||
61 | FILES:libnetplan = "${libdir}/libnetplan.so.0.0" | ||
62 | FILES:${PN} = "${sbindir} ${base_libdir}/netplan/generate ${datadir}/netplan ${sysconfdir}/netplan ${systemd_unitdir}" | ||
63 | FILES:${PN}-dbus = "${base_libdir}/netplan/netplan-dbus ${datadir}/dbus-1" | ||