diff options
author | Khem Raj <raj.khem@gmail.com> | 2021-06-03 19:10:25 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-06-03 19:12:33 -0700 |
commit | 693ec65bf279c2fa1af9f12a019c58c1a5c23d17 (patch) | |
tree | 75d343bf4da19d558f80126e8c0364c69ef31337 /meta-networking/recipes-connectivity/mbedtls/mbedtls_2.26.0.bb | |
parent | e3ea357102cb608fd9640408ff3cb4e394669c3c (diff) | |
download | meta-openembedded-693ec65bf279c2fa1af9f12a019c58c1a5c23d17.tar.gz |
mbedtls: Upgrade to 2.26.0
https://github.com/ARMmbed/mbedtls/releases/tag/v2.26.0
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-connectivity/mbedtls/mbedtls_2.26.0.bb')
-rw-r--r-- | meta-networking/recipes-connectivity/mbedtls/mbedtls_2.26.0.bb | 44 |
1 files changed, 44 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.26.0.bb b/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.26.0.bb new file mode 100644 index 000000000..8c2457ce0 --- /dev/null +++ b/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.26.0.bb | |||
@@ -0,0 +1,44 @@ | |||
1 | SUMMARY = "Lightweight crypto and SSL/TLS library" | ||
2 | DESCRIPTION = "mbedtls is a lean open source crypto library \ | ||
3 | for providing SSL and TLS support in your programs. It offers \ | ||
4 | an intuitive API and documented header files, so you can actually \ | ||
5 | understand what the code does. It features: \ | ||
6 | \ | ||
7 | - Symmetric algorithms, like AES, Blowfish, Triple-DES, DES, ARC4, \ | ||
8 | Camellia and XTEA \ | ||
9 | - Hash algorithms, like SHA-1, SHA-2, RIPEMD-160 and MD5 \ | ||
10 | - Entropy pool and random generators, like CTR-DRBG and HMAC-DRBG \ | ||
11 | - Public key algorithms, like RSA, Elliptic Curves, Diffie-Hellman, \ | ||
12 | ECDSA and ECDH \ | ||
13 | - SSL v3 and TLS 1.0, 1.1 and 1.2 \ | ||
14 | - Abstraction layers for ciphers, hashes, public key operations, \ | ||
15 | platform abstraction and threading \ | ||
16 | " | ||
17 | |||
18 | HOMEPAGE = "https://tls.mbed.org/" | ||
19 | |||
20 | LICENSE = "Apache-2.0" | ||
21 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" | ||
22 | |||
23 | SECTION = "libs" | ||
24 | |||
25 | S = "${WORKDIR}/git" | ||
26 | SRCREV = "e483a77c85e1f9c1dd2eb1c5a8f552d2617fe400" | ||
27 | SRC_URI = "git://github.com/ARMmbed/mbedtls.git;protocol=https;branch=development" | ||
28 | SRC_URI += "file://0001-ssl_tls-Increase-size-of-padbuf-to-64.patch" | ||
29 | |||
30 | inherit cmake | ||
31 | |||
32 | PACKAGECONFIG ??= "shared-libs programs" | ||
33 | PACKAGECONFIG[shared-libs] = "-DUSE_SHARED_MBEDTLS_LIBRARY=ON,-DUSE_SHARED_MBEDTLS_LIBRARY=OFF" | ||
34 | PACKAGECONFIG[programs] = "-DENABLE_PROGRAMS=ON,-DENABLE_PROGRAMS=OFF" | ||
35 | |||
36 | EXTRA_OECMAKE = "-DENABLE_TESTING=OFF -DLIB_INSTALL_DIR:STRING=${libdir}" | ||
37 | |||
38 | PROVIDES += "polarssl" | ||
39 | RPROVIDES_${PN} = "polarssl" | ||
40 | |||
41 | PACKAGES =+ "${PN}-programs" | ||
42 | FILES_${PN}-programs = "${bindir}/" | ||
43 | |||
44 | BBCLASSEXTEND = "native nativesdk" | ||