diff options
author | Khem Raj <raj.khem@gmail.com> | 2021-03-02 14:33:38 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-03-03 11:08:29 -0800 |
commit | fa0ef82344b8295040aa3fb49c8ec8da86b7ad07 (patch) | |
tree | 18ff7b9ba8739294f26ee8bb50228021ee02276a /meta-multimedia | |
parent | 1498b3407fa723a984f58e97464caa11cd4d4c40 (diff) | |
download | meta-openembedded-fa0ef82344b8295040aa3fb49c8ec8da86b7ad07.tar.gz |
vlc: Fix build with gcc 11
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Cc: Andreas Müller <schnitzeltony@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r-- | meta-multimedia/recipes-multimedia/vlc/vlc/0001-include-limits-header.patch | 43 | ||||
-rw-r--r-- | meta-multimedia/recipes-multimedia/vlc/vlc_3.0.12.bb | 1 |
2 files changed, 44 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc/0001-include-limits-header.patch b/meta-multimedia/recipes-multimedia/vlc/vlc/0001-include-limits-header.patch new file mode 100644 index 000000000..e1383c826 --- /dev/null +++ b/meta-multimedia/recipes-multimedia/vlc/vlc/0001-include-limits-header.patch | |||
@@ -0,0 +1,43 @@ | |||
1 | From 1068c7451855c3f9acde9af265b5a790073b1641 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 2 Mar 2021 14:28:27 -0800 | ||
4 | Subject: [PATCH] include <limits> header | ||
5 | |||
6 | Fixes | ||
7 | SegmentInformation.cpp:397:49: error: '::max' has not been declared; d | ||
8 | id you mean 'std::max'? | ||
9 | |||
10 | Upstream-Status: Pending | ||
11 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
12 | --- | ||
13 | modules/demux/adaptive/playlist/SegmentInformation.cpp | 1 + | ||
14 | modules/demux/hls/playlist/Parser.cpp | 1 + | ||
15 | 2 files changed, 2 insertions(+) | ||
16 | |||
17 | diff --git a/modules/demux/adaptive/playlist/SegmentInformation.cpp b/modules/demux/adaptive/playlist/SegmentInformation.cpp | ||
18 | index 344e155..8eeb054 100644 | ||
19 | --- a/modules/demux/adaptive/playlist/SegmentInformation.cpp | ||
20 | +++ b/modules/demux/adaptive/playlist/SegmentInformation.cpp | ||
21 | @@ -34,6 +34,7 @@ | ||
22 | |||
23 | #include <algorithm> | ||
24 | #include <cassert> | ||
25 | +#include <limits> | ||
26 | |||
27 | using namespace adaptive::playlist; | ||
28 | |||
29 | diff --git a/modules/demux/hls/playlist/Parser.cpp b/modules/demux/hls/playlist/Parser.cpp | ||
30 | index 67110e4..7439699 100644 | ||
31 | --- a/modules/demux/hls/playlist/Parser.cpp | ||
32 | +++ b/modules/demux/hls/playlist/Parser.cpp | ||
33 | @@ -42,6 +42,7 @@ | ||
34 | #include <map> | ||
35 | #include <cctype> | ||
36 | #include <algorithm> | ||
37 | +#include <limits> | ||
38 | |||
39 | using namespace adaptive; | ||
40 | using namespace adaptive::playlist; | ||
41 | -- | ||
42 | 2.30.1 | ||
43 | |||
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc_3.0.12.bb b/meta-multimedia/recipes-multimedia/vlc/vlc_3.0.12.bb index 046c059fb..c0074aabb 100644 --- a/meta-multimedia/recipes-multimedia/vlc/vlc_3.0.12.bb +++ b/meta-multimedia/recipes-multimedia/vlc/vlc_3.0.12.bb | |||
@@ -25,6 +25,7 @@ SRC_URI = "http://download.videolan.org/pub/videolan/${BPN}/${PV}/${BP}.tar.xz \ | |||
25 | file://0003-fix-luaL-checkint.patch \ | 25 | file://0003-fix-luaL-checkint.patch \ |
26 | file://0004-Use-packageconfig-to-detect-mmal-support.patch \ | 26 | file://0004-Use-packageconfig-to-detect-mmal-support.patch \ |
27 | file://0005-linux-thread-Use-SYS_futex-instead-of-__NR_futex.patch \ | 27 | file://0005-linux-thread-Use-SYS_futex-instead-of-__NR_futex.patch \ |
28 | file://0001-include-limits-header.patch \ | ||
28 | " | 29 | " |
29 | SRC_URI[sha256sum] = "eff458f38a92126094f44f2263c2bf2c7cdef271b48192d0fe7b1726388cf879" | 30 | SRC_URI[sha256sum] = "eff458f38a92126094f44f2263c2bf2c7cdef271b48192d0fe7b1726388cf879" |
30 | 31 | ||