summaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authorMarkus Volk <f_l_k@t-online.de>2022-05-22 10:48:51 +0200
committerKhem Raj <raj.khem@gmail.com>2022-05-24 08:39:45 -0700
commitadb282242792cbad88b3401929e8e3a2f4167d1a (patch)
tree297d932a60bfeb752eda71497abcd66eed178ff8 /meta-multimedia
parenteb1b26893b63ee1c8da2579e6187b9433f3e36f5 (diff)
downloadmeta-openembedded-adb282242792cbad88b3401929e8e3a2f4167d1a.tar.gz
pipewire: reduce native/nativesdk dependencies; add backport patch
- pipewire is by default built with lots of dependencies. Reduce them for native/nativesdk - add a backport patch to fix pipewire support in libsdl2 - allow native/nativesdk build Signed-off-by: Markus Volk <f_l_k@t-online.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-multimedia/pipewire/pipewire/0001-spa-fix-c90-header-include.patch47
-rw-r--r--meta-multimedia/recipes-multimedia/pipewire/pipewire_0.3.50.bb9
2 files changed, 54 insertions, 2 deletions
diff --git a/meta-multimedia/recipes-multimedia/pipewire/pipewire/0001-spa-fix-c90-header-include.patch b/meta-multimedia/recipes-multimedia/pipewire/pipewire/0001-spa-fix-c90-header-include.patch
new file mode 100644
index 000000000..ad6448a10
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/pipewire/pipewire/0001-spa-fix-c90-header-include.patch
@@ -0,0 +1,47 @@
1From d3ea3142e1a4de206e616bc18f63a529e6b4986a Mon Sep 17 00:00:00 2001
2From: psykose <alice@ayaya.dev>
3Date: Wed, 13 Apr 2022 21:57:49 +0000
4Subject: [PATCH 001/154] spa: fix c90 header include
5
6placing declarations after code is invalid under ISO c90
7
8Fixes !1211
9
10Patch-Status: Backport
11---
12 spa/include/spa/utils/string.h | 6 ++++--
13 1 file changed, 4 insertions(+), 2 deletions(-)
14
15diff --git a/spa/include/spa/utils/string.h b/spa/include/spa/utils/string.h
16index e80434537..43d19616c 100644
17--- a/spa/include/spa/utils/string.h
18+++ b/spa/include/spa/utils/string.h
19@@ -276,10 +276,11 @@ static inline int spa_scnprintf(char *buffer, size_t size, const char *format, .
20 static inline float spa_strtof(const char *str, char **endptr)
21 {
22 static locale_t locale = NULL;
23+ locale_t prev;
24 float v;
25 if (SPA_UNLIKELY(locale == NULL))
26 locale = newlocale(LC_ALL_MASK, "C", NULL);
27- locale_t prev = uselocale(locale);
28+ prev = uselocale(locale);
29 v = strtof(str, endptr);
30 uselocale(prev);
31 return v;
32@@ -319,10 +320,11 @@ static inline bool spa_atof(const char *str, float *val)
33 static inline double spa_strtod(const char *str, char **endptr)
34 {
35 static locale_t locale = NULL;
36+ locale_t prev;
37 double v;
38 if (SPA_UNLIKELY(locale == NULL))
39 locale = newlocale(LC_ALL_MASK, "C", NULL);
40- locale_t prev = uselocale(locale);
41+ prev = uselocale(locale);
42 v = strtod(str, endptr);
43 uselocale(prev);
44 return v;
45--
462.25.1
47
diff --git a/meta-multimedia/recipes-multimedia/pipewire/pipewire_0.3.50.bb b/meta-multimedia/recipes-multimedia/pipewire/pipewire_0.3.50.bb
index 0d725b9ee..0f527c0a5 100644
--- a/meta-multimedia/recipes-multimedia/pipewire/pipewire_0.3.50.bb
+++ b/meta-multimedia/recipes-multimedia/pipewire/pipewire_0.3.50.bb
@@ -14,7 +14,10 @@ LIC_FILES_CHKSUM = " \
14DEPENDS = "dbus ncurses" 14DEPENDS = "dbus ncurses"
15 15
16SRCREV = "64cf5e80e6240284e6b757907b900507fe56f1b5" 16SRCREV = "64cf5e80e6240284e6b757907b900507fe56f1b5"
17SRC_URI = "git://gitlab.freedesktop.org/pipewire/pipewire.git;branch=master;protocol=https" 17SRC_URI = " \
18 git://gitlab.freedesktop.org/pipewire/pipewire.git;branch=master;protocol=https \
19 file://0001-spa-fix-c90-header-include.patch \
20"
18 21
19S = "${WORKDIR}/git" 22S = "${WORKDIR}/git"
20 23
@@ -69,7 +72,7 @@ EXTRA_OEMESON += " \
69 -Dlegacy-rtkit=false \ 72 -Dlegacy-rtkit=false \
70" 73"
71 74
72PACKAGECONFIG ??= "\ 75PACKAGECONFIG:class-target ??= "\
73 ${@bb.utils.contains('DISTRO_FEATURES', 'zeroconf', 'avahi', '', d)} \ 76 ${@bb.utils.contains('DISTRO_FEATURES', 'zeroconf', 'avahi', '', d)} \
74 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \ 77 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
75 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd systemd-system-service', '', d)} \ 78 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd systemd-system-service', '', d)} \
@@ -335,3 +338,5 @@ FILES:${PN}-v4l2 += " \
335FILES:gstreamer1.0-pipewire = " \ 338FILES:gstreamer1.0-pipewire = " \
336 ${libdir}/gstreamer-1.0/* \ 339 ${libdir}/gstreamer-1.0/* \
337" 340"
341
342BBCLASSEXTEND = "native nativesdk"