diff options
author | Tim Orling <ticotimo@gmail.com> | 2014-10-11 19:47:24 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-10-14 11:48:57 +0200 |
commit | 95d78c37107fe6f11238a020fb5ce11ce76e9635 (patch) | |
tree | 5403b75f9a614e49ee56438860ee3a83fdc0fb6a /meta-multimedia | |
parent | f48e71ec3e3401231eb66fc810e7c18f0e659b47 (diff) | |
download | meta-openembedded-95d78c37107fe6f11238a020fb5ce11ce76e9635.tar.gz |
vlc: make opencv explicitly configurable
World builds are failing due to change in opencv in API.
Since vlc is only using opencv as an example and a filter, disable by default.
Revisit when upstream adapts to new opencv API.
Signed-off-by: Tim Orling <TicoTimo@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-multimedia')
3 files changed, 32 insertions, 1 deletions
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc.inc b/meta-multimedia/recipes-multimedia/vlc/vlc.inc index 88605dfaa7..72a93f57f7 100644 --- a/meta-multimedia/recipes-multimedia/vlc/vlc.inc +++ b/meta-multimedia/recipes-multimedia/vlc/vlc.inc | |||
@@ -10,7 +10,7 @@ DEPENDS = "libfribidi libtool libgcrypt libgcrypt-native gst-plugins-bad \ | |||
10 | tremor faad2 ffmpeg flac libxpm libxinerama fluidsynth alsa-lib \ | 10 | tremor faad2 ffmpeg flac libxpm libxinerama fluidsynth alsa-lib \ |
11 | libdvdcss libdvdread lua-native lua libidn libnotify gtk+ gnome-vfs \ | 11 | libdvdcss libdvdread lua-native lua libidn libnotify gtk+ gnome-vfs \ |
12 | libdc1394 libraw1394 avahi libjpeg-turbo xz libmodplug mpeg2dec \ | 12 | libdc1394 libraw1394 avahi libjpeg-turbo xz libmodplug mpeg2dec \ |
13 | libmtp opencv libopus orc libusb1 schroedinger taglib \ | 13 | libmtp libopus orc libusb1 schroedinger taglib \ |
14 | tiff xcb-util-keysyms samba" | 14 | tiff xcb-util-keysyms samba" |
15 | 15 | ||
16 | SRC_URI = "http://download.videolan.org/pub/videolan/${BPN}/${PV}/${BP}.tar.xz" | 16 | SRC_URI = "http://download.videolan.org/pub/videolan/${BPN}/${PV}/${BP}.tar.xz" |
@@ -50,6 +50,7 @@ PACKAGECONFIG[live555] = "--enable-live555,--disable-live555,live555" | |||
50 | PACKAGECONFIG[libass] = "--enable-libass,--disable-libass,libass" | 50 | PACKAGECONFIG[libass] = "--enable-libass,--disable-libass,libass" |
51 | PACKAGECONFIG[mkv] = "--enable-mkv,--disable-mkv,libmatroska libebml" | 51 | PACKAGECONFIG[mkv] = "--enable-mkv,--disable-mkv,libmatroska libebml" |
52 | PACKAGECONFIG[postproc] = "--enable-postproc,--disable-postproc,libpostproc" | 52 | PACKAGECONFIG[postproc] = "--enable-postproc,--disable-postproc,libpostproc" |
53 | PACKAGECONFIG[opencv] = "--enable-opencv,--disable-opencv,opencv" | ||
53 | 54 | ||
54 | do_configure_prepend() { | 55 | do_configure_prepend() { |
55 | cp ${STAGING_DATADIR}/libtool/config.* ${S}/autotools/ || true | 56 | cp ${STAGING_DATADIR}/libtool/config.* ${S}/autotools/ || true |
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc/0006-make-opencv-configurable.patch b/meta-multimedia/recipes-multimedia/vlc/vlc/0006-make-opencv-configurable.patch new file mode 100644 index 0000000000..950c09b8ae --- /dev/null +++ b/meta-multimedia/recipes-multimedia/vlc/vlc/0006-make-opencv-configurable.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | Recent opencv API changes break upstream filter and example. | ||
2 | Make opencv explicitly configurable. | ||
3 | |||
4 | Upstream-Status: Inappropriate [configuration] | ||
5 | |||
6 | Signed-off-by: Tim Orling <TicoTimo@gmail.com> | ||
7 | |||
8 | Index: vlc-2.1.4/configure.ac | ||
9 | =================================================================== | ||
10 | --- vlc-2.1.4.orig/configure.ac | ||
11 | +++ vlc-2.1.4/configure.ac | ||
12 | @@ -1693,7 +1693,16 @@ PKG_ENABLE_MODULES_VLC([BLURAY], [libblu | ||
13 | dnl | ||
14 | dnl OpenCV wrapper and example filters | ||
15 | dnl | ||
16 | -PKG_ENABLE_MODULES_VLC([OPENCV], [opencv_example opencv_wrapper], [opencv > 2.0], (OpenCV (computer vision) filter), [auto]) | ||
17 | +AC_ARG_ENABLE(opencv, | ||
18 | + [AS_HELP_STRING([--disable-opencv], | ||
19 | + [disable OpenCV computer vision filter and example (default auto)])]) | ||
20 | +if test "${enable_opencv}" != "no" | ||
21 | +then | ||
22 | + PKG_ENABLE_MODULES_VLC([OPENCV], | ||
23 | + [opencv_example opencv_wrapper], | ||
24 | + [opencv > 2.0], | ||
25 | + (OpenCV (computer vision) filter), [auto]) | ||
26 | +fi | ||
27 | |||
28 | |||
29 | dnl | ||
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc_2.1.4.bb b/meta-multimedia/recipes-multimedia/vlc/vlc_2.1.4.bb index b4047d3be4..418f77cfcf 100644 --- a/meta-multimedia/recipes-multimedia/vlc/vlc_2.1.4.bb +++ b/meta-multimedia/recipes-multimedia/vlc/vlc_2.1.4.bb | |||
@@ -8,6 +8,7 @@ SRC_URI += "file://0001-enable-subdir-objects.patch \ | |||
8 | file://0003-use-am-path-libgcrypt.patch \ | 8 | file://0003-use-am-path-libgcrypt.patch \ |
9 | file://0004-modules-gui-qt4-out-of-tree-build.patch \ | 9 | file://0004-modules-gui-qt4-out-of-tree-build.patch \ |
10 | file://0005-libpostproc-header-check.patch \ | 10 | file://0005-libpostproc-header-check.patch \ |
11 | file://0006-make-opencv-configurable.patch \ | ||
11 | " | 12 | " |
12 | 13 | ||
13 | SRC_URI[md5sum] = "7ed67d22f7425011078772bfc62ac222" | 14 | SRC_URI[md5sum] = "7ed67d22f7425011078772bfc62ac222" |