diff options
author | alperak <alperyasinak1@gmail.com> | 2023-11-12 16:13:55 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-11-12 12:18:47 -0800 |
commit | 7d1a0cd654ecaa68e27e09666744901e21b775a9 (patch) | |
tree | 7c2f554eee3cbf87bc2a6a7d81256d9eabcbe4fc /meta-multimedia | |
parent | f3d3bc7620427dc1d47daab52a81593509cf2737 (diff) | |
download | meta-openembedded-7d1a0cd654ecaa68e27e09666744901e21b775a9.tar.gz |
libebml: upgrade 1.3.0 -> 1.4.4
Changelog:
https://github.com/Matroska-Org/libebml/blob/master/NEWS.md
Signed-off-by: alperak <alperyasinak1@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia')
4 files changed, 15 insertions, 158 deletions
diff --git a/meta-multimedia/recipes-mkv/libebml/libebml/ldflags.patch b/meta-multimedia/recipes-mkv/libebml/libebml/ldflags.patch deleted file mode 100644 index a01c7544b6..0000000000 --- a/meta-multimedia/recipes-mkv/libebml/libebml/ldflags.patch +++ /dev/null | |||
@@ -1,57 +0,0 @@ | |||
1 | Use LD and obey LDFLAGS | ||
2 | |||
3 | Signed-off-by: Christopher Larson <chris_larson@mentor.com> | ||
4 | Upstream-Status: Pending | ||
5 | |||
6 | diff --git a/make/linux/Makefile b/make/linux/Makefile | ||
7 | index 391b6e3..a2ac13e 100644 | ||
8 | --- a/make/linux/Makefile | ||
9 | +++ b/make/linux/Makefile | ||
10 | @@ -64,6 +64,7 @@ objects_so:=$(patsubst %$(EXTENSION),%.lo,$(sources)) | ||
11 | WARNINGFLAGS=-Wall -Wextra -Wno-unknown-pragmas -ansi -fno-gnu-keywords -Wshadow | ||
12 | COMPILEFLAGS=$(WARNINGFLAGS) $(CXXFLAGS) $(CPPFLAGS) $(DEBUGFLAGS) $(INCLUDE) | ||
13 | DEPENDFLAGS = $(CXXFLAGS) $(INCLUDE) | ||
14 | +LINKFLAGS=$(LDFLAGS) | ||
15 | |||
16 | ifeq (Darwin,$(shell uname -s)) | ||
17 | all: staticlib | ||
18 | @@ -91,7 +92,7 @@ $(LIBRARY): $(objects) | ||
19 | $(RANLIB) $@ | ||
20 | |||
21 | $(LIBRARY_SO): $(objects_so) | ||
22 | - $(CXX) -shared -Wl,-soname,$(LIBRARY_SO_VER) -o $(LIBRARY_SO_VER) $(objects_so) | ||
23 | + $(LD) $(LINKFLAGS) -shared -Wl,-soname,$(LIBRARY_SO_VER) -o $(LIBRARY_SO_VER) $(objects_so) | ||
24 | rm -f $(LIBRARY_SO) | ||
25 | ln -s $(LIBRARY_SO_VER) $(LIBRARY_SO) | ||
26 | |||
27 | diff --git a/make/mingw32/Makefile b/make/mingw32/Makefile | ||
28 | index e5986ef..6ca16aa 100644 | ||
29 | --- a/make/mingw32/Makefile | ||
30 | +++ b/make/mingw32/Makefile | ||
31 | @@ -18,6 +18,7 @@ DEBUGFLAGS=-g -DDEBUG | ||
32 | endif | ||
33 | CROSS = | ||
34 | CXX = $(CROSS)g++ | ||
35 | +LD = $(CXX) | ||
36 | CC = $(CROSS)gcc | ||
37 | WINDRES = $(CROSS)windres | ||
38 | RANLIB = $(CROSS)ranlib | ||
39 | @@ -33,6 +34,7 @@ LIBS = libebml.a | ||
40 | endif | ||
41 | INCS = -I"$(shell pwd)/../.." | ||
42 | COMPILEFLAGS = $(DEBUGFLAGS) $(INCS) $(DLLFLAGS) $(CXXFLAGS) | ||
43 | +LINKFLAGS = $(LDFLAGS) | ||
44 | |||
45 | .PHONY: all all-before all-after clean clean-custom | ||
46 | |||
47 | @@ -54,7 +56,7 @@ libebml.a: $(OBJ) | ||
48 | $(RANLIB) $@ | ||
49 | |||
50 | libebml.dll: $(OBJ) | ||
51 | - $(CXX) -shared -Wl,--export-all -Wl,--out-implib=$@.a -o $@ $(OBJ) | ||
52 | + $(LD) $(LINKFLAGS) -shared -Wl,--export-all -Wl,--out-implib=$@.a -o $@ $(OBJ) | ||
53 | |||
54 | depend: | ||
55 | @echo Calculating dependecies: | ||
56 | -- | ||
57 | 2.8.0 | ||
diff --git a/meta-multimedia/recipes-mkv/libebml/libebml/override-uname.patch b/meta-multimedia/recipes-mkv/libebml/libebml/override-uname.patch deleted file mode 100644 index 57eb3450d6..0000000000 --- a/meta-multimedia/recipes-mkv/libebml/libebml/override-uname.patch +++ /dev/null | |||
@@ -1,42 +0,0 @@ | |||
1 | Allow override of the 'uname -s' for cross-compilation | ||
2 | |||
3 | Signed-off-by: Christopher Larson <chris_larson@mentor.com> | ||
4 | Upstream-Status: Pending | ||
5 | |||
6 | diff --git a/make/linux/Makefile b/make/linux/Makefile | ||
7 | index a2ac13e..4188bee 100644 | ||
8 | --- a/make/linux/Makefile | ||
9 | +++ b/make/linux/Makefile | ||
10 | @@ -9,9 +9,11 @@ | ||
11 | # 'make DEBUG=yes'. | ||
12 | # | ||
13 | |||
14 | +TARGET_OS ?= $(shell uname -s) | ||
15 | + | ||
16 | # Paths | ||
17 | # BeOS wants the libs and headers in /boot/home/config | ||
18 | -ifeq (BeOS,$(shell uname -s)) | ||
19 | +ifeq (BeOS,$(TARGET_OS)) | ||
20 | prefix=/boot/home/config | ||
21 | else | ||
22 | prefix=/usr/local | ||
23 | @@ -66,7 +68,7 @@ COMPILEFLAGS=$(WARNINGFLAGS) $(CXXFLAGS) $(CPPFLAGS) $(DEBUGFLAGS) $(INCLUDE) | ||
24 | DEPENDFLAGS = $(CXXFLAGS) $(INCLUDE) | ||
25 | LINKFLAGS=$(LDFLAGS) | ||
26 | |||
27 | -ifeq (Darwin,$(shell uname -s)) | ||
28 | +ifeq (Darwin,$(TARGET_OS)) | ||
29 | all: staticlib | ||
30 | else | ||
31 | all: staticlib sharedlib | ||
32 | @@ -116,7 +118,7 @@ depend: | ||
33 | $(CXX) $(DEPENDFLAGS) -MM -MT $$o $$i >> .depend ; \ | ||
34 | done | ||
35 | |||
36 | -ifeq (Darwin,$(shell uname -s)) | ||
37 | +ifeq (Darwin,$(TARGET_OS)) | ||
38 | install: install_staticlib install_headers | ||
39 | else | ||
40 | install: install_staticlib install_sharedlib install_headers | ||
41 | -- | ||
42 | 2.8.0 | ||
diff --git a/meta-multimedia/recipes-mkv/libebml/libebml_1.3.0.bb b/meta-multimedia/recipes-mkv/libebml/libebml_1.3.0.bb deleted file mode 100644 index 744486fa2a..0000000000 --- a/meta-multimedia/recipes-mkv/libebml/libebml_1.3.0.bb +++ /dev/null | |||
@@ -1,59 +0,0 @@ | |||
1 | SUMMARY = "libebml is a C++ libary to parse EBML files" | ||
2 | LICENSE = "LGPL-2.1-only" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=7fbc338309ac38fefcd64b04bb903e34" | ||
4 | |||
5 | SRC_URI = "\ | ||
6 | http://dl.matroska.org/downloads/libebml/libebml-${PV}.tar.bz2 \ | ||
7 | file://ldflags.patch \ | ||
8 | file://override-uname.patch \ | ||
9 | " | ||
10 | SRC_URI[md5sum] = "efec729bf5a51e649e1d9d1f61c0ae7a" | ||
11 | SRC_URI[sha256sum] = "83b074d6b62715aa0080406ea84d33df2e44b5d874096640233a4db49b8096de" | ||
12 | |||
13 | inherit dos2unix | ||
14 | |||
15 | LIBEBML_OS = "Unknown" | ||
16 | LIBEBML_OS_linux = "Linux" | ||
17 | LIBEBML_OS:darwin = "Darwin" | ||
18 | LIBEBML_OS:mingw32 = "Windows" | ||
19 | |||
20 | EXTRA_OEMAKE = "\ | ||
21 | 'TARGET_OS=${LIBEBML_OS}' \ | ||
22 | \ | ||
23 | 'CXX=${CXX}' \ | ||
24 | 'LD=${CXX}' \ | ||
25 | 'AR=${AR}' \ | ||
26 | 'RANLIB=${RANLIB}' \ | ||
27 | \ | ||
28 | 'DEBUGFLAGS=' \ | ||
29 | 'CPPFLAGS=${CPPFLAGS}' \ | ||
30 | 'CXXFLAGS=${CXXFLAGS}' \ | ||
31 | 'LDFLAGS=${LDFLAGS}' \ | ||
32 | \ | ||
33 | 'prefix=${prefix}' \ | ||
34 | 'libdir=${libdir}' \ | ||
35 | 'includedir=${includedir}/ebml' \ | ||
36 | " | ||
37 | |||
38 | do_compile () { | ||
39 | oe_runmake -C make/linux | ||
40 | } | ||
41 | |||
42 | do_install() { | ||
43 | cd ${S}/make/linux | ||
44 | |||
45 | install -d ${D}${libdir} | ||
46 | install -m 0644 libebml.a ${D}${libdir} | ||
47 | install -m 0755 libebml.so.* ${D}${libdir} | ||
48 | cp -R --no-dereference --preserve=mode,links -v libebml.so ${D}${libdir} | ||
49 | |||
50 | install -d ${D}${includedir}/ebml | ||
51 | for i in ../../ebml/*.h; do | ||
52 | install -m 0644 $i ${D}${includedir}/ebml | ||
53 | done | ||
54 | |||
55 | install -d ${D}${includedir}/ebml/c | ||
56 | for i in ../../ebml/c/*.h; do | ||
57 | install -m 0644 $i ${D}${includedir}/ebml/c | ||
58 | done | ||
59 | } | ||
diff --git a/meta-multimedia/recipes-mkv/libebml/libebml_1.4.4.bb b/meta-multimedia/recipes-mkv/libebml/libebml_1.4.4.bb new file mode 100644 index 0000000000..fe6436b148 --- /dev/null +++ b/meta-multimedia/recipes-mkv/libebml/libebml_1.4.4.bb | |||
@@ -0,0 +1,15 @@ | |||
1 | SUMMARY = "C++ library to parse EBML files" | ||
2 | HOMEPAGE = "https://github.com/Matroska-Org/libebml" | ||
3 | LICENSE = "LGPL-2.1-only" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=4fbd65380cdd255951079008b364516c" | ||
5 | |||
6 | SRC_URI = "git://github.com/Matroska-Org/libebml.git;branch=v1.x;protocol=https" | ||
7 | SRCREV = "8330b222fec992b295c8b2149cf70f9ff648ce4a" | ||
8 | |||
9 | S = "${WORKDIR}/git" | ||
10 | |||
11 | inherit pkgconfig cmake dos2unix | ||
12 | |||
13 | #Static library enabled by default. It has been added in case you want to use it dynamically. | ||
14 | #EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON" | ||
15 | |||